hdu 5073 Galaxy(2014acm鞍山亚洲分部 C)

简介:

主题链接:http://acm.hdu.edu.cn/showproblem.php?

pid=5073

Galaxy

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 768    Accepted Submission(s): 179
Special Judge


Problem Description
Good news for us: to release the financial pressure, the government started selling galaxies and we can buy them from now on! The first one who bought a galaxy was Tianming Yun and he gave it to Xin Cheng as a present.


To be fashionable, DRD also bought himself a galaxy. He named it Rho Galaxy. There are n stars in Rho Galaxy, and they have the same weight, namely one unit weight, and a negligible volume. They initially lie in a line rotating around their center of mass.

Everything runs well except one thing. DRD thinks that the galaxy rotates too slow. As we know, to increase the angular speed with the same angular momentum, we have to decrease the moment of inertia.

The moment of inertia I of a set of n stars can be calculated with the formula


where w i is the weight of star i, d i is the distance form star i to the mass of center.

As DRD’s friend, ATM, who bought M78 Galaxy, wants to help him. ATM creates some black holes and white holes so that he can transport stars in a negligible time. After transportation, the n stars will also rotate around their new center of mass. Due to financial pressure, ATM can only transport at most k stars. Since volumes of the stars are negligible, two or more stars can be transported to the same position.

Now, you are supposed to calculate the minimum moment of inertia after transportation.
 

Input
The first line contains an integer T (T ≤ 10), denoting the number of the test cases.

For each test case, the first line contains two integers, n(1 ≤ n ≤ 50000) and k(0 ≤ k ≤ n), as mentioned above. The next line contains n integers representing the positions of the stars. The absolute values of positions will be no more than 50000.
 

Output
For each test case, output one real number in one line representing the minimum moment of inertia. Your answer will be considered correct if and only if its absolute or relative error is less than 1e-9.
 

Sample Input
 
 
2 3 2 -1 0 1 4 2 -2 -1 1 2
 

Sample Output
 
 
0 0.5
 

Source
 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:   5081  5080  5079  5077  5076 
 

Statistic |  Submit |  Discuss |  Note


#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#define MAXN 50100
using namespace std;
int T,N,K;
int pos[MAXN],sum[MAXN],x[MAXN],First,Last;
double DL,DR,mass;
int PL,PR,need;
double ans,NowI;
double GetNext(){
    double ret=NowI;
    double pmass=mass;
    mass=(sum[Last+1]-sum[First]+0.0)/need;
    NowI+=-(pmass-pos[First])*(pmass-pos[First])+(mass-pos[Last+1])*(mass-pos[Last+1]);
    NowI+=(mass-pmass)*(mass-pmass)*(need-1);
    DL-=(pmass-pos[First]);
    Last++;First++;
    int t=PL-First+1;
    NowI+=2*DL*(mass-pmass);
    DL+=(mass-pmass)*t;
    PL++;
    while(PL<=N && pos[PL]<=mass){
        DL+=fabs(mass-pos[PL]);
        DR-=fabs(pmass-pos[PL]);
        NowI+=(mass-pos[PL])*(mass-pos[PL]);
        NowI-=(pmass-pos[PL])*(pmass-pos[PL]);
        NowI-=(mass-pmass)*(mass-pmass);
        PL++;
    }
    NowI+=2*(pmass-mass)*DR;
    DR+=(pos[Last]-mass);
    PL--;
    DR-=(mass-pmass)*(Last-(PL+1));
    return NowI;
}
int main(){
//    freopen("in.txt","r",stdin);
    scanf("%d",&T);
    while(T--){
        scanf("%d%d",&N,&K);
        for(int i=0;i<N;i++)
            scanf("%d",&pos[i]);
        sort(pos,pos+N);
        sum[0]=pos[0];
        for(int i=1;i<N;i++)
            sum[i]=sum[i-1]+pos[i];
        need=N-K;ans=0;PL=0;
        if(N==1 || need <2 ){
            puts("0.000000000000");
            continue;
        }
        double kkk=sum[need-1]*1.0/need;First=0;Last=need-1;
        DL=0;PL=0;DR=0;NowI=0;
        for(int i=0;i<need;i++){
            NowI+=(kkk-pos[i])*(kkk-pos[i]);
            if(pos[i]<=kkk){
                PL=i;
                DL+=(kkk-pos[i]);
            }
            else
                DR+=(pos[i]-kkk);
        }
        mass=kkk;
        ans=NowI;
        while(Last<N-1){
            GetNext();
            ans=min(ans,NowI);
        }
        printf("%.12lf\n",ans);
    }
}




本文转自mfrbuaa博客园博客,原文链接:http://www.cnblogs.com/mfrbuaa/p/5040853.html,如需转载请自行联系原作者


相关文章
|
5月前
(2021 ICPC)亚洲区域赛(昆明)I.Mr. Main and Windmills
(2021 ICPC)亚洲区域赛(昆明)I.Mr. Main and Windmills
29 0
(2021 ICPC)亚洲区域赛(昆明)I.Mr. Main and Windmills
|
机器学习/深度学习 自然语言处理 安全
2022年ACM博士论文奖公布了
2022年ACM博士论文奖公布了
|
Cloud Native 数据管理 关系型数据库
祝贺!我的同事李飞飞当选ACM Fellow、IEEE Fellow
因在数据库查询处理和优化以及云数据库系统方面所做出的卓越贡献而入选
736 0
祝贺!我的同事李飞飞当选ACM Fellow、IEEE Fellow
|
机器学习/深度学习 存储 编解码
IEEE年度大奖揭幕!华人科学家,Yang-Kieffer算法之父杨恩辉斩获Eric E.Summer奖
IEEE 宣布将Eric E. Sumner奖发给加拿大滑铁卢大学终身教授杨恩辉教授,以表彰他在视频压缩领域的贡献。
329 0
IEEE年度大奖揭幕!华人科学家,Yang-Kieffer算法之父杨恩辉斩获Eric E.Summer奖
|
人工智能 达摩院 量子技术
平头哥首席科学家谢源当选ACM Fellow
12月12日,国际计算机学会 (Association for Computing Machinery , 简称 ACM)正式公布了2019年ACM Fellow名单,阿里巴巴平头哥首席科学家、达摩院高级研究员谢源当选,这也意味着谢源成为IEEE(电气与电子工程师学会)、AAAS(美国科学促进会)、ACM(国际计算机学会) 三大国际顶级学会的会士(Fellow)。
5455 0
|
物联网 大数据 机器人