HDU2647-Reward(拓扑排序)

简介:

Reward

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3854    Accepted Submission(s): 1177


Problem Description
Dandelion's uncle is a boss of a factory. As the spring festival is coming , he wants to distribute rewards to his workers. Now he has a trouble about how to distribute the rewards.
The workers will compare their rewards ,and some one may have demands of the distributing of rewards ,just like a's reward should more than b's.Dandelion's unclue wants to fulfill all the demands, of course ,he wants to use the least money.Every work's reward will be at least 888 , because it's a lucky number.
 

Input
One line with two integers n and m ,stands for the number of works and the number of demands .(n<=10000,m<=20000)
then m lines ,each line contains two integers a and b ,stands for a's reward should be more than b's.
 

Output
For every case ,print the least money dandelion 's uncle needs to distribute .If it's impossible to fulfill all the works' demands ,print -1.
 

Sample Input
 
 
2 1 1 2 2 2 1 2 2 1
 

Sample Output
 
 
1777 -1
 
题意: 有n个人。m个关系:输入a,b 表示a比b大。

最少的工资为888,让你求最小的工资和


思路:拓扑排序。依据层数计算每一个人的工资,累加就可以。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <string>
#include <algorithm>
#include <queue>
using namespace std;

const int maxn = 10000+10;
vector<int> g[maxn];
int du[maxn];
int n,m;
int sum;
queue<int> que;
int head[maxn];
int now;
void init(){
    sum = 0;
    now = 888;
    memset(du,0,sizeof du);
    for(int i = 0; i <= n; i++) g[i].clear();
    while(!que.empty()) que.pop();
}

int main(){

    while(~scanf("%d%d",&n,&m)){
        init();
        int a,b;
        while(m--){
            scanf("%d%d",&a,&b);
            g[b].push_back(a);
            du[a]++;
        }
        int cnt = 0;
        for(int i = 1; i <= n; i++){
            if(du[i]==0){
                que.push(i);
                cnt++;
            }
        }
        while(!que.empty()){
            int qsize = que.size();
            while(qsize--){
                int k = que.front();
                sum+=now;
                que.pop();
                for(int i = 0; i < g[k].size(); i++){
                    int x = g[k][i];
                    du[x]--;
                    if(du[x]==0){
                        que.push(x);
                        cnt++;
                    }
                }
            }
            now++;

        }
        if(cnt<n){
            printf("-1\n");
        }else{
            printf("%d\n",sum);
        }
    }
    return 0;
}








本文转自mfrbuaa博客园博客,原文链接:http://www.cnblogs.com/mfrbuaa/p/5048279.html,如需转载请自行联系原作者

相关文章
|
7月前
|
Java
hdu-1869-六度分离(dijkstra)
hdu-1869-六度分离(dijkstra)
45 0
HDU 4283 You Are the One(动态规划)
HDU 4283 You Are the One(动态规划)
85 0
HDU 4283 You Are the One(动态规划)
|
测试技术
HDU-1232,畅通工程(并查集)
HDU-1232,畅通工程(并查集)
HDU-1874,畅通工程续(Floyd最短路)
HDU-1874,畅通工程续(Floyd最短路)
|
算法 机器学习/深度学习