PAT 1002 Hello World for U (20)

简介:

Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, "helloworld" can be printed as:

h  d
e  l
l  r
lowo
That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 - 2 = N. 
输入描写叙述:
Each input file contains one test case.  Each case contains one string with no less than 5 and no more than 80 characters in a line.  The string contains no white space.


输出描写叙述:
For each test case, print the input string in the shape of U as specified in the description.

输入样例:
helloworld!

输出样例:
h   !
e   d
l   l
lowor


#include <iostream>
#include <cstring>
#include <string>

using namespace std;

int main()
{
	int i1,i2,left_right,down,i,j,k;
	char s[1024];
	while(cin>>s)
	{

		i1=(strlen(s)+2)/3;
		i2=(strlen(s)+2)%3;
		if(1==i2)
		{
			left_right=i1;
			down=i1+1;
		}
		else if(2==i2)
		{
			left_right=i1;
			down=i1+2;
		}
		else
		{
			left_right=down=i1;
		}
		for(i=0,k=0;i<left_right-1;i++)
		{
			cout<<s[k];
			for(j=2;j<down;j++)
				cout<<" ";
			cout<<s[strlen(s)-1-k]<<endl;
			k++;
		}
		for(i=k;i<strlen(s)-k;i++)
			cout<<s[i];
		cout<<endl;
	}
	return 0;
}


插个图






本文转自mfrbuaa博客园博客,原文链接:http://www.cnblogs.com/mfrbuaa/p/5158606.html,如需转载请自行联系原作者

相关文章
|
6月前
|
存储 程序员 C语言
【C++】“Hello World!“
【C++】“Hello World!“
50 3
|
5月前
|
C++
C++之Hello,world
C++之Hello,world
|
6月前
|
移动开发 C++
Hello World
Hello World
51 0
01:Hello, World!
01:Hello, World!
94 0
10:Hello, World!的大小
10:Hello, World!的大小
99 0
|
C++
L1-001 Hello World
文章目录 L1-001 Hello World (5 分) 总结
95 0
L1-001 Hello World
Hello world
首帖则测试了解下如何使用,并且看看有什么不同的地方,是不是很好用呢 引用测试 H是什么不知道
559 0