Oracle数据库的非归档模式迁移到归档模式

简介:

先观察当前的状态:

[root@o_target ~]# su - oracle    
[oracle@o_target ~]$ sqlplus / as sysdba    
    
SQL*Plus: Release 11.2.0.1.0 Production on Wed Mar 19 12:38:24 2014    
    
Copyright (c) 1982, 2009, Oracle.  All rights reserved.    
    
Connected to an idle instance.    
    
SQL> startup;    
ORACLE instance started.    
    
Total System Global Area 1023004672 bytes    
Fixed Size                  2219752 bytes    
Variable Size             624951576 bytes    
Database Buffers          390070272 bytes    
Redo Buffers                5763072 bytes    
Database mounted.    
Database opened.    
SQL> archive log list;    
Database log mode              No Archive Mode    
Automatic archival             Disabled    
Archive destination            USE_DB_RECOVERY_FILE_DEST    
Oldest online log sequence     4    
Current log sequence           6 

SQL>

发现是没有在 Archive模式下。

 

进行转换,发现必须对数据库在mount状态下进行操作。

   
SQL> alter database archivelog;    
alter database archivelog    
*    
ERROR at line 1:    
ORA-01126: database must be mounted in this instance and not open in any    
instance    

然后,进入mount状态,进行转换:

SQL> shutdown immediate;    
Database closed.    
Database dismounted.    
ORACLE instance shut down.    
SQL> startup mount;           
ORACLE instance started.    
    
Total System Global Area 1023004672 bytes    
Fixed Size                  2219752 bytes    
Variable Size             624951576 bytes    
Database Buffers          390070272 bytes    
Redo Buffers                5763072 bytes    
Database mounted.    
SQL> alter database archivelog;    
    
Database altered.    
    
SQL> archive log list;    
Database log mode              Archive Mode    
Automatic archival             Enabled    
Archive destination            USE_DB_RECOVERY_FILE_DEST    
Oldest online log sequence     4    
Next log sequence to archive   6    
Current log sequence           6    
SQL>      

发现现在缺省使用的路径为 DB_RECOVERY_FILE_DEST,此路径是和Oracle的Flash_back_recovery 路径混杂在一起的,不太妥当。

参见:

http://jinyumantang110.blog.163.com/blog/static/5457915620107994131968/

http://anuj-singh.blogspot.jp/2011/10/oracle-archive-log-on.html

其提到:never use this area for archive log file , system will hang after destination full

 

先观察实际路径设置:

SQL> show parameter DB_RECOVERY_FILE_DEST;    
    
NAME                                 TYPE        VALUE    
------------------------------------ ----------- ------------------------------    
db_recovery_file_dest                string      /u01/app/oracle/flash_recovery    
                                                 _area    
db_recovery_file_dest_size           big integer 3882M    

 

尝试更改路径:

SQL> alter system set log_archive_dest = '/u01/app/arch' scope=both;    
alter system set log_archive_dest = '/u01/app/arch' scope=both    
*    
ERROR at line 1:    
ORA-02097: parameter cannot be modified because specified value is invalid    
ORA-16018: cannot use LOG_ARCHIVE_DEST with LOG_ARCHIVE_DEST_n or    
DB_RECOVERY_FILE_DEST    
   

需要把 USE_DB_RECOVERY_FILE_DEST变成空值:

SQL> alter system set DB_RECOVERY_FILE_DEST='';    
    
System altered.    
    
SQL> alter system set log_archive_dest =     
  2  '/u01/app/arch' scope=both;    
    
System altered.    
    
SQL>     
    
    
SQL> archive log list;    
Database log mode              Archive Mode    
Automatic archival             Enabled    
Archive destination            /u01/app/arch    
Oldest online log sequence     4    
Next log sequence to archive   6    
Current log sequence           6    
SQL>

 

看archive log 目录是否可以自动生成:

SQL> alter system switch logfile;    
alter system switch logfile    
*    
ERROR at line 1:    
ORA-01109: database not open    
    
    
SQL>     
    
    
    
    
SQL> alter database open;    
    
Database altered.    
    
SQL> alter system switch logfile;    
    
System altered.    
    
SQL>     
    
    
    
    
SQL> shutdown immediate;    
Database closed.    
Database dismounted.    
ORACLE instance shut down.    
SQL>     
    
   
SQL>     
SQL> startup;    
ORACLE instance started.    
    
Total System Global Area 1023004672 bytes    
Fixed Size                  2219752 bytes    
Variable Size             624951576 bytes    
Database Buffers          390070272 bytes    
Redo Buffers                5763072 bytes    
Database mounted.    
Database opened.    
SQL> archive log list;    
Database log mode              Archive Mode    
Automatic archival             Enabled    
Archive destination            /u01/app/arch    
Oldest online log sequence     5    
Next log sequence to archive   7    
Current log sequence           7   

    
SQL> !ls -lrt /u01/app    
total 836    
drwxrwx--- 5 oracle oinstall   4096 Mar 13 09:18 oraInventory    
drwxr-xr-x 9 oracle oinstall   4096 Mar 13 09:24 oracle    
-rw-r----- 1 oracle oinstall 840192 Mar 19 14:07 arch1_6_842088414.dbf    
    
SQL> !ls -lrt /u01/app/arch    
ls: /u01/app/arch: No such file or directory    
    
SQL>     
    
必须手动设置:

    
SQL> !ls -lrt /u01/app/arch    
ls: /u01/app/arch: No such file or directory    
    
SQL> !mkdir -p /u01/app/arch             
    
SQL> !ls -lrt /u01/app/arch    
total 0    
    
SQL> !ls -lrt /u01/app    
total 840    
drwxrwx--- 5 oracle oinstall   4096 Mar 13 09:18 oraInventory    
drwxr-xr-x 9 oracle oinstall   4096 Mar 13 09:24 oracle    
-rw-r----- 1 oracle oinstall 840192 Mar 19 14:07 arch1_6_842088414.dbf    
drwxr-xr-x 2 oracle oinstall   4096 Mar 19 14:11 arch    
 

SQL>





本文转自健哥的数据花园博客园博客,原文链接:http://www.cnblogs.com/gaojian/p/3611641.html,如需转载请自行联系原作者

目录
相关文章
|
12月前
|
Oracle 关系型数据库 Linux
【赵渝强老师】Oracle数据库配置助手:DBCA
Oracle数据库配置助手(DBCA)是用于创建和配置Oracle数据库的工具,支持图形界面和静默执行模式。本文介绍了使用DBCA在Linux环境下创建数据库的完整步骤,包括选择数据库操作类型、配置存储与网络选项、设置管理密码等,并提供了界面截图与视频讲解,帮助用户快速掌握数据库创建流程。
934 93
|
12月前
|
关系型数据库 MySQL 数据库
自建数据库如何迁移至RDS MySQL实例
数据库迁移是一项复杂且耗时的工程,需考虑数据安全、完整性及业务中断影响。使用阿里云数据传输服务DTS,可快速、平滑完成迁移任务,将应用停机时间降至分钟级。您还可通过全量备份自建数据库并恢复至RDS MySQL实例,实现间接迁移上云。
|
11月前
|
Oracle 关系型数据库 Linux
【赵渝强老师】使用NetManager创建Oracle数据库的监听器
Oracle NetManager是数据库网络配置工具,用于创建监听器、配置服务命名与网络连接,支持多数据库共享监听,确保客户端与服务器通信顺畅。
501 0
|
存储 Oracle 关系型数据库
服务器数据恢复—光纤存储上oracle数据库数据恢复案例
一台光纤服务器存储上有16块FC硬盘,上层部署了Oracle数据库。服务器存储前面板2个硬盘指示灯显示异常,存储映射到linux操作系统上的卷挂载不上,业务中断。 通过storage manager查看存储状态,发现逻辑卷状态失败。再查看物理磁盘状态,发现其中一块盘报告“警告”,硬盘指示灯显示异常的2块盘报告“失败”。 将当前存储的完整日志状态备份下来,解析备份出来的存储日志并获得了关于逻辑卷结构的部分信息。
|
存储 运维 关系型数据库
从MySQL到云数据库,数据库迁移真的有必要吗?
本文探讨了企业在业务增长背景下,是否应从 MySQL 迁移至云数据库的决策问题。分析了 MySQL 的优势与瓶颈,对比了云数据库在存储计算分离、自动化运维、多负载支持等方面的优势,并提出判断迁移必要性的五个关键问题及实施路径,帮助企业理性决策并落地迁移方案。
|
SQL Oracle 关系型数据库
Oracle数据库创建表空间和索引的SQL语法示例
以上SQL语法提供了一种标准方式去组织Oracle数据库内部结构,并且通过合理使用可以显著改善查询速度及整体性能。需要注意,在实际应用过程当中应该根据具体业务需求、系统资源状况以及预期目标去合理规划并调整参数设置以达到最佳效果。
715 8
|
SQL Oracle 关系型数据库
比较MySQL和Oracle数据库系统,特别是在进行分页查询的方法上的不同
两者的性能差异将取决于数据量大小、索引优化、查询设计以及具体版本的数据库服务器。考虑硬件资源、数据库设计和具体需求对于实现优化的分页查询至关重要。开发者和数据库管理员需要根据自身使用的具体数据库系统版本和环境,选择最合适的分页机制,并进行必要的性能调优来满足应用需求。
623 11
|
Oracle 关系型数据库 数据库
数据库数据恢复—服务器异常断电导致Oracle数据库报错的数据恢复案例
Oracle数据库故障: 某公司一台服务器上部署Oracle数据库。服务器意外断电导致数据库报错,报错内容为“system01.dbf需要更多的恢复来保持一致性”。该Oracle数据库没有备份,仅有一些断断续续的归档日志。 Oracle数据库恢复流程: 1、检测数据库故障情况; 2、尝试挂起并修复数据库; 3、解析数据库文件; 4、导出并验证恢复的数据库文件。
|
监控 Oracle 关系型数据库
"深度剖析:Oracle SGA大小调整策略——从组件解析到动态优化,打造高效数据库性能"
【8月更文挑战第9天】在Oracle数据库性能优化中,系统全局区(SGA)的大小调整至关重要。SGA作为一组共享内存区域,直接影响数据库处理能力和响应速度。本文通过问答形式介绍SGA调整策略:包括SGA的组成(如数据缓冲区、共享池等),如何根据负载与物理内存确定初始大小,手动调整SGA的方法(如使用`ALTER SYSTEM`命令),以及利用自动内存管理(AMM)特性实现智能调整。调整过程中需注意监控与测试,确保稳定性和性能。
1548 2

推荐镜像

更多