IntelliJ IDEA的安装环境要求-阿里云开发者社区

开发者社区> 开发与运维> 正文
登录阅读全文

IntelliJ IDEA的安装环境要求

简介: 在这部分: - 硬件要求 - 系统要求 - Windows - OS X - Linux 硬件要求 - 最小1 GB内存,推荐2 GB 内存- 300 MB硬盘空间至少1 GB的高速缓存- 最小屏幕分辨率1024×768px 系统要求 所有平台的分发版本都捆绑了JRE 1.8。

在这部分:

硬件要求

- 最小1 GB内存,推荐2 GB 内存- 300 MB硬盘空间至少1 GB的高速缓存- 最小屏幕分辨率1024×768px

系统要求

所有平台的分发版本都捆绑了JRE 1.8。你不需要将你的机器上安装任何Java才能运行的IntelliJ IDEA。
在IntelliJ IDEA的开发Web,PHP,Ruby或Python项目并不需要JDK。独立JDK安装所需的只是Java开发。
但是,您不能使用我们捆绑的JRE进行Java开发

Windows


系统要求 安装
  • Microsoft Windows 10/8/7/Vista/2003/XP (incl.64-bit)
  • 要使用IntelliJ IDEA开发Java应用程序,可根据您的项目要求安装JDK版本。

    请注意,您不能使用IntelliJ IDEA发行时捆绑在一起的JRE开发,它仅用于运行IDE本身。

  1. 下载页下载 IntelliJ IDEA。
  2. 运行 ideaIC or ideaIU-*.exe 文件启动安装向导。
  3. 按照向导提示的所有步骤。要特别注意相应的安装选项。
  4. 请参考:Windows7下安装IntelliJ IDEA Community Edition 2016.1.3(64)
  5. 请参考:WindowsXP下安装IntelliJ IDEA Ultimate Edition

OS X


系统要求 安装
  • OS X 10.5或更高版本, 包括 10.10
  • 仅支持 64位的 OS X 。
  • 要使用IntelliJ IDEA开发Java应用程序,可根据您的项目要求安装JDK版本。

    请注意,您不能使用IntelliJ IDEA发行时捆绑在一起的JRE开发,它仅用于运行IDE本身。

  1. 下载页下载 IntelliJ IDEA,ideaIC or ideaIU-*.dmg  OS X磁盘映像文件。
  2. 双击下载的 ideaIC or ideaIU-*.dmg OS X 磁盘映像文件挂载
  3. 复制 IntelliJ IDEA 到你的应用程序文件夹。

注:打开JDK 1.8的JetBrains的团队定制的OS X的分布捆绑。

Linux


系统要求 安装
  • OS Linux
  • KDE, GNOME or Unity DE desktop
  • 要使用IntelliJ IDEA开发Java应用程序,可根据您的项目要求安装JDK版本。

    请注意,您不能使用IntelliJ IDEA发行时捆绑在一起的JRE开发,它仅用于运行IDE本身。

  1. 下载页下载 ideaIC or ideaIU-*.tar.gz 文件。
  2. 解压 ideaIC or ideaIU-*.tar.gz文件到一个空目录 使用以下命令:
    tar xfz ideaIC or ideaIU-*.tar.gz
  3. 因为从你下载的文件位置运行IntelliJ IDEA可能不方便,建议您在使用mv命令使用以下格式之一的移动抽取或解压缩存档文件夹到所需的位置:
    • mv <path to extracted archive folder> <new archive folder>
      例如:
      mv /downloads/ideaIC or ideaIU-* my/desired/location
    • mv <path to ideaIC or ideaIU-*.tar.gz> <new archive folder>
      例如:
      mv /downloads/ideaIC or ideaIU-*.tar.gz my/desired/location
  4. 切换到新位置下的bin目录:
    cd <new archive folder>/ideaIC or ideaIU-*/bin
    例如,
    cd my/desired/location/ideaIC or ideaIU-*/bin
  5. 从bin子目录运行ideaIC或ideaIU.sh。

注:Linux发行版JetBrains公司捆绑定制的open JDK 1.8版本。如果你不喜欢它,可随时切换到系统中安装的另一个JRE

上一篇:IntelliJ IDEA的安装环境要求

下一篇:快速入门指南

下一篇:安装和启动

==================参阅======================

外部链接:

版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

分享:
开发与运维
使用钉钉扫一扫加入圈子
+ 订阅

集结各类场景实战经验,助你开发运维畅行无忧

其他文章
最新文章
相关文章