ZOJ1003 Crashing Balloon

简介:
On every June 1st, the Children's Day, there will be a game named "crashing balloon" on TV.   The rule is very simple.  On the ground there are 100 labeled balloons, with the numbers 1 to 100.  After the referee shouts "Let's go!" the two players, who each starts with a score of  "1", race to crash the balloons by their feet and, at the same time, multiply their scores by the numbers written on the balloons they crash.  After a minute, the little audiences are allowed to take the remaining balloons away, and each contestant reports his\her score, the product of the numbers on the balloons he\she's crashed.  The unofficial winner is the player who announced the highest score.

Inevitably, though, disputes arise, and so the official winner is not determined until the disputes are resolved.  The player who claims the lower score is entitled to challenge his\her opponent's score.  The player with the lower score is presumed to have told the truth, because if he\she were to lie about his\her score, he\she would surely come up with a bigger better lie.  The challenge is upheld if the player with the higher score has a score that cannot be achieved with balloons not crashed by the challenging player.  So, if the challenge is successful, the player claiming the lower score wins.

So, for example, if one player claims 343 points and the other claims 49, then clearly the first player is lying; the only way to score 343 is by crashing balloons labeled 7 and 49, and the only way to score 49 is by crashing a balloon labeled 49.  Since each of two scores requires crashing the balloon labeled 49, the one claiming 343 points is presumed to be lying.

On the other hand, if one player claims 162 points and the other claims 81, it is possible for both to be telling the truth (e.g. one crashes balloons 2, 3 and 27, while the other crashes balloon 81), so the challenge would not be upheld.

By the way, if the challenger made a mistake on calculating his/her score, then the challenge would not be upheld. For example, if one player claims 10001 points and the other claims 10003, then clearly none of them are telling the truth. In this case, the challenge would not be upheld.

Unfortunately, anyone who is willing to referee a game of crashing balloon is likely to get over-excited in the hot atmosphere that he\she could not reasonably be expected to perform the intricate calculations that refereeing requires.  Hence the need for you, sober programmer, to provide a software solution. 



Input

Pairs of unequal, positive numbers, with each pair on a single line, that are claimed scores from a game of crashing balloon. 



Output

Numbers, one to a line, that are the winning scores, assuming that the player with the lower score always challenges the outcome. 



Sample Input

343 49

3599 610

62 36

 

Sample Output

49

610

62

 

代码:

复制代码
#include<iostream>
using namespace std;

const int MAX=100;
bool UsedBalloon[MAX+1];

bool CanFactor(int i,int num)
{//进行因子分解
    if(num==1)
    {
        return true;
    }
    else
    {
        while(i<=MAX)
        { // 对num进行因子分解
            if((UsedBalloon[i]==false)&&((num%i)==0))
            {
                break;
            }
            else
            {
                i++;
            }
        }
        if(i>MAX) return false;
        // 尝试i因子这头路
        if(CanFactor(i+1, num/i))
        {
            return true;
        }
        else
        {
            // i这个因子不可取
            return CanFactor(i+1,num);
        }
    }
}
bool IsOK(int i,int numA,int numB)
{// 卫冕者和挑战者分别进行因子分解,看两者是否有公关因子
    if(i>MAX)
        return false;
    if(numA==1) 
        return (CanFactor(1, numB)); // 卫冕者已经分解完毕,对挑战者进行因子分解
    while(i<=MAX)
    { // 对卫冕者进行因子分解
        if((numA%i)==0)
        {
            break;
        }
        else
        {
            i++;
        }
    }
    if(i>MAX) return false;
    UsedBalloon[i]=true;//i是卫冕者的因子
    if(IsOK(i+1,numA/i,numB))
        return true; //尝试i这头路径,如果分解成功则返回true
    UsedBalloon[i]=false;//i这个因子不可取,放弃掉
    return(IsOK(i+1,numA,numB)); //放弃i,从i+1为起点重新进行分解
}
int GetWinner(int numA,int numB)
{
    for(int i=1; i<MAX+1;i++)
    {//初始化气球标记,1~100号气球都还没被踩破
        UsedBalloon[i] = false;
    }
    if(numA<numB)
    {//确保numB为挑战者
        swap(numA,numB);
    }
    if((CanFactor(1,numB)==false)&&(numB>100)) //只要挑战者说谎,就判定其失败
    { //挑战者分数无法在1~100之间进行因子分解,并且其分数超过(也就是说无法用自身*1来表达因子)
        return numA;
    }
    else if(IsOK(1,numA,numB)) 
    {//挑战者没有说谎,但挑战失败(也就是说numA和numB可以不互相干扰地进行因子分解)
        return numA; // 挑战者失败.
    }
    else
    {// 挑战者胜利
        return numB; 
    }
}

int main()
{
    int numA, numB;
    while(cin>>numA>>numB)
    {
        cout<<GetWinner(numA,numB)<<endl;
    }
    return 0;
}
复制代码



本文转自Phinecos(洞庭散人)博客园博客,原文链接:http://www.cnblogs.com/phinecos/archive/2008/09/18/1293213.htmlX,如需转载请自行联系原作者
目录
相关文章
|
1月前
|
Java
HDU-1004—Let the Balloon Rise
HDU-1004—Let the Balloon Rise
16 0
|
1月前
Strange fuction(HDU--2899)
Strange fuction(HDU--2899)
HDOJ 1004题 Let the Balloon Rise strcmp()函数
HDOJ 1004题 Let the Balloon Rise strcmp()函数
93 0
|
机器学习/深度学习