Cannot change version of project facet Dynamic Web Module to 3.0-阿里云开发者社区

开发者社区> 开发与运维> 正文
登录阅读全文

Cannot change version of project facet Dynamic Web Module to 3.0

简介: 背景描述:   最近在开发项目时,老是报错说:Project is not Dynamic Web Module 3.0.右击项目选择属性进行修改时出现以下错误:   这让我很是恼火,后来终于找到了万能的解决办法,亲测可行,先分享如下:   开发环境:eclipse.

背景描述:

  最近在开发项目时,老是报错说:Project is not Dynamic Web Module 3.0.右击项目选择属性进行修改时出现以下错误:

  这让我很是恼火,后来终于找到了万能的解决办法,亲测可行,先分享如下:

  开发环境:eclipse.

  第一步:查找项目所在位置,右键项目--》Properties

  第二步,找到项目目录下的.settings文件夹

  第三步,找到.settings文件夹下的org.eclipse.wst.common.project.facet.core.xml文件

  

  第四步,用记事本等编辑文件编辑该文件,并修改下图的标红处修改为3.0(此处编辑使用的是Editplus)

  第五步,关闭并保存该文件,刷新eclipse,在项目属性中查看,已经完美解决!

 

版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

分享:
开发与运维
使用钉钉扫一扫加入圈子
+ 订阅

集结各类场景实战经验,助你开发运维畅行无忧

其他文章