poj 2752 Seek the Name, Seek the Fame【KMP】

简介: 点击打开题目 Seek the Name, Seek the Fame Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 12651   Accepted: 6214 ...

点击打开题目

Seek the Name, Seek the Fame
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 12651   Accepted: 6214

Description

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm: 

Step1. Connect the father's name and the mother's name, to a new string S. 
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S). 

Example: Father='ala', Mother='la', we have S = 'ala'+'la' = 'alala'. Potential prefix-suffix strings of S are {'a', 'ala', 'alala'}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:) 

Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above. 

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000. 

Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby's name.

Sample Input

ababcababababcabab
aaaaa

Sample Output

2 4 9 18
1 2 3 4 5
大致题意:
给出一个字符串str,求出str中存在多少子串,使得这些子串既是str的前缀,又是str的后缀。从小到大依次输出这些子串的长度
解题思路:重在理解KMP算法中next数组的含义,递归求解
#include<cstdio>
#define maxn 400002
char str[maxn];
int next[maxn],len,s;
void GetNext(){
    int i=0,j=-1;
    next[0]=-1;
    while(str[i]){
        if(j==-1||str[i]==str[j]){
            ++i;++j;next[i]=j;
        }else j=next[j];
    }
    len=i;
}
void GetVal(int n){
    if(next[n]==0) return ;
    GetVal(next[n]);
    printf("%d ",next[n]);
}
int main(){
    while(scanf("%s",str)==1){
        GetNext();
        GetVal(len);
        printf("%d\n",len);
    }return 0;
}


目录
相关文章
|
8月前
|
Java
POJ-2752-Seek the Name, Seek the Fame
POJ-2752-Seek the Name, Seek the Fame
49 0
|
7月前
|
C语言
C语言进阶——sprintf与sscanf、文件的随机读写(fseek、ftell、rewind)
C语言进阶——sprintf与sscanf、文件的随机读写(fseek、ftell、rewind)
73 0
BM13判断一个链表是否为回文结构
BM13判断一个链表是否为回文结构
34 0
【剑指offer】JZ5 替换空格、JZ6 从尾到头打印链表
【剑指offer】JZ5 替换空格、JZ6 从尾到头打印链表
C. Prepend and Append(双指针)
C. Prepend and Append(双指针)
50 0
KMP - leetcode28. 实现 strStr()
快速学习 KMP - leetcode28. 实现 strStr()
KMP - leetcode28. 实现 strStr()
|
算法 Java C语言
leetcode算法28.实现strStr()
给你两个字符串 haystack 和 needle ,请你在 haystack 字符串中找出 needle 字符串出现的第一个位置(下标从 0 开始)。如果不存在,则返回 -1 。
163 0
leetcode算法28.实现strStr()
|
算法 Java C#
【小Y学算法】每日LeetCode打卡——15.实现 strStr()
📢前言 🌲原题样例 🌻C#方法一:暴力法 🌻C#方法二:傻瓜解法 🌻Java 方法一:暴力法 🌻Java 方法二: KMP 解法 💬总结
【小Y学算法】每日LeetCode打卡——15.实现 strStr()
|
开发者 Python
seek( ) 和 tell( )|学习笔记
快速学习 seek( ) 和 tell( )
145 0