开发者社区> 大江小浪> 正文
阿里云
为了无法计算的价值
打开APP
阿里云APP内打开

为Lampp环境配置xhprof

简介: 为了方便,一般在本地的测试环境中我都使用了 XAMPP 或者 LAMPP 。(Apache Friends XAMPP)但是默认的XAMPP中没有提供xhprof的支持,为此需要自己独立编译。下面记录了编译的过程。
+关注继续查看

为了方便,一般在本地的测试环境中我都使用了 XAMPP 或者 LAMPP 。(Apache Friends XAMPP)但是默认的XAMPP中没有提供xhprof的支持,为此需要自己独立编译。下面记录了编译的过程。

1、如果你的XAMPP没有 DEVEL包,那么编译是通不过的。我就是因为编译时遇到 include php.h 时就失败了。所以需要先确保下载并安装了 xampp 的 devel packages。下载地址:xampp-linux-devel,然后解压到安装的目录  tar -xvzf file -C /opt。下载 xampp 的 devel 包的时候,注意要选择和自己当前的版本一致的 devel 包,因为 php 的扩展编译的时候,会附加版本信息,启动时进行检查,如果不一致,即便能够编译成功,也是不能够使用的。

完成后,你会发现lampp的目录下多了个include目录,里面是一些必要的头文件。 

2、下载 xhprof 的源代码。 解压缩,然后进入 xhprof/extension/ 目录

3、依次执行以下命令:

 /opt/lampp/bin/phpize

 ./configure --with-php-config=/opt/lampp/bin/php-config --prefix=/opt/lampp/

 make

make test

make install

 

之后就会看到安装完成的提示。之后去 /opt/lampp/lib/php/extensions/no-debug-on-zts-20060613/ 下查看,会看到已经有 xhprof.so 了。

4、 在 /opt/lampp/etc/php.ini 中添加 extension="xhprof.so" 重启lampp。

5、 重启服务器后,就可以看到phpinfo中xhprof的信息了。

 

PS:我在使用lampp 1.7 的时候,编译得到的 xhprof.so 不能够够正常加载,提示版本号不对,可能是 

 

 

参考资料:

1、Apache Friends XAMPP 

2、XAMPP Devel Packages 

版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

相关文章
+关注
大江小浪
平心静气,破浪劈坚!
292
文章
0
问答
文章排行榜
最热
最新
相关电子书
更多
低代码开发师(初级)实战教程
立即下载
阿里巴巴DevOps 最佳实践手册
立即下载
冬季实战营第三期:MySQL数据库进阶实战
立即下载