HDOJ 1013题Digital Roots 大数,9余数定理

简介: Problem Description The digital root of a positive integer is found by summing the digits of the integer.
Problem Description
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

Input
The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.

Output
For each integer in the input, output its digital root on a separate line of the output.

Sample Input
 
 
24 39 0

Sample Output
 
 
6 3


一个数对九取余,得到的数称之为九余数;
一个数的九余数等于它的各个数位上的数之和的九余数!

题目大意:

 给定一个正整数,根据一定的规则求出该数的数根,其规则如下:

        例如给定 数字 24,将24的各个位上的数字分离,分别得到数字 和 4,而2+4=6

        因为 6 < 10,所以就认为6是数字24数根

        而对于数字 39  将39的各个位上的数字分离,分别得到数字 和 9,而3+9=12,12>10

       所以依据规则再对 12 进行相应的运算,最后得到数字3,而3<10,所以就认为3是数字39数根

       

              通过运算可以发现任何一个数的数根都是一个取值范围在 1 ~ 9之间的正整数,

     且任何一个正整数都只有唯一的一个数根与其相对应。

              题目要求数字 n^n 数根

解题思路:

九余数定理

一个数对九取余后的结果称为九余数。

一个数的各位数字之和想加后得到的<10的数字称为这个数的九余数(如果相加结果大于9,则继续各位相加)

代码如下:
#include <stdio.h>
#include <stdlib.h>
#include<string.h>
int main()
{
    char a[1010];
    int i,j,s,l;
    while(~scanf("%s",&a)&&a[0]!='0')
    {
        l=strlen(a);
        s=0;
        for(i=0;i<l;i++)
        {
            s=s+a[i]-'0';
        }
        s=s%9;
        if(s==0)
            s=9;
        printf("%d\n",s);
    }
    return 0;
}


一个数对九取余,得到的数称之为九余数;
一个数的九余数等于它的各个数位上的数之和的九余数!
目录
相关文章
|
机器学习/深度学习 算法 C++
剑指offer(C++)-JZ64:求1+2+3+...+n(算法-位运算)
剑指offer(C++)-JZ64:求1+2+3+...+n(算法-位运算)
|
存储 算法
经典算法之异或运算(无进位相加)
经典算法之异或运算(无进位相加)
经典算法之异或运算(无进位相加)
|
人工智能
唯一分解定理(算术基本定理)详解——hdu5248和lightoj1341
任何一个大于1的自然数 N,如果N不为质数,那么N可以唯一分解成有限个质数的乘积 N=P1a1 P2a2P3a3…Pnan,这里P1<P2<P3…<Pn均为质数,其中指数ai是正整数。这样的分解称为 N 的标准分解式.
313 0
|
机器学习/深度学习
HDOJ 1013题Digital Roots 大数,9余数定理
HDOJ 1013题Digital Roots 大数,9余数定理
146 0
|
机器学习/深度学习
HDOJ 1163 Eddy's digital Roots(九余数定理的应用)
HDOJ 1163 Eddy's digital Roots(九余数定理的应用)
112 0
|
Java
HDOJ 1753 大明A+B(大数~)
HDOJ 1753 大明A+B(大数~)
117 0
|
Go
HDOJ/HDU 1133 Buy the Ticket(数论~卡特兰数~大数~)
HDOJ/HDU 1133 Buy the Ticket(数论~卡特兰数~大数~)
116 0
HDOJ(HDU) 2504 又见GCD(利用最大公约数反推)
HDOJ(HDU) 2504 又见GCD(利用最大公约数反推)
111 0