HDOJ 1064Financial Management

简介: Problem Description Larry graduated this year and finally has a job. He’s making a lot of money, but somehow never seems to have enough.

Problem Description
Larry graduated this year and finally has a job. He’s making a lot of money, but somehow never seems to have enough. Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems. The first step is to figure out what’s been going on with his money. Larry has his bank account statements and wants to see how much money he has. Help Larry by writing a program to take his closing balance from each of the past twelve months and calculate his average account balance.

Input
The input will be twelve lines. Each line will contain the closing balance of his bank account for a particular month. Each number will be positive and displayed to the penny. No dollar sign will be included.

Output
The output will be a single number, the average (mean) of the closing balances for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign, and followed by the end-of-line. There will be no other spaces or characters in the output.

Sample Input
100.00
489.12
12454.12
1234.10
823.05
109.20
5.27
1542.25
839.18
83.99
1295.01
1.75

Sample Output
$1581.42

#include<stdio.h>
int main()
{
    int i;
    double a,s;
    s=0;
    for(i=1;i<=12;i++)
     {
       scanf("%lf",&a);
       s+=a;
     }
    printf("$%.2lf\n",s/12);
    return 0;
}
目录
相关文章
|
监控 安全 开发工具
finops Financial Operations
FinOps指的是财务运营(Financial Operations)的缩写,是一种通过运用技术、流程和文化变革来优化云计算成本的方法论。FinOps的目的是帮助企业更好地理解和管理云计算成本,实现成本的透明化和优化,从而提高云计算的价值和效益。
187 1
|
存储 弹性计算 分布式计算
NHCP H2: Computer Resource Management Topic | Cloud computing
HCNP云计算2:计算机资源管理
168 0
|
安全
Information Systems Security Assessment – Open information security framework
The Information Systems Security Assessment Framework (ISSAF) seeks to integrate the following m...
1008 0
|
Java API
解决办法:access restriction is not accessible due to restriction
解决办法:access restriction is not accessible due to restriction
151 0
HDOJ 1064Financial Management
HDOJ 1064Financial Management
118 0
HDOJ 1064 Financial Management
HDOJ 1064 Financial Management
93 0
|
安全
How Important is Data Security for the Financial Industry?
90% of financial companies worldwide think they have data security risks. What security problems do financial industry users typically encounter?
2037 0

热门文章

最新文章