HDOJ 1064 Financial Management

简介: Problem Description Larry graduated this year and finally has a job. He’s making a lot of money, but somehow never seems to have enough.

Problem Description
Larry graduated this year and finally has a job. He’s making a lot of money, but somehow never seems to have enough. Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems. The first step is to figure out what’s been going on with his money. Larry has his bank account statements and wants to see how much money he has. Help Larry by writing a program to take his closing balance from each of the past twelve months and calculate his average account balance.

Input
The input will be twelve lines. Each line will contain the closing balance of his bank account for a particular month. Each number will be positive and displayed to the penny. No dollar sign will be included.

Output
The output will be a single number, the average (mean) of the closing balances for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign, and followed by the end-of-line. There will be no other spaces or characters in the output.

Sample Input
100.00
489.12
12454.12
1234.10
823.05
109.20
5.27
1542.25
839.18
83.99
1295.01
1.75

Sample Output
$1581.42

import java.util.*;
class Main {
   public static void main(String args[]){
      Scanner sc = new Scanner(System.in);
      double sum =0 ;
      for(int i=0 ;i<12;i++){
         double a=  sc.nextDouble();
         sum+=a;

      }
      System.out.print("$");
      System.out.printf("%.2f",sum/12);
      System.out.println();
   }
}
目录
相关文章
|
2月前
|
机器学习/深度学习 JSON 网络协议
Nostr with NIP-05 Verification Guide
该文章是一个关于Nostr协议中NIP-05验证的指南,解释了NIP-05允许用户将公钥映射到基于DNS的可读标识符上,并提供了如何在个人域名上设置`nostr.json`文件或使用现有NIP-05服务来完成验证的步骤。
21 3
Nostr with NIP-05 Verification Guide
Choosing Teams
Choosing Teams
123 0
Choosing Teams
HDOJ 1064 Financial Management
HDOJ 1064 Financial Management
79 0
HDOJ 1064Financial Management
HDOJ 1064Financial Management
100 0
|
JavaScript 前端开发 vr&ar
Use Augmented Reality technology to bring enhanced customer experience
Use Augmented Reality technology to bring enhanced customer experience
111 0
Use Augmented Reality technology to bring enhanced customer experience
|
XML 数据格式
Some more technical details about SAP note
I use this note 2184333 which I am responsible for as an example:
Some more technical details about SAP note
|
CDN
Building an Industry Information Website
Object Storage Server (OSS) is a massive, secure, low-cost and highly reliable distributed storage service offered by Alibaba Cloud.
1561 0
Building an Industry Information Website
6 Major Changes in Science and Technology Reshaping the Retail Industry
As the transformation of the retail industry deepens, consumers are now at the center of the entire industry ecosystem.
3813 0
6 Major Changes in Science and Technology Reshaping the Retail Industry
|
安全
How Important is Data Security for the Financial Industry?
90% of financial companies worldwide think they have data security risks. What security problems do financial industry users typically encounter?
2009 0