HDOJ 1064 Financial Management

简介: Problem Description Larry graduated this year and finally has a job. He’s making a lot of money, but somehow never seems to have enough.

Problem Description
Larry graduated this year and finally has a job. He’s making a lot of money, but somehow never seems to have enough. Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems. The first step is to figure out what’s been going on with his money. Larry has his bank account statements and wants to see how much money he has. Help Larry by writing a program to take his closing balance from each of the past twelve months and calculate his average account balance.

Input
The input will be twelve lines. Each line will contain the closing balance of his bank account for a particular month. Each number will be positive and displayed to the penny. No dollar sign will be included.

Output
The output will be a single number, the average (mean) of the closing balances for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign, and followed by the end-of-line. There will be no other spaces or characters in the output.

Sample Input
100.00
489.12
12454.12
1234.10
823.05
109.20
5.27
1542.25
839.18
83.99
1295.01
1.75

Sample Output
$1581.42

import java.util.*;
class Main {
   public static void main(String args[]){
      Scanner sc = new Scanner(System.in);
      double sum =0 ;
      for(int i=0 ;i<12;i++){
         double a=  sc.nextDouble();
         sum+=a;

      }
      System.out.print("$");
      System.out.printf("%.2f",sum/12);
      System.out.println();
   }
}
目录
相关文章
|
存储 弹性计算 分布式计算
NHCP H2: Computer Resource Management Topic | Cloud computing
HCNP云计算2:计算机资源管理
167 0
|
安全
Information Systems Security Assessment – Open information security framework
The Information Systems Security Assessment Framework (ISSAF) seeks to integrate the following m...
1007 0
HDOJ 1064Financial Management
HDOJ 1064Financial Management
118 0
HDOJ 1064 Financial Management
HDOJ 1064 Financial Management
93 0
|
JavaScript Oracle 关系型数据库
Uptime And Monitoring Strategies For Cloud-Based E-Commerce Applications/Websites
In order to keep your e-commerce site functioning properly, you need to take positive steps to monitor both its performance and functionality.
1540 0
|
Oracle 关系型数据库 应用服务中间件