HDOJ 2052 Picture

简介: Problem Description Give you the width and height of the rectangle,darw it.Input Input contains a number of test cases.

Problem Description
Give you the width and height of the rectangle,darw it.

Input
Input contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.

Output
For each case,you should draw a rectangle with the width and height giving in the input.
after each case, you should a blank line.

Sample Input
3 2

Sample Output
+---+
|   |
|   |
+---+

别忘了每一个输出后面空一行

import java.util.Scanner;

public class Main {

    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        while(sc.hasNext()){
            int m = sc.nextInt();
            int n = sc.nextInt();

            for(int i=0;i<n+2;i++){

                for(int j=0;j<m+2;j++){
                    if(i==0){
                        if(j==0||j==m+1){
                            System.out.print("+");
                        }else{
                            System.out.print("-");
                        }
                    }else if(i==n+1){
                        if(j==0||j==m+1){
                            System.out.print("+");
                        }else{
                            System.out.print("-");
                        }
                    }else {
                        if(j==0||j==m+1){
                            System.out.print("|");
                        }else{
                            System.out.print(" ");
                        }
                    }
                }
                System.out.println();
            }
            System.out.println();

        }


    }

}
目录
相关文章
|
自然语言处理 网络协议 Unix
有趣的Code Poster
有趣的Code Poster
有趣的Code Poster
HDOJ 1326 Box of Bricks(简单题)
HDOJ 1326 Box of Bricks(简单题)
104 0
HDOJ 1326 Box of Bricks(简单题)
HDOJ 2052 Picture
HDOJ 2052 Picture
92 0
HDOJ 1089 A+B for Input-Output Practice (I)
HDOJ 1089 A+B for Input-Output Practice (I)
107 0
HDOJ 1093 A+B for Input-Output Practice (V)
HDOJ 1093 A+B for Input-Output Practice (V)
89 0
HDOJ 1090 A+B for Input-Output Practice (II)
HDOJ 1090 A+B for Input-Output Practice (II)
87 0
HDOJ 1091 A+B for Input-Output Practice (III)
HDOJ 1091 A+B for Input-Output Practice (III)
95 0
HDOJ 1092 A+B for Input-Output Practice (IV)
HDOJ 1092 A+B for Input-Output Practice (IV)
115 0
|
机器学习/深度学习
HDOJ 1390 Binary Numbers(进制问题)
HDOJ 1390 Binary Numbers(进制问题)
112 0
HDOJ 2057 A + B Again
HDOJ 2057 A + B Again
102 0