HDOJ 1212 Big Number

简介: Problem Description As we know, Big Number is always troublesome. But it’s really important in our ACM.

Problem Description
As we know, Big Number is always troublesome. But it’s really important in our ACM. And today, your task is to write a program to calculate A mod B.

To make the problem easier, I promise that B will be smaller than 100000.

Is it too hard? No, I work it out in 10 minutes, and my program contains less than 25 lines.

Input
The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000, and B will be smaller than 100000. Process to the end of file.

Output
For each test case, you have to ouput the result of A mod B.

Sample Input
2 3
12 7
152455856554521 3250

Sample Output
2
5
1521

public BigDecimal remainder(BigDecimal divisor)返回其值为 (this % divisor) 的 BigDecimal。
余数由 this.subtract(this.divideToIntegralValue(divisor).multiply(divisor)) 给出。注意,这不是模操作(结果可以为负)。
参数:
divisor - 此 BigDecimal 要除以的值。
返回:
this % divisor。

import java.math.BigDecimal;
import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        while(sc.hasNext()){
            BigDecimal a = sc.nextBigDecimal();
            int b = sc.nextInt();
            System.out.println(a.remainder(new BigDecimal(b)));
        }
    }

}
目录
相关文章
|
前端开发
HDOJ 1212 Big Number
HDOJ 1212 Big Number
105 0
HDOJ1018Big Number
HDOJ1018Big Number
104 0
HDOJ 1005 Number Sequence
HDOJ 1005 Number Sequence
95 0
HDOJ 1093 A+B for Input-Output Practice (V)
HDOJ 1093 A+B for Input-Output Practice (V)
89 0
HDOJ 1090 A+B for Input-Output Practice (II)
HDOJ 1090 A+B for Input-Output Practice (II)
87 0
HDOJ 1089 A+B for Input-Output Practice (I)
HDOJ 1089 A+B for Input-Output Practice (I)
107 0
HDOJ 1091 A+B for Input-Output Practice (III)
HDOJ 1091 A+B for Input-Output Practice (III)
95 0
|
机器学习/深度学习
POJ 1423 Big Number
POJ 1423 Big Number
95 0