HDOJ 1390 Binary Numbers(进制问题)

简介: Problem Description Given a positive integer n, find the positions of all 1’s in its binary representation.

Problem Description
Given a positive integer n, find the positions of all 1’s in its binary representation. The position of the least significant bit is 0.

Example

The positions of 1’s in the binary representation of 13 are 0, 2, 3.

Task

Write a program which for each data set:

reads a positive integer n,

computes the positions of 1’s in the binary representation of n,

writes the result.

Input
The first line of the input contains exactly one positive integer d equal to the number of data sets, 1 <= d <= 10. The data sets follow.

Each data set consists of exactly one line containing exactly one integer n, 1 <= n <= 10^6.

Output
The output should consists of exactly d lines, one line for each data set.

Line i, 1 <= i <= d, should contain increasing sequence of integers separated by single spaces - the positions of 1’s in the binary representation of the i-th input number.

Sample Input
1
13

Sample Output
0 2 3

思路:
就是输入一个数n,n二进制假如为m。
就是输出二进制m这个数的1所在的位数。从小到大输出。
例如:输入13.
13的二进制数是1101;
所以输出为:0 2 3
注意,最后一个数字后面没有接空格。

import java.util.Scanner;

public class Main{
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int t = sc.nextInt();
        while(t-->0){
            int n =sc.nextInt();
            String nstr = Integer.toString(n, 2);
            //System.out.println(nstr);
            boolean isOne=true;
            for(int i=nstr.length()-1;i>=0;i--){
                if(nstr.charAt(i)=='1'){
                    if(isOne){
                        System.out.print(nstr.length()-1-i);
                        isOne=false;
                    }else{
                        System.out.print(" "+(nstr.length()-1-i));
                    }
                }
            }
            System.out.println();

        }
    }

}
目录
相关文章
|
机器学习/深度学习 Java
HDOJ 2095 find your present (2)
HDOJ 2095 find your present (2)
106 0
HDOJ 2095 find your present (2)
|
机器学习/深度学习
HDOJ 1390 Binary Numbers(进制问题)
HDOJ 1390 Binary Numbers(进制问题)
112 0
|
前端开发
HDOJ 1212 Big Number
HDOJ 1212 Big Number
105 0
HDOJ1018Big Number
HDOJ1018Big Number
104 0
HDOJ 2101 A + B Problem Too
HDOJ 2101 A + B Problem Too
100 0
HDOJ 1002 A + B Problem II
HDOJ 1002 A + B Problem II
113 0
HDOJ 1405 The Last Practice
HDOJ 1405 The Last Practice
92 0
HDOJ 2058 The sum problem
HDOJ 2058 The sum problem
107 0
HDOJ 2055 An easy problem
HDOJ 2055 An easy problem
104 0
|
Java
HDOJ 1000 A + B Problem
HDOJ 1000 A + B Problem
107 0