HDOJ 1397 Goldbach's Conjecture(快速筛选素数法)

简介: Problem Description Goldbach’s Conjecture: For any even number n greater than or equal to 4, there exists at least one pair of prime numbers p1 and p2 such that n = p1 + p2.

Problem Description
Goldbach’s Conjecture: For any even number n greater than or equal to 4, there exists at least one pair of prime numbers p1 and p2 such that n = p1 + p2.
This conjecture has not been proved nor refused yet. No one is sure whether this conjecture actually holds. However, one can find such a pair of prime numbers, if any, for a given even number. The problem here is to write a program that reports the number of all the pairs of prime numbers satisfying the condition in the conjecture for a given even number.

A sequence of even numbers is given as input. Corresponding to each number, the program should output the number of pairs mentioned above. Notice that we are interested in the number of essentially different pairs and therefore you should not count (p1, p2) and (p2, p1) separately as two different pairs.

Input
An integer is given in each input line. You may assume that each integer is even, and is greater than or equal to 4 and less than 2^15. The end of the input is indicated by a number 0.

Output
Each output line should contain an integer number. No other characters should appear in the output.

Sample Input
6
10
12
0

Sample Output
1
2
1

题意:
哥德巴赫猜想:任何偶数n大于或等于4,至少存在一对素数P1和P2,n=p1+p2。p1+p2和p2+p1是一样的。
本题是统计有多少对不同的素数和等于n.

注意用到素数筛选,然后打表就可以得出答案了。

import java.util.Scanner;

public class Main{
    static int[] db = new int[65536];
    public static void main(String[] args) {
        dabiao();
        //System.out.println(Math.pow(2, 15));-32768
        Scanner sc = new Scanner(System.in);
        while(sc.hasNext()){
            int n = sc.nextInt();
            if(n==0){
                return ;
            }
            int tp = 0;
            for(int i=1;i<=n/2;i++){

                if(db[i]==1&&db[n-i]==1){
                    tp++;
                }
            }
            System.out.println(tp);

        }

    }

    //快速筛选素数
    private static void dabiao() {
        for(int i=0;i<db.length;i++){
            db[i]=1;
        }
        db[0]=0;
        db[1]=0;
        for(int i=2;i<=Math.sqrt(db.length);i++){
            for(int j=i+i;j<db.length;j=j+i){
                if(db[i]==1){
                    db[j]=0;
                }
            }
        }

//      for(int i=0;i<1000;i++){
//          if(db[i]==1){
//              System.out.println(i);
//          }
//      }
    }

}
目录
相关文章
|
5月前
求出这个数列的前20项之和
求出这个数列的前20项之和。
46 11
|
9月前
等差素数列
等差素数列
42 0
|
9月前
|
存储 算法
算法题解-组合总和3
算法题解-组合总和3
|
9月前
|
Java
leetcode-377:组合总和 Ⅳ
leetcode-377:组合总和 Ⅳ
54 0
|
9月前
|
C++
『C/C++』Eg1:数列的前20项之和
『C/C++』Eg1:数列的前20项之和
leetcode:39.组合总和
给定一个无重复元素的数组 candidates和一个目标数 target,找出 candidates中所有可以使数字和为 target的组合。
79 0
LeetCode 39. 组合总和
LeetCode 39. 组合总和
98 0
力扣40. 组合总和 IIJava
力扣40. 组合总和 IIJava
73 0