HDOJ(HDU) 1708 Fibonacci String

简介: Problem Description After little Jim learned Fibonacci Number in the class , he was very interest in it.

Problem Description
After little Jim learned Fibonacci Number in the class , he was very interest in it.
Now he is thinking about a new thing – Fibonacci String .

He defines : str[n] = str[n-1] + str[n-2] ( n > 1 )

He is so crazying that if someone gives him two strings str[0] and str[1], he will calculate the str[2],str[3],str[4] , str[5]….

For example :
If str[0] = “ab”; str[1] = “bc”;
he will get the result , str[2]=”abbc”, str[3]=”bcabbc” , str[4]=”abbcbcabbc” …………;

As the string is too long ,Jim can’t write down all the strings in paper. So he just want to know how many times each letter appears in Kth Fibonacci String . Can you help him ?

Input
The first line contains a integer N which indicates the number of test cases.
Then N cases follow.
In each case,there are two strings str[0], str[1] and a integer K (0 <= K < 50) which are separated by a blank.
The string in the input will only contains less than 30 low-case letters.

Output
For each case,you should count how many times each letter appears in the Kth Fibonacci String and print out them in the format “X:N”.
If you still have some questions, look the sample output carefully.
Please output a blank line after each test case.

To make the problem easier, you can assume the result will in the range of int.

Sample Input
1
ab bc 3

Sample Output
a:1
b:3
c:2
d:0
e:0
f:0
g:0
h:0
i:0
j:0
k:0
l:0
m:0
n:0
o:0
p:0
q:0
r:0
s:0
t:0
u:0
v:0
w:0
x:0
y:0
z:0

格式:每个案例后面都有一个空行!!!

不能直接用字符串相加来做,因为可能到后面会超内存!累加到后面的字符串太长了!!!

所以换位思考,既然是统计字母的个数,为什么不直接来建立整型数组呢。
只要统计出str0和str1中各个字母的个数就可以了。
后面各个字母个数的按照公式来推就行。

import java.util.Scanner;

public class Main{
    public static void main(String[] args) {
        long num[][] = new long[56][26];
        Scanner sc = new Scanner(System.in);
        int t = sc.nextInt();
        while(t-->0){
            for(int i=0;i<num[0].length;i++){
                for(int j=0;j<num.length;j++){
                    num[j][i]=0;
                }
            }
            String str0 = sc.next();
            for(int i=0;i<str0.length();i++){
                for(int j='a';j<='z';j++){
                    if(str0.charAt(i)==(char)j){
                        num[0][j-'a']++;
                        break;
                    }
                }
            }
            String str1 = sc.next();
            for(int i=0;i<str1.length();i++){
                for(int j='a';j<='z';j++){
                    if(str1.charAt(i)==(char)j){
                        num[1][j-'a']++;
                        break;
                    }
                }
            }
            int n = sc.nextInt();
            for(int i=2;i<=n;i++){
                for(int k='a';k<='z';k++){
                    num[i][k-'a'] = num[i-1][k-'a']+num[i-2][k-'a'];
                }
            }

            for(int k='a';k<='z';k++){
                System.out.println((char)k+":"+num[n][k-'a']);
            }
            System.out.println();

        }
    }


}
目录
相关文章
LeetCode 258. Add Digits
给定一个非负整数 num,反复将各个位上的数字相加,直到结果为一位数。
66 0
LeetCode 258. Add Digits
ZOJ - Problem Set - 3985 String of CCPC
ZOJ - Problem Set - 3985 String of CCPC
92 0
HDOJ(HDU) 1708 Fibonacci String
HDOJ(HDU) 1708 Fibonacci String
88 0
|
Java
HDOJ/HDU 2539 点球大战(String.endsWith()方法的一个应用~)
HDOJ/HDU 2539 点球大战(String.endsWith()方法的一个应用~)
96 0
|
机器学习/深度学习 Java C语言
HDOJ(HDU) 2137 circumgyrate the string(此题用Java-AC不过!坑)
HDOJ(HDU) 2137 circumgyrate the string(此题用Java-AC不过!坑)
101 0
|
Java C语言
HDOJ(HDU) 2139 Calculate the formula(水题,又一个用JavaAC不了的题目)
HDOJ(HDU) 2139 Calculate the formula(水题,又一个用JavaAC不了的题目)
95 0
ZOJ Problem Set - 3758 素数
ZOJ Problem Set - 3758 素数
97 0
LeetCode之Add Digits
LeetCode之Add Digits
102 0
hdu 3336 Count the string
点击打开链接hdu 3336 思路:kmp+next数组的应用 分析: 1 题目要求的是给定一个字符串s,求字符串s的所有的前缀在s的匹配的次数之和mod10007. 2 很明显n1,为什么要从n开始而不是1开始呢,这里因为是要求前缀的匹配数而不是后缀; 4 求sum的时候注意每一步都有可能超过范围,所以就要求一次sum同时取模一次。
845 1