HDOJ(HDU) 1877 又一版 A+B(进制、、)

简介: Problem Description 输入两个不超过整型定义的非负10进制整数A和B(

Problem Description
输入两个不超过整型定义的非负10进制整数A和B(<=231-1),输出A+B的m (1 < m <10)进制数。

Input
输入格式:测试输入包含若干测试用例。每个测试用例占一行,给出m和A,B的值。
当m为0时输入结束。

Output
输出格式:每个测试用例的输出占一行,输出A+B的m进制数。

Sample Input
8 1300 48
2 1 7
0

Sample Output
2504
1000

java强大的Integer.toString方法秒解!

import java.util.Scanner;

public class Main{

    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);

        while(sc.hasNext()){
            int m  =sc.nextInt();
            if(m==0){
                return ;
            }
            int a = sc.nextInt();
            int b = sc.nextInt(); 
            String s = (a+b)+"";
            System.out.println( Integer.toString(a+b, m) );
        }
    }
}
目录
相关文章
|
5月前
|
Java
hdu-2546-饭卡
hdu-2546-饭卡
25 0
|
11月前
|
Java
hdu 1257 最少拦截系统
hdu 1257 最少拦截系统
41 0
HDU 2669 Romantic
题意:找出最小的非负整数X,使之满足式子X*a + Y*b = 1。
106 0
|
C++
HDU1862
中文题,题意挺好理解,不过多赘述。
1261 0