HDOJ(HDU) 1977 Consecutive sum II(推导、、)

简介: Problem Description Consecutive sum come again. Are you ready? Go ~~ 1 = 0 + 1 2+3+4 = 1 + 8 5+6+7+8+9 = 8 + 27 … You can see the consecutive sum can be representing like that.

Problem Description
Consecutive sum come again. Are you ready? Go ~~
1 = 0 + 1
2+3+4 = 1 + 8
5+6+7+8+9 = 8 + 27

You can see the consecutive sum can be representing like that. The nth line will have 2*n+1 consecutive numbers on the left, the first number on the right equal with the second number in last line, and the sum of left numbers equal with two number’s sum on the right.
Your task is that tell me the right numbers in the nth line.

Input
The first integer is T, and T lines will follow.
Each line will contain an integer N (0 <= N <= 2100000).

Output
For each case, output the right numbers in the Nth line.
All answer in the range of signed 64-bits integer.

Sample Input
3
0
1
2

Sample Output
0 1
1 8
8 27

看到有很多人的这个题目是找规律做的,我开始没注意规律了,
就打表做了。。。。
现在给出2种能AC的方法:

第一种:打表:

import java.util.Scanner;

public class Main{
    static long[] db1 = new long[2100005];
    public static void main(String[] args) {
        dabiao();
        //System.out.println("aa");
        Scanner sc = new Scanner(System.in);
        int t = sc.nextInt();
        while(t-->0){
            int n = sc.nextInt();
            System.out.println(db1[n]+" "+db1[n+1]);
        }
    }
    private static void dabiao() {
        db1[0] = 0;
        db1[1] = 1;
        db1[2] = 8;
        db1[3] = 27;
        long k=9;
        long num =7;
        Scanner sc = new Scanner(System.in);
        for(int i=4;i<=2100001;i++){
            db1[i] =(k+num/2+1)*num-db1[i-1];
//          System.out.println(k);
//          System.out.println(num/2+1);
//          
//          System.out.println(i);
//          System.out.println(db1[i]);
//          System.out.println((k+num/2+1)*num);
//          int m = sc.nextInt();
            k=k+num;
            num+=2;

        }
    }
}

第二种:找规律:

import java.util.Scanner;

public class Main {

    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int t  =sc.nextInt();

        while(t-->0){
            long n =sc.nextLong();
            System.out.println(n*n*n+" "+(n+1)*(n+1)*(n+1));
        }
    }
}
目录
相关文章
LeetCode 216. Combination Sum III
找出所有相加之和为 n 的 k 个数的组合。组合中只允许含有 1 - 9 的正整数,并且每种组合中不存在重复的数字。
102 0
LeetCode 216. Combination Sum III
LeetCode 39. Combination Sum
给定一个无重复元素的数组 candidates 和一个目标数 target ,找出 candidates 中所有可以使数字和为 target 的组合。 candidates 中的数字可以无限制重复被选取。
68 0
LeetCode 39. Combination Sum
HDOJ 1391 Number Steps(打表DP)
HDOJ 1391 Number Steps(打表DP)
121 0
HDOJ 1391 Number Steps(打表DP)
HDOJ 1016 Prime Ring Problem素数环【深搜】
HDOJ 1016 Prime Ring Problem素数环【深搜】
112 0
HDOJ 1016 Prime Ring Problem素数环【深搜】
|
Go
HDOJ(HDU) 1977 Consecutive sum II(推导、、)
HDOJ(HDU) 1977 Consecutive sum II(推导、、)
104 0
HDOJ(HDU) 2136 Largest prime factor(素数筛选)
HDOJ(HDU) 2136 Largest prime factor(素数筛选)
106 0
HDOJ(HDU) 1898 Sempr == The Best Problem Solver?(水题、、、)
HDOJ(HDU) 1898 Sempr == The Best Problem Solver?(水题、、、)
120 0
|
C语言
HDOJ 1016 Prime Ring Problem素数环【深搜2】
HDOJ 1016 Prime Ring Problem素数环【深搜】
95 0
|
人工智能 Java