HDOJ(HDU) 1985 Conversions(汇率转换)

本文涉及的产品
传统型负载均衡 CLB,每月750个小时 15LCU
应用型负载均衡 ALB,每月750个小时 15LCU
EMR Serverless StarRocks,5000CU*H 48000GB*H
简介: Problem Description Conversion between the metric and English measurement systems is relatively simple.

Problem Description
Conversion between the metric and English measurement systems is relatively simple. Often, it involves either multiplying or dividing by a constant. You must write a program that converts between the following units:

Input
The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.
Each dataset consists of a single line of input containing a floating point (double precision) number, a space and the unit specification for the measurement to be converted. The unit specification is one of kg, lb, l, or g referring to kilograms, pounds, liters and gallons respectively.

Output
For each dataset, you should generate one line of output with the following values: The dataset number as a decimal integer (start counting at one), a space, and the appropriately converted value rounded to 4 decimal places, a space and the unit specification for the converted value.

Sample Input
5
1 kg
2 l
7 lb
3.5 g
0 l

Sample Output
1 2.2046 lb
2 0.5284 g
3 3.1752 kg
4 13.2489 l
5 0.0000 g

题目很简单,就是给出了汇率,让你转换!!!
水题!

import java.util.Scanner;

public class Main{
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        String[] str1 = {"kg","l","lb","g"};
        String[] str2 = {"lb","g","kg","l"};
        double[]  d = {2.2046,0.2642,0.4536,3.7854};
        int time = 1;
        int t = sc.nextInt();
        while(t-->0){
            int k=0;
            double n = sc.nextDouble();
            String s = sc.next();
            for(int i=0;i<str1.length;i++){
                if(s.equals(str1[i])){
                    k=i;
                    n = n*d[i];
                    break;
                }
            }
            System.out.printf("%d %.4f %s",time,n,str2[k] );
            System.out.println();
            time++;
        }


    }

}
相关实践学习
SLB负载均衡实践
本场景通过使用阿里云负载均衡 SLB 以及对负载均衡 SLB 后端服务器 ECS 的权重进行修改,快速解决服务器响应速度慢的问题
负载均衡入门与产品使用指南
负载均衡(Server Load Balancer)是对多台云服务器进行流量分发的负载均衡服务,可以通过流量分发扩展应用系统对外的服务能力,通过消除单点故障提升应用系统的可用性。 本课程主要介绍负载均衡的相关技术以及阿里云负载均衡产品的使用方法。
目录
相关文章
|
开发者
斐波那契数列——UPC
题目描述 斐波那契数列F满足如下性质:F1=1,F2=2,Fi+2=Fi+1+Fi。 对于一个正整数n,它可以表示成一些不同的斐波那契数列中的数的和。你需要求出:有多少种不同的方式可以表示出n?
115 0
|
知识图谱
HDOJ(HDU) 1985 Conversions(汇率转换)
HDOJ(HDU) 1985 Conversions(汇率转换)
119 0
|
Java
HDOJ(HDU) 2502 月之数(进制)
HDOJ(HDU) 2502 月之数(进制)
109 0
HDOJ(HDU) 1994 利息计算(简单题目)
HDOJ(HDU) 1994 利息计算(简单题目)
107 0
|
测试技术
HDOJ(HDU) 1860 统计字符
HDOJ(HDU) 1860 统计字符
102 0
HDOJ/HDU 2566 统计硬币(公式~遍历~)
HDOJ/HDU 2566 统计硬币(公式~遍历~)
146 0
HDOJ(HDU) 1465 不容易系列之一(错排)
HDOJ(HDU) 1465 不容易系列之一(错排)
86 0
HDOJ(HDU) 2304 Electrical Outlets(求和、、)
HDOJ(HDU) 2304 Electrical Outlets(求和、、)
107 0
|
Go
HDOJ/HDU 1133 Buy the Ticket(数论~卡特兰数~大数~)
HDOJ/HDU 1133 Buy the Ticket(数论~卡特兰数~大数~)
108 0
HDOJ/HDU 2561 第二小整数(水题~排序~)
HDOJ/HDU 2561 第二小整数(水题~排序~)
112 0