JAVA刚碰见的问题( java.lang.SecurityException: The jurisdiction policy files are not signed by a trusted signer)-阿里云开发者社区

开发者社区> 杰克.陈> 正文

JAVA刚碰见的问题( java.lang.SecurityException: The jurisdiction policy files are not signed by a trusted signer)

简介: 原文: 刚碰见的问题 1.  failed to load the jni shared library jre bin server jvm.dll           解决:这个主要是eclipse的版本和安装的jdk版本不相同。
+关注继续查看

原文: 刚碰见的问题

1.  failed to load the jni shared library jre bin server jvm.dll

          解决:这个主要是eclipse的版本和安装的jdk版本不相同。

2.  java.lang.SecurityException: The jurisdiction policy files are not signed by a trusted signer!

         解决:主要是因为加密文件的版本和jdk的版本加密文件不相同。查看主类(local_policy.jar,US_export_policy.jar)和jdk的加密文件的版本不相同。

         目录C:\Program Files\Java\jdk1.6.0_45\jre\lib\security\下的local_policy.jar,US_export_policy.jar

     与 目录C:\Program Files\Java\jre6\lib\security\下的local_policy.jar,US_export_policy.jar版本不一样

  JCE8: http://www.oracle.com/technetwork/java/javase/downloads/jce8-download-2133166.html

  JCE7: http://www.oracle.com/technetwork/java/embedded/embedded-se/downloads/jce-7-download-432124.html

  JCE6: http://www.oracle.com/technetwork/java/javase/downloads/jce-6-download-429243.html

  JCE5-1.4:http://www.oracle.com/technetwork/java/javasebusiness/downloads/java-archive-downloads-java-plat-419418.html#jce_policy-1.5.0-oth-JPR

 

 

         参考:http://stackoverflow.com/questions/9745193/java-lang-securityexception-the-jurisdiction-policy-files-are-not-signed-by-a-t

                     http://stackoverflow.com/questions/18754243/securityexception-even-after-replacing-crypto-policy-jars

3.  安装不同版本jdk后,java  -version不同的问题

        解决:我先安装的jdk7,然后在安装jdk6,之前的path全部替换成jdk6,但是执行java -version后显示的还是jdk7,我去。。。 我用的是windows,挺操蛋的windows直接写进注册表了,于是只能卸载掉,重新安装重新配置环境。。。

4. Eclipse The JRE could not be found. Edit the server and change the JRE location.

       解决:eclipse->windows->prefrence->server->runtime environment->然后编辑你的tomcat->添加jdk

5.  struts2刨析:http://www.iteye.com/topic/829843

6.  unable to install breakpoint in

       Eclipse Unable to install breakpoint in  的问题总算解决了,重装eclipse无效,最后只有到window-preferences-java-compiler下面 
把Add line number attributes..前的勾去掉,然后apply-OK。再window-preferences-java-compiler把勾打上,再apply-OK,问题才解决了,网上有人说这个问题是因为既使用ant编译又使用eclipse编译造成的,依然是困惑中。。。

版权声明:本文为博主原创文章,未经博主允许不得转载。

版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

相关文章
Failed to get D-Bus connection: Operation not permitted —解决Docker中CentOS镜像无法使用systemd的问题
解决Docker中CentOS镜像无法使用systemd的问题:Failed to get D-Bus connection: Operation not permitted
8662 0
struts/Servlet,action转到jsp后,路径问题(struts2,jsp路径,action路径,action跳转,相对路径,绝对路径)
问题:使用struts2,如何处理action的路径?还有,在action转到的jsp中,如何写js,css,图 片的路径?(例如访问 http://localhost/project/listUser.action后转到http://localhost/project/user /listUser.jsp,这时候浏览器还是停留在http://localhost/project/addUser.action。
888 0
解决UnicodeEncodeError: 'ascii' codec can't encode characters in position 问题(转)
UnicodeEncodeError: 'ascii' codec can't encode characters in position 8-11: ordinal not in range(128) 解决UnicodeEncodeError: 'ascii' codec can't encode characters in position 转自:http://cooler1217.
1081 0
解决sitemesh3装饰页面不能使用freemarker标签问题
如题,这个问题其实在sitemesh2中已经很好的解决了,不过在sitemesh3中可能没有解决,所以要自己写代码解决了,下面我先讲下sitemesh2是如何解决的: sitemesh-freemarker com.
884 0
Visual Studio 2010 起始页中 不显示最近使用的项目问题,解决办法
最近新装了vs2010,发现打开vs2010 后 起始页面中的最近使用的栏目中 并未显示最近加载的项目 解决办法如下: 运行 regedit 打开下面的键值: HKEY_CURRENT_USER/Software/Microsoft/Windows/CurrentVersion/Policie...
486 0
Microsoft Visual Studio与Firefly 一直提示加载项目,更新源码状态问题
        笔记本一开始安装的是vs2010,由于近期开发要用vs2008与vs2005于是今天又把2008、2005安装上了,但在打开项目的时候,先是提示加载项目文件,然后一直提示更新源码状态,很慢很慢的,之前只有vs2010的时候,打开是很快的,现在不管是用2008、2005、2010就没有一个快的,源码管理用的是firefly,有人知道为什么会出现这种情况吗?        
1003 0
+关注
杰克.陈
一个安静的程序猿~
10427
文章
2
问答
文章排行榜
最热
最新
相关电子书
更多
《2021云上架构与运维峰会演讲合集》
立即下载
《零基础CSS入门教程》
立即下载
《零基础HTML入门教程》
立即下载