some command on different platform

简介:                           Linux         Solaris                                                          ...

    

                    

Linux        

Solaris                                                         

HPUX                      

AIX              

Mac                                                                        

 

Description

SLES

RHEL

Ubuntu

x86

Sparc

ia64

HP-PARISC

 

 

Install package

rpm -i <package file>

dpkg -i <package file>

pkgadd -d <package file> <package>

swinstall -s <full path to depot> <package name>

installp -X -d <package file> <package name>

installer -pkg <package file> -tgt LocalSystem

Remove package

rpm -e <package>

dpkg -r <package>

pkgrm <package>

swremove <package name>

installp -u <package name>

/usr/libexec/microsoft/domain1/bin/domain1Uninstall.sh (specific for DOMAIN1)

Upgrade package

rpm -U <package>

dpkg -i <package file>

N.A.

swinstall -s <full path to depot> <package name>

 

 

Package info

rpm -q domain1

dpkg -l <package>

pkginfo -l MSFTdomain1

swlist domain1

lslpp -l domain1.rte

pkgutil --pkgs[=<name>]

Start service

/etc/init.d/<service> start

invoke-rc.d <service> start

svcadm enable <name>

Pre10: /etc/init.d/<service> start

/sbin/init.d/<service> start

startsrc -s <subsystem>

launchctl load -w <service path>

Stop service

/etc/init.d/<service> stop

invoke-rc.d <service> stop

svcadm disable <name>

Pre10: /etc/init.d/<service> stop

/sbin/init.d/<service> stop

stopsrc -s <subsystem>

launchctl unload -w <service path>

Service Status

/etc/init.d/<service> status

-

svcs <name>

Pre10: N/A

/sbin/init.d/<service> status

lssrc -s <subsystem>

launchctl -list

"Top"-command

top

prstat

top

topas

top

Library path

LD_LIBRARY_PATH

 

LD_LIBRARY_PATH

SHLIB_PATH(32-bit) LD_LIBRARY_PATH(64-bit)

LIBPATH

DYLD_LIBRARY_PATH

Get certificate info

openssl x509 -in <certificate file (pem format)> -noout -text

Show exported symbols

nm <library>

dump -HTv <library>

nm <library>

List shared library dependencies

ldd <file>

otool -L <file>

目录
打赏
0
0
0
0
20
分享
相关文章
成功解决ERROR: Unable to find the development tool `cc` in your path; please make sure that you have the
成功解决ERROR: Unable to find the development tool `cc` in your path; please make sure that you have the
成功解决ERROR: Unable to find the development tool `cc` in your path; please make sure that you have the
plugin cannot be loaded for module “QtQuick“ && Could not load the Qt platform plugin “windows“
本文讨论了在Qt应用程序中遇到的平台插件加载问题,包括具体的错误信息、解决方案和参考链接。问题表现为无法加载“QtQuick”模块的插件,并且无法找到“windows”平台插件。解决方案是修改环境变量`Qt5_DIR`以使用正确的Qt版本和编译器环境。
261 1
vs2019 This application failed to start because it could not find or load the QT platform plugin
这篇文章介绍了在VS2019中解决QT程序运行时出现的“无法找到或加载QT平台插件”错误的步骤,通过将必要的DLL文件和插件目录复制到项目解决方案中解决了问题。
使用docker 启动naocs 报错出现:standard_init_linux.go:241: exec user process caused "exec format error"
```markdown Error in Docker container startup: &quot;standard_init_linux.go:241: exec user process caused \&quot;exec format error\&quot;&quot;. Occurred at 2024-06-29 09:26:19.910, followed by a failed hook with a syslog delivery error at 09:27:20.193. Seeking solutions from experts. ```
Qtdesigner报错:This application failed to stat could not find or load the Qt platform plugin “windows“
Qtdesigner报错:This application failed to stat could not find or load the Qt platform plugin “windows“
notsup Unsupported platform for n@7.3.1: wanted {“os“:“!win32“,“arch“:“any“} (current: {“os“:“win32“
notsup Unsupported platform for n@7.3.1: wanted {“os“:“!win32“,“arch“:“any“} (current: {“os“:“win32“
481 0
notsup Unsupported platform for n@7.3.1: wanted {“os“:“!win32“,“arch“:“any“} (current: {“os“:“win32“
OCI runtime exec failed: exec failed: unable to start container process: exec: "mongo": executable file not found in $PATH: unknown
OCI runtime exec failed: exec failed: unable to start container process: exec: "mongo": executable file not found in $PATH: unknown
1188 0
OCI runtime exec failed: exec failed: unable to start container process: exec: "mongo": executable file not found in $PATH: unknown
x86_64-linux-gnu/libgdk-x11-2.0.so: error adding symbols: DSO missing from command line
x86_64-linux-gnu/libgdk-x11-2.0.so: error adding symbols: DSO missing from command line
264 0