在项目中切换thinkphp框架的版本-阿里云开发者社区

开发者社区> 开发与运维> 正文
登录阅读全文

在项目中切换thinkphp框架的版本

简介: 学习使用thinkphp 的过程中,由于thinkphp不断的升级,有时在3.0上的代码就不一能在3.1.3上使用, 百思不得其解啊,没有办法还要工作啊,不知道怎么处理,先写吧, 将thinkphp3.0  3.1.2 3.1.3三个版本的核心放到项目目录,然后在index.php中修改成合适的版本 define('CORE', 'ThinkPHP2'); require(CORE
学习使用thinkphp 的过程中,由于thinkphp不断的升级,有时在3.0上的代码就不一能在3.1.3上使用,
百思不得其解啊,没有办法还要工作啊,不知道怎么处理,先写吧,
将thinkphp3.0  3.1.2 3.1.3三个版本的核心放到项目目录,然后在index.php中修改成合适的版本
define('CORE', 'ThinkPHP2');
require(CORE . '/ThinkPHP.php');
先用3.0的写一部分,调试好了,然后在升级到新的版本,
比如我现在使用3.0的时候,使用分组就正常,但是切换到3.1.3就只显示空白,不怎么是怎么回事,也不报错,就是空白,切换到3.12就没有问题了
有时间了再解决吧

版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

分享:
开发与运维
使用钉钉扫一扫加入圈子
+ 订阅

集结各类场景实战经验,助你开发运维畅行无忧

其他文章