HDU4716-A Computer Graphics Problem

简介:

A Computer Graphics Problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 693    Accepted Submission(s): 522


Problem Description
In this problem we talk about the study of Computer Graphics. Of course, this is very, very hard.
We have designed a new mobile phone, your task is to write a interface to display battery powers.
Here we use '.' as empty grids.
When the battery is empty, the interface will look like this:
*------------*
|............|
|............|
|............|
|............|
|............|
|............|
|............|
|............|
|............|
|............|
*------------*

When the battery is 60% full, the interface will look like this:
*------------*
|............|
|............|
|............|
|............|
|------------|
|------------|
|------------|
|------------|
|------------|
|------------|
*------------*

Each line there are 14 characters.
Given the battery power the mobile phone left, say x%, your task is to output the corresponding interface. Here x will always be a multiple of 10, and never exceeds 100.
 

Input
The first line has a number T (T < 10) , indicating the number of test cases.
For each test case there is a single line with a number x. (0 < x < 100, x is a multiple of 10)
 

Output
For test case X, output "Case #X:" at the first line. Then output the corresponding interface.
See sample output for more details.
 

Sample Input
 
 
2 0 60
 

Sample Output
 
 
Case #1: *------------* |............| |............| |............| |............| |............| |............| |............| |............| |............| |............| *------------* Case #2: *------------* |............| |............| |............| |............| |------------| |------------| |------------| |------------| |------------| |------------| *------------*
 

Source
 


 

偷懒水一题......

#include<stdio.h>
#include<string.h>
char a[50][50];
int main()
{
    int i,j,n,m,num,k=1;
    scanf("%d",&n);
    while(n--)
    {
       scanf("%d",&m);
       memset(a,0,sizeof(a));
       num=10-(m/10)+1;
       for(i=0;i<12;i++)
       {
           for(j=0;j<14;j++)
           {
             if(i==0||i==11)
             {
               if(j==0||j==13)
               a[i][j]='*';
               else
               a[i][j]='-';
             }
             else 
             if(j==0||j==13)
             {
                a[i][j]='|'; 
             }
             else
             {
                 if(num>0)
                 {
                   a[i][j]='.';
                 }
                 else
                 a[i][j]='-';
             }
           }
           num--;
       }
       printf("Case #%d:\n",k++);
       for(i=0;i<12;i++)
       {
          for(j=0;j<14;j++)
          printf("%c",a[i][j]);
          puts("");
       }
    }
    return 0;
}


 

相关文章
|
10月前
|
图形学
hdu1086 You can Solve a Geometry Problem too(判断线段相交)
hdu1086 You can Solve a Geometry Problem too(判断线段相交)
54 0
|
机器学习/深度学习
AtCoder Beginner Contest 218 C - Shapes (模拟)
AtCoder Beginner Contest 218 C - Shapes (模拟)
130 0
|
Java 文件存储
HDOJ(HDU) 2123 An easy problem(简单题...)
HDOJ(HDU) 2123 An easy problem(简单题...)
149 0
|
机器学习/深度学习 自然语言处理
|
Java
HDU 5882 Balanced Game
Balanced Game Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 508    Accepted Submission(s): ...
830 0
|
人工智能 Java 安全
HDU 1039 Easier Done Than Said?
Easier Done Than Said? Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 12751    Accepted Subm...
798 0