HDU4813-Hard Code

简介:
Hard Code

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 217    Accepted Submission(s): 170

Problem Description
Some strange code is sent to Da Shan High School. It's said to be the prophet's note. The note is extremely hard to understand. However, Professor Meng is so smart that he successfully found the pattern of the code. That is, the length of the code is the product of two prime numbers. He tries to reallocate the code into a grid of size N*M, where M is the bigger prime. In specific, he writes down the letters of the code to the cells one by one, from left to right, and from top to button. In this way, he found the code eventually readable.

Professor Meng wants to know all the secrets of the note right now. But he doesn't take his computer with him. Can you help him?
 
Input
The first line of the input is L (L ≤ 1000), which means the number of test cases.

For each test case, the first line contains two prime numbers, which indicates N, M (0 < N * M ≤ 1000) as describe above. The second line contains a string, i.e., the code, containing only lowercase letters. It’s guaranteed the length of the string equals to N * M.
 
Output
For each test case, output N lines, each line with M letters representing the readable code after the reallocation.
 
Sample Input
1
2 5
klmbbileay

Sample Output
klmbb
ileay

Source
2013 Asia Regional Changchun



//简单字符串分离

AC代码:

#include<stdio.h>
#include<string.h>
char word[2000],value[1000];
int main()
{
    int i,j,x,n,m,T,len;
    scanf("%d",&T);
    while(T--)
    {
         scanf("%d %d",&n,&m);
         scanf("%s",word);
         len=strlen(word);
         j=0;x=0;
         for(i=0;i<len;i++)
         {
             j++;value[j-1]=word[i];
             if(j==m)
             {
                 printf("%s\n",value);
                 x++;
                 memset(value,0,sizeof(value));
                 j=0;
             }
             if(x==n)
             break;
         }
    }
    return 0;
}



相关文章
|
2月前
|
流计算
POJ 3620--Avoid The Lakes【DFS】
POJ 3620--Avoid The Lakes【DFS】
16 0
|
2月前
Strange fuction(HDU--2899)
Strange fuction(HDU--2899)
LeetCode 383. Ransom Note
给定一个赎金信 (ransom) 字符串和一个杂志(magazine)字符串,判断第一个字符串ransom能不能由第二个字符串magazines里面的字符构成。如果可以构成,返回 true ;否则返回 false。
53 0
LeetCode 383. Ransom Note
HDU-1097,A hard puzzle(快速幂)
HDU-1097,A hard puzzle(快速幂)
|
Web App开发 Java 数据安全/隐私保护
HDOJ(HDU) 1563 Find your present!(异或)
HDOJ(HDU) 1563 Find your present!(异或)
223 0
|
Java
HDOJ 1097 A hard puzzle(循环问题)
HDOJ 1097 A hard puzzle(循环问题)
109 0
HDOJ(HDU) 1673 Optimal Parking
HDOJ(HDU) 1673 Optimal Parking
109 0
LeetCode之Ransom Note
LeetCode之Ransom Note
98 0