【北大夏令营笔记-并查集】poj1611-The Suspects

简介:
The Suspects
Time Limit: 1000MS Memory Limit: 20000K
Total Submissions: 21517 Accepted: 10422
Description


Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
Once a member in a group is a suspect, all members in the group are suspects. 
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n?1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output

For each case, output the number of suspects in one line.
Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0
Sample Output

4
1
1
Source

Asia Kaohsiung 2003



//题意,有一些学生,加入了一些社团,包括0。一旦0患病,和他有关的人(同一团体)都是嫌疑对象。

问有多少嫌疑对象

//思路:并查集,将所有与0有关的人都放在同一集合,并把与0有关
的人所在的社团的所有人数统计

AC代码:

#include<stdio.h>
#define MAX 30000
int parent[MAX+10];
int total[MAX+10];
//total[Get_Root(a)]是a所在社团的人数 
int Get_Root(int x)
{
    //获取a的根,并把a父节点改为根 
    if(parent[x]!=x)
      parent[x]=Get_Root(parent[x]);
    return parent[x];
}
void Merge(int x,int y)
{
     x=Get_Root(x);
     y=Get_Root(y);
     if(x==y)
     return;
     parent[y]=x;
     total[x]+=total[y];
}
int main()
{
    int i,j,n,m,k,x,y;
    while(scanf("%d %d",&n,&m)!=EOF)
    {
        if(n==0&&m==0)
        break;
        for(i=0;i<n;i++)
        {
           parent[i]=i;
           total[i]=1;
        }
        for(i=0;i<m;i++)
        {
           scanf("%d",&x);
           scanf("%d",&k);
           x--;
           while(x--)
           {
              scanf("%d",&y);
              Merge(k,y);
           }
        }
        printf("%d\n",total[Get_Root(0)]);
    }
    return 0;
}



相关文章
|
6月前
|
存储 人工智能 测试技术
2020年第十一届蓝桥杯模拟赛解题报告
2020年第十一届蓝桥杯模拟赛解题报告
|
存储
【蓝桥杯冲刺】蓝桥杯12届省赛C++b组真题-填空题
【蓝桥杯冲刺】蓝桥杯12届省赛C++b组真题-填空题
98 1
【蓝桥杯冲刺】蓝桥杯11届省赛C++b组真题-填空题
【蓝桥杯冲刺】蓝桥杯11届省赛C++b组真题-填空题
124 0
|
人工智能 测试技术 BI
【蓝桥杯冲刺】蓝桥杯11届省赛C++b组真题-编程题
【蓝桥杯冲刺】蓝桥杯11届省赛C++b组真题-编程题
106 0
|
测试技术
【蓝桥杯冲刺】蓝桥杯13届省赛C++b组真题-A~E题
【蓝桥杯冲刺】蓝桥杯13届省赛C++b组真题-A~E题
140 0
|
6月前
|
Windows
孤独的树(牛客月赛)
孤独的树(牛客月赛)
35 0
|
存储 算法 Java
【AcWing每日一题】4818. 奶牛大学
【AcWing每日一题】4818. 奶牛大学
115 0
|
人工智能 测试技术
【蓝桥杯冲刺】蓝桥杯12届省赛C++b组真题-编程题
【蓝桥杯冲刺】蓝桥杯12届省赛C++b组真题-编程题
105 0
|
算法 测试技术
蓝桥杯2022年第十三届决赛真题-卡牌——二分法
蓝桥杯2022年第十三届决赛真题-卡牌——二分法
123 0
|
JavaScript BI
【蓝桥杯集训·周赛】AcWing 第96场周赛
文章目录 第一题 AcWing 4876. 完美数 一、题目 1、原题链接 2、题目描述 二、解题报告 1、思路分析 2、时间复杂度 3、代码详解 第二题 AcWing 4877. 最大价值 一、题目 1、原题链接 2、题目描述 二、解题报告 1、思路分析 2、时间复杂度 3、代码详解 第三题 AcWing 4878. 维护数组 一、题目 1、原题链接 2、题目描述 二、解题报告 1、思路分析 2、时间复杂度 3、代码详解
85 0