【北大夏令营笔记-并查集】poj1611-The Suspects

简介:
The Suspects
Time Limit: 1000MS Memory Limit: 20000K
Total Submissions: 21517 Accepted: 10422
Description


Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
Once a member in a group is a suspect, all members in the group are suspects. 
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n?1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output

For each case, output the number of suspects in one line.
Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0
Sample Output

4
1
1
Source

Asia Kaohsiung 2003



//题意,有一些学生,加入了一些社团,包括0。一旦0患病,和他有关的人(同一团体)都是嫌疑对象。

问有多少嫌疑对象

//思路:并查集,将所有与0有关的人都放在同一集合,并把与0有关
的人所在的社团的所有人数统计

AC代码:

#include<stdio.h>
#define MAX 30000
int parent[MAX+10];
int total[MAX+10];
//total[Get_Root(a)]是a所在社团的人数 
int Get_Root(int x)
{
    //获取a的根,并把a父节点改为根 
    if(parent[x]!=x)
      parent[x]=Get_Root(parent[x]);
    return parent[x];
}
void Merge(int x,int y)
{
     x=Get_Root(x);
     y=Get_Root(y);
     if(x==y)
     return;
     parent[y]=x;
     total[x]+=total[y];
}
int main()
{
    int i,j,n,m,k,x,y;
    while(scanf("%d %d",&n,&m)!=EOF)
    {
        if(n==0&&m==0)
        break;
        for(i=0;i<n;i++)
        {
           parent[i]=i;
           total[i]=1;
        }
        for(i=0;i<m;i++)
        {
           scanf("%d",&x);
           scanf("%d",&k);
           x--;
           while(x--)
           {
              scanf("%d",&y);
              Merge(k,y);
           }
        }
        printf("%d\n",total[Get_Root(0)]);
    }
    return 0;
}



相关文章
|
2月前
|
存储 人工智能 测试技术
2020年第十一届蓝桥杯模拟赛解题报告
2020年第十一届蓝桥杯模拟赛解题报告
|
2月前
|
Windows
孤独的树(牛客月赛)
孤独的树(牛客月赛)
19 0
|
11月前
|
存储 算法 Java
【AcWing每日一题】4818. 奶牛大学
【AcWing每日一题】4818. 奶牛大学
92 0
|
12月前
|
人工智能 BI
《蓝桥杯每日一题》并查集·AcWing1249. 亲戚
《蓝桥杯每日一题》并查集·AcWing1249. 亲戚
39 0
|
12月前
|
机器学习/深度学习 C++
ACM刷题之路(十七)二分 2019暑期集训 POJ2785
ACM刷题之路(十七)二分 2019暑期集训 POJ2785
|
算法 测试技术
蓝桥杯2022年第十三届决赛真题-卡牌——二分法
蓝桥杯2022年第十三届决赛真题-卡牌——二分法
96 0
|
存储 算法
【蓝桥杯集训·每日一题】AcWing 3728. 城市通电
文章目录 一、题目 1、原题链接 2、题目描述 二、解题报告 1、思路分析 2、时间复杂度 3、代码详解 三、知识风暴 Prim算法
69 0
|
存储 机器学习/深度学习 人工智能
【蓝桥杯集训·周赛】AcWing 第94场周赛
文章目录 第一题 AcWing 4870. 装物品 一、题目 1、原题链接 2、题目描述 二、解题报告 1、思路分析 2、时间复杂度 3、代码详解 第二题 AcWing 4871. 最早时刻 一、题目 1、原题链接 2、题目描述 二、解题报告 1、思路分析 2、时间复杂度 3、代码详解 第三题 AcWing 4872. 最短路之和 一、题目 1、原题链接 2、题目描述 二、解题报告 1、思路分析 2、时间复杂度 3、代码详解
51 0
|
机器学习/深度学习 物联网 C++
【LGR-(-17)】洛谷入门赛 #8个人思考
某 E 在 2022 年的幸运数字是 x xx,这个数可能是正的,也可能是负的。 某 E 想要知道 x   m o d   2023 x \bmod 2023xmod2023 的值。其中,  m o d   \bmodmod 是取模操作。也就是说,你需要求出 x xx 除以 2023 20232023 的余数,这个余数必须是非负整数。 例如,2022   m o d   2023 = 2022 2022 \bmod 2023 = 20222022mod2023=2022,2025   m o d   2023 = 2 2025 \bmod 2023 = 22025mod2023=2,− 2
301 0
|
存储 人工智能 BI
【蓝桥杯集训·每日一题】AcWing 1249. 亲戚
文章目录 一、题目 1、原题链接 2、题目描述 二、解题报告 1、思路分析 2、时间复杂度 3、代码详解 三、知识风暴 并查集
60 0