POJ1979-Red and Black

简介:

Red and Black
Time Limit: 1000MS  Memory Limit: 30000K
Total Submissions: 22250  Accepted: 12011

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0
Sample Output

45
59
6
13

Source

Japan 2004 Domestic

 

 

问题描述:有一间长方形的房子,地上铺了红色、黑色两种颜色的正方形瓷砖。你站在其中一块黑色的瓷砖上,只能向相邻的黑色瓷砖移动。请写一个程序,计算你总共能够到达多少块黑色的瓷砖。

算法:设f(x,y)为从点(x,y)出发能够走过的黑瓷砖总数,则
f(x,y) = 1+f(x-1,y)+f(x+1,y)+f(x,y-1)+f(x,y+1)
这里需要注意,凡是走过的瓷砖不能够被重复走过

AC代码:

#include<stdio.h>
#include<string.h>
//方块四周加白色块,去掉边界判断,
//使得递归统一终止于白色块
int Rank[22][22];
int FindBlack(int c,int l)
{
   if(Rank[c][l]==2)//出口条件(防止重复走)
   return 0;
   else Rank[c][l]=2;
   return 1+FindBlack(c+1,l)+FindBlack(c-1,l)+FindBlack(c,l-1)+FindBlack(c,l+1);//递归函数
}
int main()
{
    int i,j,c,l,n,m;
    char x;
    while(scanf("%d %d",&m,&n),n!=0&&m!=0)
    {
       max=0;
       for(i=0;i<22;i++)
       for(j=0;j<22;j++)
       Rank[i][j]=2;
       for(i=1;i<=n;i++)
       {  
          getchar();
          for(j=1;j<=m;j++)
          {  
              scanf("%c",&x);
              if(x=='.')
              Rank[i][j]=1;
              else
              {
                 if(x=='#')
                 Rank[i][j]=2;
                 else
                 {
                     c=i;l=j;
                     Rank[i][j]=1; 
                 }
              }
          }
       }
       printf("%d\n",FindBlack(c,l));
    }
    return 0;
}
相关文章
|
24天前
|
Java
hdu-1312-Red and Black
hdu-1312-Red and Black
17 0
|
1月前
利用ellipse and rectangle画图
利用ellipse and rectangle画图。
27 7
|
11月前
HDU - 1312 Red and Black(DFS)
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles. Write a program to count the number of black
60 0
|
10月前
UVa837 - Light and Transparencies(排序)
UVa837 - Light and Transparencies(排序)
41 0
hdu 1312 Red and Black
一个人从@点出发,求他所能到达的'.'的数目,'#'不可走,@本身算1个点。 思路:搜索入门题。
129 0
HDOJ 1312 (POJ 1979) Red and Black
HDOJ 1312 (POJ 1979) Red and Black
96 0
|
机器学习/深度学习
HDOJ/HDU 1556 Color the ball(树状数组)
HDOJ/HDU 1556 Color the ball(树状数组)
88 0