HDU1548-A strange lift【广搜做法】

简介:

A strange lift

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11510    Accepted Submission(s): 4362


Problem Description
There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist.
Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button "UP" or "DOWN"?
 

Input
The input consists of several test cases.,Each test case contains two lines.
The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.
A single 0 indicate the end of the input.
 

Output
For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".
 

Sample Input
 
 
5 1 5 3 3 1 2 5 0
 

Sample Output
 
 
3
 

Recommend
8600   |   We have carefully selected several similar problems for you:   1385  1242  1142  1217  2066 
 
 
 
 
 
 
 
题意:一个特别的电梯,按up可升上k[i]层,到大i+k[i]层,down则到达i-k[i]层,最高不能超过n
,最低不能小于1,给你一个起点和终点,问最少可以按几次到达目的地。
思路:搜索,采用广度优先搜索,被搜过的情况要计算,下次之搜之前没到过的楼层
AC代码:
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<queue>
using namespace std;
int a[210],n,flag[210];
void BFS(int s,int t)
{
   int v;
   queue<int> q;
   q.push(s);
   flag[s]=1;
   while(!q.empty())
   {
       v=q.front();
       q.pop();
       if(v==t)
         break;
       if(v+a[v]<=n&&flag[v+a[v]]==0)//向上 
       {
          q.push(v+a[v]);
          flag[v+a[v]]=flag[v]+1;
       } 
       
       if(v-a[v]>=1&&flag[v-a[v]]==0)//向下 
       {
          q.push(v-a[v]);
          flag[v-a[v]]=flag[v]+1;
       }
   }
   if(v!=t)
     flag[t]=0;
   
}
int main()
{
    int i,j,s,t;
    while(scanf("%d %d %d",&n,&s,&t),n!=0)
    {
       for(i=1;i<=n;i++)
       {
          scanf("%d",&a[i]);
       }
       memset(flag,0,sizeof(flag));
       BFS(s,t);
       printf("%d\n",flag[t]-1);
    }
    return 0;
}
相关文章
|
10月前
|
算法
The kth great number(小根堆思想,模板题)
The kth great number(小根堆思想,模板题)
30 0
The kth great number(小根堆思想,模板题)
AtCoder Beginner Contest 216 D - Pair of Balls (思维建图 拓扑排序判断有向图是否有环)
AtCoder Beginner Contest 216 D - Pair of Balls (思维建图 拓扑排序判断有向图是否有环)
98 0
AtCoder Beginner Contest 223 D - Restricted Permutation(建图 思维 构造 拓扑排序)
AtCoder Beginner Contest 223 D - Restricted Permutation(建图 思维 构造 拓扑排序)
95 0
|
人工智能 vr&ar
SPOJ - COT Count on a tree(主席树 LCA)
SPOJ - COT Count on a tree(主席树 LCA)
75 0
2019CCPC秦皇岛HDU - 6736 F - Forest Program(dfs找环 组合数学)
2019CCPC秦皇岛HDU - 6736 F - Forest Program(dfs找环 组合数学)
83 0
AtCoder Beginner Contest 216 G - 01Sequence (并查集 贪心 树状数组 差分约束)
AtCoder Beginner Contest 216 G - 01Sequence (并查集 贪心 树状数组 差分约束)
125 0
|
人工智能 Java
[HDU 7136] Jumping Monkey | 并查集 | 逆向思维
Jumping Monkey Time Limit: 8000/4000 MS (Java/Others) Memory Limit: 262144/262144 K (Java/Others) Total Submission(s): 747 Accepted Submission(s): 360
198 0
[HDU 7136] Jumping Monkey | 并查集 | 逆向思维
|
人工智能 BI
[UVA 1599] Ideal Path | 细节最短路
Description New labyrinth attraction is open in New Lostland amusement park. The labyrinth consists of n rooms connected by m passages. Each passage is colored into some color ci .
179 0
|
算法 Go
HDU-1548,A strange lift(Dijkstra)
HDU-1548,A strange lift(Dijkstra)
|
C语言
HDOJ/HDU Tempter of the Bone(深搜+奇偶性剪枝)
HDOJ/HDU Tempter of the Bone(深搜+奇偶性剪枝)
85 0