【最大子矩阵和】HDU1081-To The Max

简介:

To The Max

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8193    Accepted Submission(s): 3981


Problem Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2

is in the lower left corner:

9 2
-4 1
-1 8

and has a sum of 15.
 

Input
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
 

Output
Output the sum of the maximal sub-rectangle.
 

Sample Input
4
0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
 

Sample Output
15
 

Source
Greater New York 2001

 

最大子矩阵和
关于最大子矩阵和的做法探讨详细请看:http://blog.csdn.net/acmman/article/details/38580931
AC代码:

#include <stdio.h>
#include <string.h>
#include <limits.h>
#define MAXN 200
int a[MAXN][MAXN],temp[MAXN];
int n;
int getsum()
{
   int i,sum=0,max=0;
   for(i=0;i<n;i++)
   {
      sum+=temp[i];
      if(sum>max) max=sum;
      if(sum<0) sum=0; 
   }
   return max;
}
int main()
{
    int i,j,ans,k; 
 while(scanf("%d",&n)!=EOF)
    {
       memset(a,0,sizeof(a));
    for(i=0;i<n;i++)
         for(j=0;j<n;j++)
         scanf("%d",&a[i][j]);
      ans=INT_MIN;
      for(i=0;i<n;i++)//从第i行开始 
      {
         memset(temp,0,sizeof(temp));
         for(j=i;j<n;j++)//从 i行到 n-1行都尝试一次 
         {
            for(k=0;k<n;k++)//把 j至 k行的每一列都加起来,就是矩阵压缩 
             temp[k]+=a[j][k]; 
             
             int pre=getsum();//计算压缩矩阵形成的一维数组的最长连续序列 
             if(ans<pre)//更新最大值 
                ans=pre; 
         }
      } 
      printf("%d\n",ans);
 }
 return 0;
}
相关文章
|
2月前
|
人工智能 Java
HDU-1003- Max Sum (动态规划)
HDU-1003- Max Sum (动态规划)
17 0
P1216 [USACO1.5][IOI1994]数字三角形 Number Triangles
P1216 [USACO1.5][IOI1994]数字三角形 Number Triangles
POJ 1844 Sum
POJ 1844 Sum
87 0
|
BI 人工智能
|
机器学习/深度学习 人工智能
|
存储 人工智能 算法
HDU 1024 Max Sum Plus Plus【动态规划求最大M子段和详解 】
Max Sum Plus Plus Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 29942    Accepted Submissio...
2369 0