The Famous Clock
时间限制:
1000 ms | 内存限制:
65535 KB
难度:
1
- 描述
-
Mr. B, Mr. G and Mr. M are now in Warsaw, Poland, for the 2012’s ACM-ICPC World Finals Contest. They’ve decided to take a 5 hours training every day before the contest. Also, they plan to start training at 10:00 each day since the World Final Contest will do so. The scenery in Warsaw is so attractive that Mr. B would always like to take a walk outside for a while after breakfast. However, Mr. B have to go back before training starts, otherwise his teammates will be annoyed. Here is a problem: Mr. B does not have a watch. In order to know the exact time, he has bought a new watch in Warsaw, but all the numbers on that watch are represented in Roman Numerals. Mr. B cannot understand such kind of numbers. Can you translate for him?
- 输入
- Each test case contains a single line indicating a Roman Numerals that to be translated. All the numbers can be found on clocks. That is, each number in the input represents an integer between 1 and 12. Roman Numerals are expressed by strings consisting of uppercase ‘I’, ‘V’ and ‘X’. See the sample input for further information.
- 输出
- For each test case, display a single line containing a decimal number corresponding to the given Roman Numerals.
- 样例输入
-
I II III IV V VI VII VIII IX X XI XII
- 样例输出
-
Case 1: 1 Case 2: 2 Case 3: 3 Case 4: 4 Case 5: 5 Case 6: 6 Case 7: 7 Case 8: 8 Case 9: 9 Case 10: 10 Case 11: 11 Case 12: 12
查看代码---运行号:252406----结果:Accepted
运行时间:
2012-10-05 19:47:00 | 运行人:
huangyibiao
01.
#include <string>
02.
#include <iostream>
03.
using
namespace
std;
04.
05.
int
main()
06.
{
07.
string s;
08.
int
count = 0;
09.
while
(cin >> s)
10.
{
11.
cout <<
"Case "
<< ++count <<
": "
;
12.
if
(s ==
"I"
)
13.
cout <<
"1\n"
;
14.
else
if
(s ==
"II"
)
15.
cout <<
"2\n"
;
16.
else
if
(s ==
"III"
)
17.
cout <<
"3\n"
;
18.
else
if
(s ==
"IV"
)
19.
cout <<
"4\n"
;
20.
else
if
(s ==
"V"
)
21.
cout <<
"5\n"
;
22.
else
if
(s ==
"VI"
)
23.
cout <<
"6\n"
;
24.
else
if
(s ==
"VII"
)
25.
cout <<
"7\n"
;
26.
else
if
(s ==
"VIII"
)
27.
cout <<
"8\n"
;
28.
else
if
(s ==
"IX"
)
29.
cout <<
"9\n"
;
30.
else
if
(s ==
"X"
)
31.
cout <<
"10\n"
;
32.
else
if
(s ==
"XI"
)
33.
cout <<
"11\n"
;
34.
else
if
(s ==
"XII"
)
35.
cout <<
"12\n"
;
36.
}
37.
return
0;
38.
}