NEFU 659

简介:

//今天刚写的代码,有可能不是很简洁,但是刚开始嘛,不能像那些大牛是的那么厉害的,如果写的不好,请多多包涵。。。

description

 
We know that if a phone number A is another phone number B’s prefix, B is not able to be called. For an example, A is 123 while B is 12345, after pressing 123, we call A, and not able to call B.
Given N phone numbers, your task is to find whether there exits two numbers A and B that A is B’s prefix.

input

 
Input
The input consists of several test cases.
The first line of input in each test case contains one integer N (0 < N < 1001), represent the number of phone numbers.
The next line contains N integers, describing the phone numbers.
The last case is followed by a line containing one zero.

output

 
For each test case, if there exits a phone number that cannot be called, print “NO”, otherwise print “YES” instead.

sample_input

 
2
012
012345
2
12
012345
0

sample_output

 
NO
YES

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
struct sa
{
char st[1000];
int l;
}data[1005];
int main()
{
int m;
while(~scanf("%d",&m)&&m!=0)
{
int flag=0;
for(int i=0;i<m;i++)
{
scanf("%s",data[i].st);
data[i].l=strlen(data[i].st);
}
for(int i=0;i<m;i++)
{
for(int j=i+1;j<m;j++)
{
int k=0;
while(1)
{

if(data[i].st[k]==data[j].st[k])
k++;
else
break;
if(k==data[i].l)
flag=1;
}
k=0;
}
}
if(flag==0)cout<<"YES"<<endl;
else cout<<"NO"<<endl;
}
return 0;
}


目录
相关文章
|
6月前
|
Java Spring 容器
SpringAop
SpringAop
55 0
|
XML 监控 Java
SpringAOP介绍与使用
SpringAOP介绍与使用
68 0
|
Java Spring
|
Java Spring 容器
@ComponentScan的特点
@ComponentScan的特点
|
XML Java 数据格式
SpringAOP(一)
SpringAOP(一)
|
Java 数据库连接 数据库
SpringAOP(三)
SpringAOP(三)
|
数据安全/隐私保护
SpringAOP(二)
SpringAOP(二)
|
数据安全/隐私保护
SpringAOP(四)
SpringAOP(四)
|
XML 缓存 Java
|
Java Spring 容器
Spring中的Autowired、Qualifier、Resource注解详解
使用Spring系列的框架对这三个注解肯定都不会陌生,这三个注解有一个特性,就是用于属性注入,说白了点就是将Spring容器中的对象取出来,这样我们才可以使用,那么这三者到底是什么关系,又有什么区别呢?
611 0