链表4(法二)------7-4 sdut-C语言实验-单链表中重复元素的删除

简介: 链表4(法二)------7-4 sdut-C语言实验-单链表中重复元素的删除

7-4 sdut-C语言实验-单链表中重复元素的删除

分数 20

全屏浏览

切换布局

作者 马新娟

单位 山东理工大学

按照数据输入的相反顺序(逆位序)建立一个单链表,并将单链表中重复的元素删除(值相同的元素只保留最后输入的一个)。

输入格式:

第一行输入元素个数 n (1 <= n <= 15);

第二行输入 n 个整数,保证在 int 范围内。

输出格式:

第一行输出初始链表元素个数;

第二行输出按照逆位序所建立的初始链表;

第三行输出删除重复元素后的单链表元素个数;

第四行输出删除重复元素后的单链表。


输入样例:

1. 10
2. 21 30 14 55 32 63 11 30 55 30

输出样例:

10
30 55 30 11 63 32 55 14 30 21
7
30 55 11 63 32 14 21
 
 


代码长度限制

16 KB

时间限制

400 ms

内存限制

64 MB

栈限制

8192 KB


#include <stdio.h>
#include <stdlib.h>
struct node
{
    int data;
    struct node*next;
};
int main()
{
    struct node*p,*head,*q,*t;
    int n,i,a;
    scanf("%d",&n);
    head=(struct node*)malloc(sizeof(struct node));
    head->next=NULL;
    for(i=0;i<n;i++)
    {
        p=(struct node*)malloc(sizeof(struct node));
        p->next=head->next;
     scanf("%d",&p->data);
        head->next=p;
    }
    printf("%d\n",n);
    p=head->next;
    while(p)
    {
        if(p->next)
        {
            printf("%d ",p->data);
        }
        else{
            printf("%d\n",p->data);
        }
        p=p->next;
    }
    t=head->next;
    while(t)
    {
        p=t;
        q=t->next;
        while(q)
        {
            if(q->data==t->data)
            {
                p->next=q->next;
                q=q->next;
                n--;
            }
            else{
                q=q->next;
                p=p->next;
            }
        }
        t=t->next;
 
    }
    printf("%d\n",n);
    p=head->next;
    while(p)
    {
        if(p->next)
        {
            printf("%d ",p->data);
        }
        else{
            printf("%d\n",p->data);
        }
        p=p->next;
    }
 
    return 0;
}
目录
相关文章
|
3天前
链表9(优化版)7-9 sdut-C语言实验-约瑟夫问题
链表9(优化版)7-9 sdut-C语言实验-约瑟夫问题
7 0
|
3天前
链表5(考试用)7-5 sdut-C语言实验-链表的逆置
链表5(考试用)7-5 sdut-C语言实验-链表的逆置
7 0
|
3天前
链表8(法二考试专用)7-8 sdut-C语言实验-双向链表
链表8(法二考试专用)7-8 sdut-C语言实验-双向链表
4 0
|
3天前
链表6(法二好理解)------ 7-6 sdut-C语言实验-有序链表的归并分数 20
链表6(法二好理解)------ 7-6 sdut-C语言实验-有序链表的归并分数 20
4 0
|
2月前
【移除链表元素】LeetCode第203题讲解
【移除链表元素】LeetCode第203题讲解
|
27天前
|
存储 SQL 算法
LeetCode力扣第114题:多种算法实现 将二叉树展开为链表
LeetCode力扣第114题:多种算法实现 将二叉树展开为链表
|
27天前
|
存储 SQL 算法
LeetCode 题目 86:分隔链表
LeetCode 题目 86:分隔链表
|
1月前
|
存储 算法 Java
【经典算法】Leetcode 141. 环形链表(Java/C/Python3实现含注释说明,Easy)
【经典算法】Leetcode 141. 环形链表(Java/C/Python3实现含注释说明,Easy)
11 2
|
2月前
<数据结构>五道LeetCode链表题分析.环形链表,反转链表,合并链表,找中间节点.
<数据结构>五道LeetCode链表题分析.环形链表,反转链表,合并链表,找中间节点
28 1
|
24天前
|
算法
【经典LeetCode算法题目专栏分类】【第7期】快慢指针与链表
【经典LeetCode算法题目专栏分类】【第7期】快慢指针与链表