Poj 2386 Lake Counting

简介:

click here~~

                                                       ***Lake Counting***


Time Limit: 1000MS  Memory Limit: 65536K 
Total Submissions: 24201  Accepted: 12216 

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input
10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output
3

解题思路:
dfs  ,注意从8个方面进行搜索:
上代码:

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;


int n,m,ans;
char map[110][110];

bool judge(int i,int j)
{
    if(i>=n || i<0)
        return false;
    if(j>=m || j<0)
        return false;
    if(map[i][j] == '.')
        return false;
    return true;
}

void dfs(int i,int j)
{
    map[i][j] = '.';
    if(judge(i+1, j))
        dfs(i+1, j);
    if(judge(i, j+1))
        dfs(i, j+1);
    if(judge(i-1, j))
        dfs(i-1, j);
    if(judge(i, j-1))
        dfs(i, j-1);
    if(judge(i+1, j+1))
        dfs(i+1, j+1);
    if(judge(i-1, j-1))
        dfs(i-1, j-1);
    if(judge(i+1, j-1))
        dfs(i+1, j-1);
    if(judge(i-1, j+1))
        dfs(i-1, j+1);
}

int main()
{
    while(cin>>n>>m)
    {
        getchar();
        ans=0;
        for(int i=0; i<n; i++)
            gets(map[i]);
        for(int i=0; i<n; i++)
        {
            for(int j=0; j<m; j++)
            {
                if(map[i][j] == 'W')
                {
                    ans++;
                    dfs(i,j);
                }
            }
        }
        cout<<ans<<endl;
    }
    return 0;
}
目录
相关文章
poj 3624 Charm Bracelet(简单01背包)
Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.
39 0
华为机试HJ75:公共子串计算
华为机试HJ75:公共子串计算
P2852 [USACO06DEC]牛奶模式Milk Patterns 后缀数组(poj3261)
P2852 [USACO06DEC]牛奶模式Milk Patterns 后缀数组(poj3261)
96 0
HDU-2602,Bone Collector(01背包)
HDU-2602,Bone Collector(01背包)
[HDU7073] Integers Have Friends 2.0 -随机大法好
题意: 找到最大的一个集合,使得集合内所有元素 % m(>=2) 问最大的集合大小
94 0
[HDU7073] Integers Have Friends 2.0 -随机大法好
HDU-3635,Dragon Balls(有点难度的并查集。。。)
HDU-3635,Dragon Balls(有点难度的并查集。。。)
|
搜索推荐 算法