hdu 3038D - How Many Answers Are Wrong [kuangbin带你飞]专题五 并查集

简介:

点击打开链接

 

How Many Answers Are Wrong

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4106    Accepted Submission(s): 1571


Problem Description
TT and FF are ... friends. Uh... very very good friends -________-b

FF is a bad boy, he is always wooing TT to play the following game with him. This is a very humdrum game. To begin with, TT should write down a sequence of integers-_-!!(bored).

Then, FF can choose a continuous subsequence from it(for example the subsequence from the third to the fifth integer inclusively). After that, FF will ask TT what the sum of the subsequence he chose is. The next, TT will answer FF's question. Then, FF can redo this process. In the end, FF must work out the entire sequence of integers.

Boring~~Boring~~a very very boring game!!! TT doesn't want to play with FF at all. To punish FF, she often tells FF the wrong answers on purpose.

The bad boy is not a fool man. FF detects some answers are incompatible. Of course, these contradictions make it difficult to calculate the sequence.

However, TT is a nice and lovely girl. She doesn't have the heart to be hard on FF. To save time, she guarantees that the answers are all right if there is no logical mistakes indeed.

What's more, if FF finds an answer to be wrong, he will ignore it when judging next answers.

But there will be so many questions that poor FF can't make sure whether the current answer is right or wrong in a moment. So he decides to write a program to help him with this matter. The program will receive a series of questions from FF together with the answers FF has received from TT. The aim of this program is to find how many answers are wrong. Only by ignoring the wrong answers can FF work out the entire sequence of integers. Poor FF has no time to do this job. And now he is asking for your help~(Why asking trouble for himself~~Bad boy)
 

Input
Line 1: Two integers, N and M (1 <= N <= 200000, 1 <= M <= 40000). Means TT wrote N integers and FF asked her M questions.

Line 2..M+1: Line i+1 contains three integer: Ai, Bi and Si. Means TT answered FF that the sum from Ai to Bi is Si. It's guaranteed that 0 < Ai <= Bi <= N.

You can assume that any sum of subsequence is fit in 32-bit integer.
 

Output
A single line with a integer denotes how many answers are wrong.
 

Sample Input
 
     
10 5 1 10 100 7 10 28 1 3 32 4 6 41 6 6 1
 

Sample Output
 
     
1

题目大意:

找有几个数据是错误的,具体我给你们样例解释,首先输入一个m 和 n,

m表示有区间的最大值,然后有n行数 u, v, w

分别表示[u, v] == w,看有几个矛盾的

解题思路:

种类并查集,就是找u-1就行了,看是否能够找到他们的父亲是一样的,

具体详见代码


样例解释:

1 - 10 -> 100

7 - 10 ->28

1 - 3 -> 32

4 - 6-> 41

6 - 6 -> 1 

可以将1-3和4-6结合 == 1-6,然后在与7-10结合 == 1-10

32+41==73  + 28==101!=100

所以有一个是错误的

上代码:


/**
2015 - 09 - 19 中午

Author: ITAK

Motto:

今日的我要超越昨日的我,明日的我要胜过今日的我,
以创作出更好的代码为目标,不断地超越自己。
**/
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <vector>
#include <queue>
#include <algorithm>
#include <set>
using namespace std;
typedef long long LL;
const int maxn = 200005;
const double eps = 1e-7;

struct node
{
    int x, y;
} arr[maxn];

int rank[maxn], fa[maxn], sum[maxn];
int w, ans;
///基本上是模板
void Init(int x)
{
    for(int i=0; i<=x; i++)
    {
        fa[i] = i;
        ///rank[i] = 0;
        sum[i] = 0;
    }
}

int Find(int x)
{
    int t;
    if(fa[x] != x)
    {
        t = fa[x];
        fa[x] = Find(fa[x]);
        sum[x] += sum[t];
    }
    return fa[x];
}

void Union(int x, int y)
{
    int fx = Find(x), fy = Find(y);
    if(fx == fy)
    {
        if(sum[y] != sum[x]+w)
            ans++;
        return;
    }
    if(fx > fy)
    {
        fa[fx] = fy;
        sum[fx] = sum[y]-sum[x]-w;
    }
    else
    {
        fa[fy] = fx;
        sum[fy] = sum[x]+w-sum[y];
    }
}

int main()
{
    int m, n;
    int u, v;
    while(cin>>m>>n)
    {
        ans = 0;
        Init(m);

        while(n--)
        {
            cin>>u>>v>>w;
            Union(u-1, v);
        }
        cout<<ans<<endl;
    }
    return 0;
}


目录
相关文章
|
7月前
|
算法
The kth great number(小根堆思想,模板题)
The kth great number(小根堆思想,模板题)
21 0
The kth great number(小根堆思想,模板题)
|
8月前
|
网络架构
POJ 3250 Bad Hair Day、POJ 2796 Feel Good(单调栈)
POJ 3250 Bad Hair Day、POJ 2796 Feel Good(单调栈)
CodeForces 1195C Basketball Exercise (线性DP)
CodeForces 1195C Basketball Exercise (线性DP)
84 0
[HDU7073] Integers Have Friends 2.0 -随机大法好
题意: 找到最大的一个集合,使得集合内所有元素 % m(>=2) 问最大的集合大小
76 0
[HDU7073] Integers Have Friends 2.0 -随机大法好
|
人工智能 Java
[HDU 7136] Jumping Monkey | 并查集 | 逆向思维
Jumping Monkey Time Limit: 8000/4000 MS (Java/Others) Memory Limit: 262144/262144 K (Java/Others) Total Submission(s): 747 Accepted Submission(s): 360
186 0
[HDU 7136] Jumping Monkey | 并查集 | 逆向思维
|
数据挖掘
HDU-1032,The 3n + 1 problem(水题)
HDU-1032,The 3n + 1 problem(水题)
HDOJ/HDU 1372 Knight Moves(经典BFS)
HDOJ/HDU 1372 Knight Moves(经典BFS)
93 0
HDOJ/HDU 2535 Vote(排序、)
HDOJ/HDU 2535 Vote(排序、)
83 0