POJ- 2367- Genealogical tree【拓扑排序】

简介: POJ- 2367- Genealogical tree【拓扑排序】


Genealogical tree

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 2   Accepted Submission(s) : 2
Special Judge

Problem Description

The system of Martians' blood relations is confusing enough. Actually, Martians bud when they want and where they want. They gather together in different groups, so that a Martian can have one parent as well as ten. Nobody will be surprised by a hundred of children. Martians have got used to this and their style of life seems to them natural.

And in the Planetary Council the confusing genealogical system leads to some embarrassment. There meet the worthiest of Martians, and therefore in order to offend nobody in all of the discussions it is used first to give the floor to the old Martians, than to the younger ones and only than to the most young childless assessors. However, the maintenance of this order really is not a trivial task. Not always Martian knows all of his parents (and there's nothing to tell about his grandparents!). But if by a mistake first speak a grandson and only than his young appearing great-grandfather, this is a real scandal.

Your task is to write a program, which would define once and for all, an order that would guarantee that every member of the Council takes the floor earlier than each of his descendants.

 


Input

The first line of the standard input contains an only number N, 1 <= N <= 100 a number of members of the Martian Planetary Council. According to the centuries-old tradition members of the Council are enumerated with the natural numbers from 1 up to N. Further, there are exactly N lines, moreover, the I-th line contains a list of I-th member's children. The list of children is a sequence of serial numbers of children in a arbitrary order separated by spaces. The list of children may be empty. The list (even if it is empty) ends with 0.

 


Output

The standard output should contain in its only line a sequence of speakers' numbers, separated by spaces. If several sequences satisfy the conditions of the problem, you are to write to the standard output any of them. At least one such sequence always exists.

 


Sample Input

      5 0 4 5 1 0 1 0 5 3 0 3 0      

 


Sample Output

      2 4 5 3 1      

 


Source

PKU

 


标准的拓扑排序

题目分析:主要是这个题如果读不懂就不知道怎么树是怎么连接的。按样例数据解释就是 5组数据

                   第一组是    没有约束条件  

                   第二组是    2  4   ,2   5 ,2  1    //  2  在4前    2在  5前    2 在 1前

                   第三组是    3  1

                   第四组是    4  5  ,4   3

                   第五组是     5  3


#include<cstdio>
#include<cstring>
int map[110][110],indgree[110];
int dui[110];
int n;
void topo(int n)
{
  int k;
  for(int i=1;i<=n;i++)
  {
    for(int j=1;j<=n;j++)
       if(!indgree[j])
       {
           k=j;
           break;
       } //  此循环是找出树头 
      dui[i]=k;
      indgree[k]=-1;
      for(int t=1;t<=n;t++)
        if(map[k][t])
            indgree[t]--;
   }
   for(int i=1;i<n;i++)
        printf("%d ",dui[i]);
        printf("%d\n",dui[n]);
}
int main()
{
  int n;
  while(~scanf("%d",&n))
  {
    memset(indgree,0,sizeof(indgree));
    memset(map,0,sizeof(map));
    for(int i=1;i<=n;i++)
    {
      int m;
      while(~scanf("%d",&m),m)
      {
        map[i][m]=1;
        indgree[m]++;
      }
    }
    topo(n);
  }
  return 0;
}



目录
相关文章
|
4月前
深度优先搜索(DFS、深搜)和广度优先搜索(BFS、广搜)(下)
深度优先搜索(DFS、深搜)和广度优先搜索(BFS、广搜)
30 0
POJ-1308,Is It A Tree?(并查集和树)
POJ-1308,Is It A Tree?(并查集和树)
|
算法
树与图的遍历:DFS,BFS 算法模板
树与图的遍历:DFS,BFS 算法模板
154 0
|
BI 算法 人工智能
POJ 1741 Tree(树的点分治,入门题)
Tree Time Limit: 1000MS   Memory Limit: 30000K Total Submissions: 21357   Accepted: 7006 Description Give a tree with n vertices...
904 0