sdut java lab7.2

简介: sdut java lab7.2

7-2 sdut-JAVA-Words Containing AB

分数 9

全屏浏览

切换布局

作者 马新娟

单位 山东理工大学

Write a program that requests a word as input containing the two letters a and b (in this order). Examples of valid words would include, abacus, cab, and anybody, whereas invalid words would include branch, back, and bank. You should only concern yourself with the first occurrence of a and b should they exist.

Input Specification:

a word as input containing the two letters a and b (in this order).

Output Specification:

Output the input word is valid or not.

Sample Input:

Sample Output:

No input provided to check.

Sample Input:

about12

Sample Output:

Input should comprise of alphabetic characters only.

Sample Input:

about

Sample Output:

about is valid

代码长度限制

16 KB

时间限制

400 ms

内存限制

64 MB

栈限制

8192 KB

import java.util.Scanner;
 
public class Main {
    public static void main(String[] args) {
        Scanner scanner = new Scanner(System.in);
 
        String word = scanner.nextLine();
        String result = checkWordValidity(word);
 
        if (result == null) {
            System.out.println("No input provided to check.");
        } else {
            System.out.println(result);
        }
    }
 
    private static String checkWordValidity(String word) {
        if (word.isEmpty()) {
            return null; // No input provided
        }
 
        if (!word.matches("[a-zA-Z]+")) {
            return "Input should comprise of alphabetic characters only.";
        }
 
        int indexA = word.indexOf('a');
        int indexB = word.indexOf('b');
 
        if (indexA != -1 && indexB != -1 && indexA < indexB) {
            return word + " is valid";
        } else {
            return word + " is not valid";
        }
    }
}

程序的目的是检查用户输入的单词是否满足特定的条件,即单词中的字母'a'是否在字母'b'之前。下面是对每一行代码的解释:

import java.util.Scanner;

导入Java的Scanner类,它用于获取用户的输入。

public class Main {

定义了一个名为Main的公共类。

public static void main(String[] args) {

定义了程序的主入口点main方法。

Scanner scanner = new Scanner(System.in);

创建了Scanner类的一个实例,用于从标准输入(键盘)读取数据。

String word = scanner.nextLine();

调用ScannernextLine方法读取用户输入的一行文本,通常是一个单词,并将其存储在变量word中。

String result = checkWordValidity(word);

调用自定义的checkWordValidity方法,并将用户输入的word作为参数传递。该方法将返回一个字符串,指示该单词是否有效。

if (result == null) {

检查checkWordValidity方法返回的result是否为null

System.out.println("No input provided to check.");

如果resultnull,表示没有输入或输入为空,程序将打印一条消息并退出。

} else { System.out.println(result); }

如果result不是null,则打印checkWordValidity方法返回的结果。

}

结束main方法。

private static String checkWordValidity(String word) {

定义了一个名为checkWordValidity的私有静态方法,它接受一个String类型的参数word,并返回一个String类型的结果。

if (word.isEmpty()) { return null; // No input provided }

检查传入的word是否为空或空白,如果是,则返回null

if (!word.matches("[a-zA-Z]+")) { return "Input should comprise of alphabetic characters only."; }

使用正则表达式验证word是否只包含字母字符,如果不满足条件,则返回一条错误消息。

int indexA = word.indexOf('a'); int indexB = word.indexOf('b');

使用indexOf方法找到单词中'a'和'b'的位置。

if (indexA != -1 && indexB != -1 && indexA < indexB) {

检查'a'和'b'是否都在单词中,并且'a'是否在'b'之前。

return word + " is valid";

如果上述条件满足,返回一条消息表明该单词是有效的。

} else { return word + " is not valid"; }

如果条件不满足,返回一条消息表明该单词是无效的。

}

结束checkWordValidity方法。

}

结束Main类。

这个程序的逻辑是:读取用户输入的单词,检查它是否只包含字母,然后检查'a'是否出现在'b'之前。根据这些条件,程序将输出单词是否有效。


目录
相关文章
|
8月前
|
Java
sdut java lab 7.1(法二好理解)
sdut java lab 7.1(法二好理解)
65 1
|
8月前
|
Java 应用服务中间件 AHAS
sdut java lab6主观题
sdut java lab6主观题
40 0
|
8月前
|
人工智能 Java
sdut java lab5
sdut java lab5
42 0
|
8月前
|
Java
sdut java lab7.2(法二)
sdut java lab7.2(法二)
52 0
|
8月前
|
Java
SDUT JAVA lab3.9
SDUT JAVA lab3.9
53 2
|
8月前
|
Java
SDUT Java lab6
SDUT Java lab6
33 0
|
8月前
|
Java
sdut java lab7单选
sdut java lab7单选
51 0
|
10天前
|
Java
Java—多线程实现生产消费者
本文介绍了多线程实现生产消费者模式的三个版本。Version1包含四个类:`Producer`(生产者)、`Consumer`(消费者)、`Resource`(公共资源)和`TestMain`(测试类)。通过`synchronized`和`wait/notify`机制控制线程同步,但存在多个生产者或消费者时可能出现多次生产和消费的问题。 Version2将`if`改为`while`,解决了多次生产和消费的问题,但仍可能因`notify()`随机唤醒线程而导致死锁。因此,引入了`notifyAll()`来唤醒所有等待线程,但这会带来性能问题。
Java—多线程实现生产消费者
|
12天前
|
安全 Java Kotlin
Java多线程——synchronized、volatile 保障可见性
Java多线程中,`synchronized` 和 `volatile` 关键字用于保障可见性。`synchronized` 保证原子性、可见性和有序性,通过锁机制确保线程安全;`volatile` 仅保证可见性和有序性,不保证原子性。代码示例展示了如何使用 `synchronized` 和 `volatile` 解决主线程无法感知子线程修改共享变量的问题。总结:`volatile` 确保不同线程对共享变量操作的可见性,使一个线程修改后,其他线程能立即看到最新值。
|
12天前
|
消息中间件 缓存 安全
Java多线程是什么
Java多线程简介:本文介绍了Java中常见的线程池类型,包括`newCachedThreadPool`(适用于短期异步任务)、`newFixedThreadPool`(适用于固定数量的长期任务)、`newScheduledThreadPool`(支持定时和周期性任务)以及`newSingleThreadExecutor`(保证任务顺序执行)。同时,文章还讲解了Java中的锁机制,如`synchronized`关键字、CAS操作及其实现方式,并详细描述了可重入锁`ReentrantLock`和读写锁`ReadWriteLock`的工作原理与应用场景。