npm install没问题,但npm run dev的时候报Node Sass version 6.0.1 is incompatible with ^4.0.0 ^5.0.0

简介: npm install没问题,但npm run dev的时候报Node Sass version 6.0.1 is incompatible with ^4.0.0 ^5.0.0

npm install --legacy-peer-deps  进行相应的安装比较好

Vue报错Syntax Error:TypeError: this.getOptions is not a function的解决方法

安装好正确的版本后,运行出现下面问题

把上面的/deep/都修改成如下:

::v-deep

这样就好了。

相关文章
|
17天前
|
前端开发
windows10 安装node npm 等前端环境 并配置国内源
windows10 安装node npm 等前端环境 并配置国内源
|
1月前
|
资源调度 JavaScript Linux
nvm, node.js, npm, yarn 安装配置
nvm, node.js, npm, yarn 安装配置
79 1
|
21小时前
|
缓存
npm install 安装依赖报错解决
npm install 安装依赖报错解决
5 0
|
1月前
node node-sass sass-loader版本对应问题,对于npm编译大家经常遇到这个问题
node node-sass sass-loader版本对应问题,对于npm编译大家经常遇到这个问题
29 2
|
1月前
|
JavaScript Unix Shell
#! /usr/bin/env node 命令与 npm link 建立项目间软连接(一)
#! /usr/bin/env node 命令与 npm link 建立项目间软连接(一)
28 0
|
1月前
|
JavaScript
vue启动报错解决Syntax Error: Error: Node Sass version 7.0.1 is incompatible with ^4.0.0.
vue启动报错解决Syntax Error: Error: Node Sass version 7.0.1 is incompatible with ^4.0.0.
|
1月前
|
网络安全 计算机视觉
【node】 npm install 报错:code 128
【node】 npm install 报错:code 128
56 1
|
1月前
|
Linux
npm install 报错ERESOLVE unable to resolve dependency tree
npm install 报错ERESOLVE unable to resolve dependency tree
33 0
|
9月前
npm install 报错 npm ERR! puppeteer@1.20.0 install: `node install.js`
npm install 报错 npm ERR! puppeteer@1.20.0 install: `node install.js`
218 0
|
1月前
|
缓存 网络虚拟化
解决 npm install 报错的常见问题
解决 npm install 报错的常见问题
582 0

热门文章

最新文章