UVA —10361—Automatic Poetry

简介: UVA —10361—Automatic Poetry

题目描述

“Oh God”, Lara Croft exclaims, “it’s one of these dumb riddles again!”

In Tomb Raider XIV, Lara is, as ever, gunning her way through ancient Egyptian pyramids, prehistoric caves and medival hallways. Now she is standing in front of some important Germanic looking doorway and has to solve a linguistic riddle to pass. As usual, the riddle is not very intellectually challenging.

This time, the riddle involves poems containing a “Schuttelreim”. An example of a Schuttelreim is the following short poem:

Ein Kind halt seinen Schnabel nur,

wenn es hangt an der Nabelschnur.


The Problem

A Schuttelreim seems to be a typical German invention. The funny thing about this strange type of poetry is that if somebody gives you the first line and the beginning of the second one, you can complete the poem yourself. Well, even a computer can do that, and your task is to write a program which completes them automatically. This will help Lara concentrate on the “action” part of Tomb Raider and not on the “intellectual” part.


Input

The input will begin with a line containing a single number n. After this line follow n pairs of lines containing Schuttelreims. The first line of each pair will be of the form

s1s3s5

where the si are possibly empty strings of lowercase characters or blanks. The second line will be a string of lowercase characters or blanks ending with three dots “…”. Lines will we at most 100 characters long.


Output

For each pair of Schuttelreim lines l1 and l2 you are to output two lines c1 and c2 in the following way: c1 is the same as l1 only that the bracket marks “<” and “>” are removed. Line c2 is the same as l2, except that instead of the three dots the string

s4s3s2s5

should appear.


Sample Input


3

ein kind haelt seinen abel ur

wenn es haengt an der …

weil wir zu spaet zur <>oma amen

verpassten wir das …

u ist


Sample Output

ein kind haelt seinen schnabel nur

wenn es haengt an der nabel schnur

weil wir zu spaet zur oma kamen

verpassten wir das koma amen

du bist

bu dist

解题思路:

这个题以字符串的形式输入,判断<>中的内容,第一行输出直接去掉<>就行了,第二行把刚刚<>中的内容交换一下输出。

程序代码:

#include<stdio.h>
#include<string.h>
char s1[100],s2[100],c1[100],c2[100],l1[100],l2[100];
int main()
{
  int cad,n,i,j,k,m,t,a,b,e,f;
  scanf("%d",&cad);
  getchar();
  while(cad--)
  {
    memset(s1,0,sizeof(s1));
    memset(s2,0,sizeof(s2));
    memset(c1,0,sizeof(c1));
    memset(c2,0,sizeof(c2));
    memset(l1,0,sizeof(l1));
    memset(l2,0,sizeof(l2));
    fgets(s1,sizeof(s1),stdin);
    fgets(s2,sizeof(s2),stdin);
    n=strlen(s1);
    m=strlen(s2); 
    for(j=0;j<n;j++)
    {
      if(s1[j]=='<'||s1[j]=='>')
        continue;
      printf("%c",s1[j]);
    }
    for(i=n-1;i>=0;i--)
    {
      if(s1[i]=='>')
        a=i;
      if(s1[i]=='<')
      {
        b=i; break;
      } 
    }   
    for(i=0;i<n;i++)
    {
      if(s1[i]=='<')
        e=i;
      if(s1[i]=='>')
      {
        f=i; break;
      }
    }
    for(i=0;i<m;i++)
    {
      if(s2[i]=='.')
      {
        for(i=b+1;i<a;i++)
          printf("%c",s1[i]);
        for(i=f+1;i<b;i++)
          printf("%c",s1[i]);
        for(i=e+1;i<f;i++)
          printf("%c",s1[i]);
        for(i=a+1;i<n-1;i++)
          printf("%c",s1[i]);
        break;
      }
      else
        printf("%c",s2[i]);
    }
    printf("\n");     
  }
  return 0;
} 


相关文章
uva 11991 - Easy Problem from Rujia Liu?
这个题目的意思是输入n个数,m组询问,每组询问包含两个整数k,v,意思是询问整数v第k次出现的位置。
41 0
UVa11958 - Coming Home
UVa11958 - Coming Home
48 0
|
Shell Windows
[记录condaのbug] CommandNotFoundError: Your shell has not been properly configured to use ‘conda...
[记录condaのbug] CommandNotFoundError: Your shell has not been properly configured to use ‘conda...
[记录condaのbug] CommandNotFoundError: Your shell has not been properly configured to use ‘conda...
【HDU 5572 An Easy Physics Problem】计算几何基础
2015上海区域赛现场赛第5题。 题目连接:http://acm.hdu.edu.cn/showproblem.php?pid=5572 题意:在平面上,已知圆(O, R),点B、A(均在圆外),向量V。
1039 0