【Python】Windows如何在cmd中切换python版本

简介: 【Python】Windows如何在cmd中切换python版本

(关注“测试开发自动化” 弓中皓,查看历史文章,获取更多知识)

【方法一】从环境变量中切换python

这是我最喜欢用的方法,但是也是比较笨的一种方法,但是这种方法有一定的好处。

第一步: 打开环境变量

第二步:打开系统变量中Path变量

可以看到,目前我们3.6版本的python是置顶的,因此说明,目前如果在cmd中输入python使用的将是3.6版本的python,不信可以看下面:

第三步:将你想使用的Python版本提前

然后,点击确定并保存环境变量即可。

【注意 】:必须重新打开一个cmd,否则不会生效。

第四步:使用pip安装第三方库

为什么说这种方法好呢?就是因为这种方法可以使用pip非常方便(可以对比后面的方法)。

我们可以指定pip的版本来使用pip来安装第三方库:

查看对应版本的第三方库:pip3.9 list

【方法二】直接从cmd中任选python版本

使用这种方法的前提是需要对安装在根目录下的python做一定的修改

第一步:查看安装的python版本的路径

打开cmd,输入where python

第二步:修改python.exe的版本号

我们要做的是将每个版本的python.exe文件修改为python+版本号.exe

以python3.9为例,我们将C:\Users\mech-mind_lcl\AppData\Local\Programs\Python\Python39\python.exe 路径下的python.exe文件修改为python3.9.exe

第三步:使用对应的python版本

重新打开一个cmd,输入python3.9 即可使用对应的版本

第四步:使用pip安装第三方库

为什么说这种方式不好呢? 是因为这种方式使用pip会报错。不信?你看:

所以,如果不适用pip的话,可以用这种办法。如果使用pip的话,我推荐大家使用第一种方法。


相关文章
|
6天前
|
Linux 数据库管理 Python
CentOS7编译安装Python3.10(含OpenSSL1.1.1安装),创建虚拟环境,运行Django项目(含sqlite版本报错)
CentOS7编译安装Python3.10(含OpenSSL1.1.1安装),创建虚拟环境,运行Django项目(含sqlite版本报错)
64 4
|
1天前
|
C++ Python Windows
在Visual Studio中使用Python(Windows)
在Visual Studio中使用Python(Windows)
|
6天前
|
网络架构 Windows
windows电脑开机自动启动FRP客户端CMD代码,增加延时15秒功能
经常使用FRP客户端的都知道,FRP客户端启动时需要电脑有网络,否则会自动退出。我们的电脑在启动时,受路由器网络的影响,很多时间并不能第一时间建立起网络来,所以很容易受到网络影响,让FRP客户端自动启动发生故障。而这里的解决办法就是增加一段代码,可以延时15秒再执行。
|
9天前
|
Windows
win10 cmd切换不了目录 windows命令提示符 切换目录 (已解决)
win10 cmd切换不了目录 windows命令提示符 切换目录 (已解决)
|
10天前
|
应用服务中间件 Windows
Windows下CMD和Tomcat设置编码为UTF-8
解决CMD和Tomcat中文乱码问题:通过修改注册表永久设置CMD编码为UTF-8,路径 `\HKEY_CURRENT_USER\Console\%SystemRoot%_system32_cmd.exe`,修改CodePage为65001。Tomcat日志乱码时,在 `\HKEY_CURRENT_USER\Console` 下新建Tomcat项,添加DWORD值PageCode,值设为65001。
|
15天前
|
程序员 开发者 Python
Python2.x与 3.x 版本区别
Python2.x与 3.x 版本区别
|
24天前
|
安全 Linux 开发者
Windows系统历史版本简介
Windows系统历史版本简介
37 0
|
24天前
|
存储 文件存储 Python
Python基础 --- 实现学生管理系统(Python 文件版本)
Python基础 --- 实现学生管理系统(Python 文件版本)
35 4
|
24天前
|
Python
Python 新版本有75个内置函数,你不会不知道吧(1)
Python 新版本有75个内置函数,你不会不知道吧(1)
Python 新版本有75个内置函数,你不会不知道吧(1)
|
27天前
|
关系型数据库 Java 分布式数据库
实时计算 Flink版操作报错合集之在使用 Python UDF 时遇到 requests 包的导入问题,提示 OpenSSL 版本不兼容如何解决
在使用实时计算Flink版过程中,可能会遇到各种错误,了解这些错误的原因及解决方法对于高效排错至关重要。针对具体问题,查看Flink的日志是关键,它们通常会提供更详细的错误信息和堆栈跟踪,有助于定位问题。此外,Flink社区文档和官方论坛也是寻求帮助的好去处。以下是一些常见的操作报错及其可能的原因与解决策略。
40 5