华为配置VXLAN构建虚拟网络实现相同网段互通示例(静态方式)

简介: 配置VXLAN构建虚拟网络实现相同网段互通示例(静态方式


配置VXLAN构建虚拟网络实现相同网段互通示例(静态方式)

组网图形

图1 配置VXLAN构建虚拟网络实现相同网段互通组网图

image.png

  • 组网需求
  • 数据准备
  • 配置思路
  • 操作步骤
  • 配置文件

组网需求

企业已经建成比较成熟的园区网络,但是没有专用的数据中心网络,所有的服务器分布在不同的部门,并且不具备集中放置的条件。现在用户希望在已有园区网络上构建一个虚拟网络,需求如下:

  • 将散落在不同部门的服务器构建成一个虚拟网络,实现资源整合和业务灵活部署。
  • 各服务器上部署着大量的VM,相同业务的服务器之间需要实现二层互通。
  • 各VM之间由于业务需求需要在服务器之间进行平滑迁移,且保证业务不中断。

图1所示,企业在不同的位置都拥有自己的服务器,Server1与Server2都属于VLAN 10,现需要通过VXLAN隧道实现相同业务的服务器之间的二层互通。


本举例中交换机以S6730-S、S6730S-S、S5732-H、S5732-H-K、S5731-S、S5731S-S、S5731S-H、S6730-H、S6730-H-K、S6730S-H、S5731-H-K或S5731-H为例。

数据准备

表1 部署VXLAN隧道相关数据

设备

VXLAN隧道

BD

VNI

Source IP

Peer IP

VTEP1

VTEP1—>VTEP2

10

2010

10.1.1.2

10.2.2.2

VTEP2

VTEP2—>VTEP1

10

2010

10.2.2.2

10.1.1.2

配置思路

采用如下思路配置同网段用户通过VXLAN隧道互通:

  1. 分别在VTEP1、VTEP2、Switch1上配置路由协议,保证网络三层互通。
  2. 分别在VTEP1、VTEP2上配置VXLAN接入业务部署方式,在Switch2、Switch3上配置VLAN。
  3. 分别在VTEP1、VTEP2上配置VXLAN隧道。


园区网络的三层互通是构建虚拟数据中心网络的基础条件,现网中,如果园区网络已经实现三层网络的互通,那么该举例中的步骤1可以省略。

操作步骤

  1. 配置路由协议# 配置VTEP1各接口IP地址。VTEP2和Switch1的配置与VTEP1类似,这里不再赘述。配置OSPF时,注意需要发布设备上的Loopback接口地址。

<HUAWEI> system-view

[HUAWEI] sysname VTEP1

[VTEP1] interface loopback 1

[VTEP1-LoopBack1] ip address 10.1.1.2 32

[VTEP1-LoopBack1] quit

[VTEP1] interface gigabitethernet 0/0/1

[VTEP1-GigabitEthernet0/0/1] undo portswitch

[VTEP1-GigabitEthernet0/0/1] ip address 192.168.2.1 24

[VTEP1-GigabitEthernet0/0/1] quit

[VTEP1] ospf router-id 10.1.1.2

[VTEP1-ospf-1] area 0

[VTEP1-ospf-1-area-0.0.0.0] network 10.1.1.2 0.0.0.0

[VTEP1-ospf-1-area-0.0.0.0] network 192.168.2.0 0.0.0.255

[VTEP1-ospf-1-area-0.0.0.0] quit

[VTEP1-ospf-1] quit

  1. # OSPF成功配置后,VTEP之间可通过OSPF协议发现对方的Loopback接口的IP地址,并能互相ping通。以VTEP1 ping VTEP2的显示为例。

[VTEP1] ping 10.2.2.2

 PING 10.2.2.2: 56  data bytes, press CTRL_C to break                          

   Reply from 10.2.2.2: bytes=56 Sequence=1 ttl=255 time=240 ms                

   Reply from 10.2.2.2: bytes=56 Sequence=2 ttl=255 time=5 ms                  

   Reply from 10.2.2.2: bytes=56 Sequence=3 ttl=255 time=5 ms                  

   Reply from 10.2.2.2: bytes=56 Sequence=4 ttl=255 time=14 ms                  

   Reply from 10.2.2.2: bytes=56 Sequence=5 ttl=255 time=5 ms                  

                                                                               

 --- 10.2.2.2 ping statistics ---                                              

   5 packet(s) transmitted                                                    

   5 packet(s) received                                                        

   0.00% packet loss                                                          

   round-trip min/avg/max = 5/53/240 ms  


  1. 分别在Switch2、Switch3上配置VLAN,在VTEP1、VTEP2上配置业务接入点# 配置Switch2。

<HUAWEI> system-view

[HUAWEI] sysname Switch2

[Switch2] vlan 10

[Switch2-vlan10] quit

[Switch2] interface gigabitethernet 0/0/2

[Switch2-GigabitEthernet0/0/2] port link-type access

[Switch2-GigabitEthernet0/0/2] port default vlan 10

[Switch2-GigabitEthernet0/0/2] quit

[Switch2] interface gigabitethernet 0/0/1

[Switch2-GigabitEthernet0/0/1] port link-type trunk

[Switch2-GigabitEthernet0/0/1] port trunk allow-pass vlan 10

[Switch2-GigabitEthernet0/0/1] quit

  1. # 配置Switch3。

<HUAWEI> system-view

[HUAWEI] sysname Switch3

[Switch3] vlan 10

[Switch3-vlan10] quit

[Switch3] interface gigabitethernet 0/0/2

[Switch3-GigabitEthernet0/0/2] port link-type access

[Switch3-GigabitEthernet0/0/2] port default vlan 10

[Switch3-GigabitEthernet0/0/2] quit

[Switch3] interface gigabitethernet 0/0/1

[Switch3-GigabitEthernet0/0/1] port link-type trunk

[Switch3-GigabitEthernet0/0/1] port trunk allow-pass vlan 10

[Switch3-GigabitEthernet0/0/1] quit

  1. # 配置VTEP1。

[VTEP1] bridge-domain 10

[VTEP1-bd10] quit

[VTEP1] interface gigabitethernet 0/0/2

[VTEP1-GigabitEthernet0/0/2] port link-type trunk

[VTEP1-GigabitEthernet0/0/2] quit

[VTEP1] interface gigabitethernet 0/0/2.1 mode l2

[VTEP1-GigabitEthernet0/0/2.1] encapsulation dot1q vid 10

[VTEP1-GigabitEthernet0/0/2.1] bridge-domain 10

[VTEP1-GigabitEthernet0/0/2.1] quit

  1. # 配置VTEP2。

[VTEP2] bridge-domain 10

[VTEP2-bd10] quit

[VTEP2] interface gigabitethernet 0/0/2

[VTEP2-GigabitEthernet0/0/2] port link-type trunk

[VTEP2-GigabitEthernet0/0/2] quit

[VTEP2] interface gigabitethernet 0/0/2.1 mode l2

[VTEP2-GigabitEthernet0/0/2.1] encapsulation dot1q vid 10

[VTEP2-GigabitEthernet0/0/2.1] bridge-domain 10

[VTEP2-GigabitEthernet0/0/2.1] quit

  1. 分别在VTEP1、VTEP2上配置VXLAN隧道# 配置VTEP1。

[VTEP1] bridge-domain 10

[VTEP1-bd10] vxlan vni 2010

[VTEP1-bd10] quit

[VTEP1] interface nve 1

[VTEP1-Nve1] source 10.1.1.2

[VTEP1-Nve1] vni 2010 head-end peer-list 10.2.2.2

[VTEP1-Nve1] quit

  1. # 配置VTEP2。

[VTEP2] bridge-domain 10

[VTEP2-bd10] vxlan vni 2010

[VTEP2-bd10] quit

[VTEP2] interface nve 1

[VTEP2-Nve1] source 10.2.2.2

[VTEP2-Nve1] vni 2010 head-end peer-list 10.1.1.2

[VTEP2-Nve1] quit

  1. 验证配置结果# 上述配置成功后,在VTEP1、VTEP2上执行display vxlan vni命令可查看到VNI的状态是Up;执行display vxlan tunnel命令可查看到VXLAN隧道的信息。以VTEP1显示为例。

[VTEP1] display vxlan vni

VNI               BD-ID             State                                      

-----------------------------------------                                      

2010              10                up                                        

-----------------------------------------                                      

Number of vxlan vni bound to BD is : 1  


VNI               VRF-ID

-----------------------------------------

-----------------------------------------

Number of vxlan vni bound to VPN is : 0


[VTEP1] display vxlan tunnel

Tunnel ID       Source              Destination         State     Type        

----------------------------------------------------------------------------  

4026531841      10.1.1.2             10.2.2.2             up        static      

----------------------------------------------------------------------------    

Number of vxlan tunnel :

Total : 1    Static: 1    L2 dynamic: 0    L3 dynamic: 0

  1. # 配置完成后,同网段用户通过VXLAN隧道可以互通。以服务器上1的VM1 ping服务器2上的VM1的显示为例。

C:\Users\VM1>ping 192.168.10.2


Pinging 192.168.10.2 with 32 bytes of data:              

Reply from 192.168.10.2: bytes=32 time=1ms TTL=126        

Reply from 192.168.10.2: bytes=32 time=1ms TTL=126        

Reply from 192.168.10.2: bytes=32 time=1ms TTL=126        

Reply from 192.168.10.2: bytes=32 time=1ms TTL=126        

                                                           

Ping statistics for 192.168.10.2:                        

   Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),    

Approximate round trip times in milli-seconds:              

   Minimum = 1ms, Maximum = 1ms, Average = 1ms            

                             

配置文件

  • VTEP1的配置文件

#

sysname VTEP1

#

bridge-domain 10                                                                

vxlan vni 2010

#                                                                              

interface GigabitEthernet0/0/1                                                        

undo portswitch                                                                

ip address 192.168.2.1 255.255.255.0                                          

#                                                                              

interface GigabitEthernet0/0/2                                                

port link-type trunk                                                          

#                                                                              

interface GigabitEthernet0/0/2.1 mode l2                                              

encapsulation dot1q vid 10                                                    

bridge-domain 10

#                                                                              

interface LoopBack1                                                            

ip address 10.1.1.2 255.255.255.255  

#                                                                              

interface Nve1                                                                  

source 10.1.1.2                                                                

vni 2010 head-end peer-list 10.2.2.2                                            

#  

ospf 1 router-id 10.1.1.2                                                    

area 0.0.0.0                                                                  

 network 10.1.1.2 0.0.0.0                                                      

 network 192.168.2.0 0.0.0.255

#                                                                              

return


  • VTEP2的配置文件

#

sysname VTEP2

#

bridge-domain 10                                                                

vxlan vni 2010

#                                                                              

interface GigabitEthernet0/0/1                                                        

undo portswitch                                                                

ip address 192.168.3.1 255.255.255.0                                          

#                                                                              

interface GigabitEthernet0/0/2                                                

port link-type trunk    

#                                                                              

interface GigabitEthernet0/0/2.1 mode l2                                              

encapsulation dot1q vid 10                                                    

bridge-domain 10

#                                                                              

interface LoopBack1                                                            

ip address 10.2.2.2 255.255.255.255  

#                                                                              

interface Nve1                                                                  

source 10.2.2.2                                                                

vni 2010 head-end peer-list 10.1.1.2                                            

#  

ospf 1 router-id 10.2.2.2                                                    

area 0.0.0.0                                                                  

 network 10.2.2.2 0.0.0.0                                                      

 network 192.168.3.0 0.0.0.255

#                                                                              

return

  • Switch1的配置文件

#

sysname Switch1

#                                                                              

interface GigabitEthernet0/0/1                                                        

undo portswitch                                                                

ip address 192.168.2.2 255.255.255.0                                          

#                                                                              

interface GigabitEthernet0/0/2                                                        

undo portswitch                                                                

ip address 192.168.3.2 255.255.255.0                                          

#  

ospf 1 router-id 192.168.2.2                                                    

area 0.0.0.0                                                                  

 network 192.168.2.0 0.0.0.255

 network 192.168.3.0 0.0.0.255

#                                                                              

return

  • Switch2的配置文件

#

sysname Switch2

#

vlan batch 10

#

interface GigabitEthernet0/0/1

port link-type trunk

port trunk allow-pass vlan 10

#

interface GigabitEthernet0/0/2

port link-type access

port default vlan 10

#

return


  • Switch3的配置文件

#

sysname Switch3

#

vlan batch 10

#

interface GigabitEthernet0/0/1

port link-type trunk

port trunk allow-pass vlan 10

#

interface GigabitEthernet0/0/2

port link-type access

port default vlan 10

#

return



相关文章
|
1天前
|
存储 安全 网络安全
云端防御:构建弹性云计算环境中的网络安全体系
【5月更文挑战第19天】 在当今数字化时代,随着企业逐渐迁移至云计算平台,数据和服务的安全性变得至关重要。本文深入探讨了如何在弹性云计算环境中构建一个坚固的网络安全体系。首先,文中概述了云服务的基本类型及其安全挑战;随后,详细分析了当前网络威胁的面貌以及它们如何影响云服务;最后,提出了一套综合性策略,旨在增强身份认证、数据加密、入侵检测及事件响应等方面的能力,确保云服务的信息安全。
|
2天前
|
网络协议 Python
Python 网络编程实战:构建高效的网络应用
【5月更文挑战第18天】Python在数字化时代成为构建网络应用的热门语言,因其简洁的语法和强大功能。本文介绍了网络编程基础知识,包括TCP和UDP套接字,强调异步编程、数据压缩和连接池的关键作用。提供了一个简单的TCP服务器和客户端代码示例,并提及优化与改进方向,鼓励读者通过实践提升网络应用性能。
19 6
|
3天前
|
监控 安全 数据安全/隐私保护
企业组网:构建智慧型网络基础设施,驱动未来商业发
随着数字化进程,企业组网演变为创新与竞争力的关键。智慧型网络基础设施助力企业内部协作效率提升,外部市场拓展及应对未来挑战。核心要素包括前瞻网络架构、高性能硬件、智能化软件和全面安全。实施策略涉及明确需求、制定方案、精细化实施、全面测试及持续优化,确保网络稳定、高效、安全。
11 3
企业组网:构建智慧型网络基础设施,驱动未来商业发
|
3天前
|
机器学习/深度学习 JSON PyTorch
图神经网络入门示例:使用PyTorch Geometric 进行节点分类
本文介绍了如何使用PyTorch处理同构图数据进行节点分类。首先,数据集来自Facebook Large Page-Page Network,包含22,470个页面,分为四类,具有不同大小的特征向量。为训练神经网络,需创建PyTorch Data对象,涉及读取CSV和JSON文件,处理不一致的特征向量大小并进行归一化。接着,加载边数据以构建图。通过`Data`对象创建同构图,之后数据被分为70%训练集和30%测试集。训练了两种模型:MLP和GCN。GCN在测试集上实现了80%的准确率,优于MLP的46%,展示了利用图信息的优势。
10 1
|
3天前
|
监控 安全 网络安全
构建安全防线:云计算环境下的网络安全策略
【5月更文挑战第17天】随着企业数字化转型步伐的加快,云计算已成为支撑现代业务架构的关键基石。然而,云服务的广泛应用同时带来了前所未有的安全挑战。本文旨在探讨云计算环境中的网络安全问题,并提出一系列创新的安全策略,以保障数据完整性、确保服务可用性并抵御网络威胁。我们将深入分析云服务模型(IaaS, PaaS, SaaS)与相应的安全考量,探讨加密技术、身份认证、访问控制以及入侵检测等关键技术在云环境中的应用,并讨论如何通过多层次防御策略和持续监控来强化整体安全性。
|
5天前
|
SQL 安全 网络安全
构建安全防线:云计算环境中的网络安全策略与实践
【5月更文挑战第14天】 随着企业逐渐将关键业务流程迁移到云端,云计算服务的安全性成为不容忽视的重要议题。本文深入探讨了在动态且复杂的云环境中实施有效的网络安全措施的策略和技术。通过分析当前云计算模型中的安全挑战,我们提出了一系列创新的安全框架和防御机制,旨在保护数据完整性、确保业务连续性并抵御不断演变的网络威胁。文中不仅涵盖了理论分析和案例研究,还对未来云计算安全技术的发展趋势进行了预测。
|
5天前
|
域名解析 网络协议 网络虚拟化
【计算机网络】—— 中小型网络构建与配置
【计算机网络】—— 中小型网络构建与配置
6 0
|
5天前
|
SQL 安全 算法
数字堡垒的构建者:网络安全与信息安全的深层剖析
【5月更文挑战第12天】在信息技术迅猛发展的今天,网络空间已成为信息交流的重要平台。然而,随之而来的是各种网络安全漏洞和威胁的增多。本文深入探讨了网络安全漏洞的类型、成因以及预防措施,并详细分析了加密技术在保障信息安全中的应用。文章还强调了提升个人和企业安全意识的重要性,并分享了如何通过教育和培训来增强这一意识。通过对这些关键方面的知识分享,旨在为读者提供一个全面的网络安全与信息安全视角。
|
5天前
|
网络安全
|
5天前
|
机器学习/深度学习 人工智能 算法
构建未来:AI驱动的自适应网络安全防御系统
【5月更文挑战第11天】在数字时代的风口浪尖,网络安全问题日益凸显。传统的安全防御手段在应对不断进化的网络威胁时显得力不从心。本文提出了一个基于人工智能技术的自适应网络安全防御系统框架,旨在通过实时分析、学习和预测网络行为,自动调整防御策略以抵御未知攻击。系统采用先进的机器学习算法和大数据分析技术,能够在保持高效性能的同时,最小化误报率。文章详细阐述了系统的设计理念、关键技术组件以及预期效果,为网络安全的未来发展方向提供新思路。

热门文章

最新文章