输出GPLT(2016)

简介: 输出GPLT(2016)

输出GPLT(2016)

给定一个长度不超过10000的、仅由英文字母构成的字符串。请将字符重新调整顺序,按GPLTGPLT…这样的顺序输出,并忽略其它字符。当然,四种字符(不区分大小写)的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按GPLT的顺序打印,直到所有字符都被输出。

输入格式:

输入在一行中给出一个长度不超过10000的、仅由英文字母构成的非空字符串。

输出格式:

在一行中按题目要求输出排序后的字符串。题目保证输出非空。

输入样例:

pcTclnGloRgLrtLhgljkLhGFauPewSKgt

输出样例:

GPLTGPLTGLTGLGLL

提交代码

#include<bits/stdc++.h>
using namespace std;
int main(){
  string strs;
  cin >> strs;
  int len = strs.length(), g = 0, p = 0, l = 0, t = 0;
  for(int i = 0; i < len; i++)
  {
    if(strs[i] == 'G' || strs[i] == 'g') g ++;
    else if(strs[i] == 'P'|| strs[i] == 'p') p ++;
    else if(strs[i] == 'L'|| strs[i] == 'l') l ++;
    else if(strs[i] == 'T'|| strs[i] == 't') t ++;
  }
  while(g || p || l || t)
  {
    if(g)
    {
      putchar('G');
      g--;
    }
    if(p)
    {
      putchar('P');
      p--;
    }
    if(l)
    {
      putchar('L');
      l--;
    }
    if(t)
    {
      putchar('T');
      t--;
    }
  }
  return 0;
}

输出GPLT(2016)

给定一个长度不超过10000的、仅由英文字母构成的字符串。请将字符重新调整顺序,按GPLTGPLT…这样的顺序输出,并忽略其它字符。当然,四种字符(不区分大小写)的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按GPLT的顺序打印,直到所有字符都被输出。

输入格式:

输入在一行中给出一个长度不超过10000的、仅由英文字母构成的非空字符串。

输出格式:

在一行中按题目要求输出排序后的字符串。题目保证输出非空。

输入样例:

pcTclnGloRgLrtLhgljkLhGFauPewSKgt

输出样例:

GPLTGPLTGLTGLGLL

提交代码

#include<bits/stdc++.h>
using namespace std;
int main(){
  string strs;
  cin >> strs;
  int len = strs.length(), g = 0, p = 0, l = 0, t = 0;
  for(int i = 0; i < len; i++)
  {
    if(strs[i] == 'G' || strs[i] == 'g') g ++;
    else if(strs[i] == 'P'|| strs[i] == 'p') p ++;
    else if(strs[i] == 'L'|| strs[i] == 'l') l ++;
    else if(strs[i] == 'T'|| strs[i] == 't') t ++;
  }
  while(g || p || l || t)
  {
    if(g)
    {
      putchar('G');
      g--;
    }
    if(p)
    {
      putchar('P');
      p--;
    }
    if(l)
    {
      putchar('L');
      l--;
    }
    if(t)
    {
      putchar('T');
      t--;
    }
  }
  return 0;
}

输出GPLT(2016)

给定一个长度不超过10000的、仅由英文字母构成的字符串。请将字符重新调整顺序,按GPLTGPLT…这样的顺序输出,并忽略其它字符。当然,四种字符(不区分大小写)的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按GPLT的顺序打印,直到所有字符都被输出。

输入格式:

输入在一行中给出一个长度不超过10000的、仅由英文字母构成的非空字符串。

输出格式:

在一行中按题目要求输出排序后的字符串。题目保证输出非空。

输入样例:

pcTclnGloRgLrtLhgljkLhGFauPewSKgt

输出样例:

GPLTGPLTGLTGLGLL

提交代码

#include<bits/stdc++.h>
using namespace std;
int main(){
  string strs;
  cin >> strs;
  int len = strs.length(), g = 0, p = 0, l = 0, t = 0;
  for(int i = 0; i < len; i++)
  {
    if(strs[i] == 'G' || strs[i] == 'g') g ++;
    else if(strs[i] == 'P'|| strs[i] == 'p') p ++;
    else if(strs[i] == 'L'|| strs[i] == 'l') l ++;
    else if(strs[i] == 'T'|| strs[i] == 't') t ++;
  }
  while(g || p || l || t)
  {
    if(g)
    {
      putchar('G');
      g--;
    }
    if(p)
    {
      putchar('P');
      p--;
    }
    if(l)
    {
      putchar('L');
      l--;
    }
    if(t)
    {
      putchar('T');
      t--;
    }
  }
  return 0;
}


相关文章
|
1月前
等差数列输出 10x10 矩阵格式
【10月更文挑战第26天】等差数列输出 10x10 矩阵格式。
30 5
|
7月前
39.输入任意的a,b,c求一元二次方程ax*x+bx+c=0的根​
39.输入任意的a,b,c求一元二次方程ax*x+bx+c=0的根​
101 0
|
7月前
L1-023 输出GPLT
L1-023 输出GPLT
34 0
|
7月前
|
C++
【PTA】​L1-023 输出GPLT ​ (C++)
【PTA】​L1-023 输出GPLT ​ (C++)
57 0
【PTA】​L1-023 输出GPLT ​ (C++)
vector打印锯齿矩阵
vector打印锯齿矩阵
|
7月前
|
存储 定位技术
ASD光谱仪.asd格式光谱曲线文件转换为.txt格式的方法
ASD光谱仪.asd格式光谱曲线文件转换为.txt格式的方法
102 1
|
7月前
|
存储
nowcoder NC236题 最大差值
【1月更文挑战第2天】
55 0
|
7月前
nowcoder NC30 缺失的第一个正整数
题目链接:  https://www.nowcoder.com/share/jump/819478881694767416272
48 0
Qt-使用QString输出数字上标(不要再用x2或x^2表示平方啦)
Qt-使用QString输出数字上标(不要再用x2或x^2表示平方啦)
381 0
PTA 1043 输出PATest (20 分)
给定一个长度不超过 10 4 的、仅由英文字母构成的字符串。请将字符重新调整顺序,按 PATestPATest.... 这样的顺序输出,并忽略其它字符。
80 0