数据结构实验之链表四:有序链表的归并

简介: 数据结构实验之链表四:有序链表的归并

数据结构实验之链表四:有序链表的归并

Time Limit: 1000 ms Memory Limit: 65536 KiB

SubmitStatisticDiscuss

Problem Description

分别输入两个有序的整数序列(分别包含M和N个数据),建立两个有序的单链表,将这两个有序单链表合并成为一个大的有序单链表,并依次输出合并后的单链表数据。

Input

第一行输入M与N的值;

第二行依次输入M个有序的整数;

第三行依次输入N个有序的整数。

Output

输出合并后的单链表所包含的M+N个有序的整数。

Sample Input

6 5

1 23 26 45 66 99

14 21 28 50 100

Sample Output

1 14 21 23 26 28 45 50 66 99 100

Hint

不得使用数组!

Source

SDUTACM运维技术中心.

#include <stdio.h>
#include <stdlib.h>
struct node
{
    int data;
    struct node *next;
};
int main()
{
    struct node *head, *head1, *head2, *tail1, *tail2, *tail, *p;
    int m, n, i;
    scanf("%d%d", &m, &n);
    head1 = (struct node *)malloc(sizeof(struct node));
    head1->next = NULL;
    tail = head1;
    for(i = 1; i <= m; i++)
    {
        p = (struct node *)malloc(sizeof(struct node));
        scanf("%d", &p->data);
        p->next = NULL;
        tail->next = p;
        tail = p;
    }
    head2 = (struct node *)malloc(sizeof(struct node));
    head2->next = NULL;
    tail = head2;
    for(i = 1; i <= n; i++)
    {
        p = (struct node *)malloc(sizeof(struct node));
        scanf("%d", &p->data);
        p->next = NULL;
        tail->next = p;
        tail = p;
    }
    head = (struct node *)malloc(sizeof(struct node));
    head->next = NULL;
    tail = head;
    tail1 = head1->next;
    tail2 = head2->next;
    for(i = 1; i <= m + n; i++)
    {
        if(tail1 == NULL)
        {
            tail->next = tail2;
            tail = tail2;
            tail2 = tail2->next;
        }
        else if(tail2 == NULL)
        {
            tail->next = tail1;
            tail = tail1;
            tail1 = tail1->next;
        }
        else
        {
            if(tail1->data < tail2->data)
            {
                tail->next = tail1;
                tail = tail1;
                tail1 = tail1->next;
            }
            else
            {
                tail->next = tail2;
                tail = tail2;
                tail2 = tail2->next;
            }
        }
    }
    tail->next = NULL;
    for(tail = head->next; tail->next != NULL; tail = tail->next)
    {
        printf("%d ", tail->data);
    }
    printf("%d\n", tail->data);
    return 0;
}


相关文章
|
2天前
|
存储
数据结构第二课 -----线性表之单向链表
数据结构第二课 -----线性表之单向链表
|
2天前
|
存储
数据结构第三课 -----线性表之双向链表
数据结构第三课 -----线性表之双向链表
|
3天前
|
存储 Java
数据结构奇妙旅程之顺序表和链表
数据结构奇妙旅程之顺序表和链表
|
6天前
|
算法 索引
数据结构与算法-循环链表详解
数据结构与算法-循环链表详解
6 0
|
6天前
|
算法 Java C语言
数据结构与算法-双向链表知识详解
数据结构与算法-双向链表知识详解
5 0
|
6天前
|
算法 数据可视化 Java
数据结构与算法-单向链表的实现以及相关面试题
数据结构与算法-单向链表的实现以及相关面试题
7 0
|
7天前
|
存储 C语言
数据结构基础:双链表结构、实现
数据结构基础:双链表结构、实现
|
7天前
|
存储
数据结构基础:一篇文章教你单链表(头插,尾插,查找,头删等的解析和代码)
数据结构基础:一篇文章教你单链表(头插,尾插,查找,头删等的解析和代码)
|
10天前
|
C语言
数据结构:5、链表之双向链表
数据结构:5、链表之双向链表
25 0
|
10天前
|
存储
数据结构:4、链表之单链表
数据结构:4、链表之单链表
11 0