求二叉树的先序遍历

简介: 求二叉树的先序遍历

二叉树的先序遍历

Time Limit: 1000 ms Memory Limit: 65536 KiB

SubmitStatistic

Problem Description

已知一棵二叉树的中序遍历和后序遍历,求二叉树的先序遍历

Input

输入数据有多组,第一行是一个整数t (t<1000),代表有t组测试数据。每组包括两个长度小于50 的字符串,第一个字符串表示二叉树的中序遍历序列,第二个字符串表示二叉树的后序遍历序列。

Output

输出二叉树的先序遍历序列

Sample Input

2

dbgeafc

dgebfca

lnixu

linux

Sample Output

abdegcf

xnliu

Hint

 

Source

GYX

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
struct node
{
    char num;
    struct node *l,*r;
};
struct node *kk(char j[],int n,char i[])
{
    if(n<=0)
        return NULL;
    struct node *root;
    root=(struct node *)malloc(sizeof(struct node));
    root->num=j[n-1];
    int v;
    for(v=0;v<n;v++)
    if(i[v]==j[n-1])break;
    root->l=kk(j,v,i);
    root->r=kk(j+v,n-v-1,i+v+1);
    return root;
};
void zz(struct node *head)
{
    if(head==NULL)
        return ;
         printf("%c",head->num);
    zz(head->l);
    zz(head->r);
}
int main()
{
    int a,b;
    char i[1000],j[1000];
    struct node *head;
    scanf("%d",&b);
    while(b--)
    {
    scanf("%s %s",i,j);
    a=strlen(i);
    head=kk(j,a,i);
    zz(head);
    printf("\n");
    }
    return 0;
}


相关文章
|
4月前
二叉树的前序遍历、中序遍历、后序遍历
二叉树的前序遍历、中序遍历、后序遍历
|
4月前
|
存储
什么?二叉树的反前序遍历?
什么?二叉树的反前序遍历?
|
4月前
|
算法
二叉树中序遍历(一)
二叉树中序遍历(一)
|
4月前
二叉树的中序遍历
二叉树的中序遍历
27 0
|
4月前
|
C++
二叉树的前序遍历(C++)
二叉树的前序遍历(C++)
43 0
二叉树的前序遍历(C++)
|
4月前
|
C++
二叉树的后序遍历(C++)
二叉树的后序遍历(C++)
35 0
|
4月前
二叉树的前、中、后序遍历的实现
二叉树的前、中、后序遍历的实现