AC me

简介: AC me

AC me

Ignatius is doing his homework now. The teacher gives him some articles and asks him to tell how many times each letter appears.


It's really easy, isn't it? So come on and AC ME.

Input

Each article consists of just one line, and all the letters are in lowercase. You just have to count the number of each letter, so do not pay attention to other characters. The length of article is at most 100000. Process to the end of file.


Note: the problem has multi-cases, and you may use "while(gets(buf)){...}" to process to the end of file.

Output

For each article, you have to tell how many times each letter appears. The output format is like "X:N".


Output a blank line after each test case. More details in sample output.

Sample Input

hello, this is my first acm contest!

work hard for hdu acm.

Sample Output

a:1

b:0

c:2

d:0

e:2

f:1

g:0

h:2

i:3

j:0

k:0

l:2

m:2

n:1

o:2

p:0

q:0

r:1

s:4

t:4

u:0

v:0

w:0

x:0

y:1

z:0


a:2

b:0

c:1

d:2

e:0

f:1

g:0

h:2

i:0

j:0

k:1

l:0

m:1

n:0

o:2

p:0

q:0

r:3

s:0

t:0

u:1

v:0

w:1

x:0

y:0

z:0

思路:直接遍历字符串,存进数组,输出。

注意:一定要仔细检查自己的字母是不是输对了。

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
int main()
{
    char a[1000010];
    char c[27] = "abcdefghijklmnopqrstuvwxyz";
    int i, len;
    int b[100];
    while(gets(a))
    {
        memset(b,0,sizeof(b));
        len = strlen(a);
        for(i = 0; i < len; i++)
        {
            if(a[i] == 'a')
            {
                b[1]++;
            }
            else if(a[i] == 'b')
            {
                b[2]++;
            }
            else if(a[i] == 'c')
            {
                b[3]++;
            }
            else if(a[i] == 'd')
            {
                b[4]++;
            }
            else if(a[i] == 'e')
            {
                b[5]++;
            }
            else if(a[i] == 'f')
            {
                b[6]++;
            }
            else if(a[i] == 'g')
            {
                b[7]++;
            }
            else if(a[i] == 'h')
            {
                b[8]++;
            }
            else if(a[i] == 'i')
            {
                b[9]++;
            }
            else if(a[i] == 'j')
            {
                b[10]++;
            }
            else if(a[i] == 'k')
            {
                b[11]++;
            }
            else if(a[i] == 'l')
            {
                b[12]++;
            }
            else if(a[i] == 'm')
            {
                b[13]++;
            }
            else if(a[i] == 'n')
            {
                b[14]++;
            }
            else if(a[i] == 'o')
            {
                b[15]++;
            }
            else if(a[i] == 'p')
            {
                b[16]++;
            }
            else if(a[i] == 'q')
            {
                b[17]++;
            }
            else if(a[i] == 'r')
            {
                b[18]++;
            }
            else if(a[i] == 's')
            {
                b[19]++;
            }
            else if(a[i] == 't')
            {
                b[20]++;
            }
            else if(a[i] == 'u')
            {
                b[21]++;
            }
            else if(a[i] == 'v')
            {
                b[22]++;
            }
            else if(a[i] == 'w')
            {
                b[23]++;
            }
            else if(a[i] == 'x')
            {
                b[24]++;
            }
            else if(a[i] == 'y')
            {
                b[25]++;
            }
            else if(a[i] == 'z')
            {
                b[26]++;
            }
        }
        for(i = 1; i <= 26; i++)
        {
            printf("%c:%d\n", c[i-1], b[i]);
        }
        printf("\n");
    }
    return 0;
}


相关文章
|
7月前
|
传感器
AC31 40和50系列
AC31 40和50系列
AC31 40和50系列
|
算法 搜索推荐 数据挖掘
AB实验设计
AB实验的原理、优缺点及流程
1462 0
AB实验设计
|
6月前
|
传感器 网络架构
使用AC/DC电源模块的案例
使用AC/DC电源模块的案例
使用AC/DC电源模块的案例
|
6月前
|
安全 数据中心
AC/DC电源模块的多种应用需求使其成为一种重要的技术
AC/DC电源模块的多种应用需求使其成为一种重要的技术
AC/DC电源模块的多种应用需求使其成为一种重要的技术
|
7月前
探讨AC/DC电源模块的可靠性设计和测试方法
探讨AC/DC电源模块的可靠性设计和测试方法
探讨AC/DC电源模块的可靠性设计和测试方法
|
7月前
选择适合自己应用的AC/DC电源模块
选择适合自己应用的AC/DC电源模块
选择适合自己应用的AC/DC电源模块
|
7月前
|
监控 数据库
ABB AC800F SD802F电源模块
ABB AC800F SD802F电源模块
ABB AC800F SD802F电源模块
|
传感器 存储 编解码
51单片机--AD/DA
51单片机--AD/DA
326 0
|
人工智能
CF628B
CF628B
70 0