据说一个人的标准体重应该是其身高(单位:厘米)减去100、再乘以0.9所得到的公斤数。已知市斤的数值是公斤数值的两倍。现给定某人身高,请你计算其标准体重应该是多少?(顺便也悄悄给自己算一下吧……)
输入格式:
输入第一行给出一个正整数H
(100 < H ≤ 300),为某人身高。
输出格式:
在一行中输出对应的标准体重,单位为市斤,保留小数点后1位。
输入样例:
169
输出样例:
124.2
代码长度限制16 KB时间限制400 ms内存限制64 MB
#include <stdio.h>
// 通过身高计算标准体重
float cal_norm_weight_from_height(int height){
float weight = (height - 100)*0.9*2;
return weight;
}
int main(){
int height;
float weight;
if (scanf("%d",&height)==1 && height>100 && height<=300){
weight = cal_norm_weight_from_height(height);
printf("%.1f",weight);
}else{
printf("输入的身高数据存在错误");
}
return 0;
}