Maven问题:【不支持源选项5。请使用7或更高版本。】问题解决方案

简介: Maven问题:【不支持源选项5。请使用7或更高版本。】问题解决方案

一、问题

不支持源选项5。请使用7或更高版本。不支持目标选项5。请使用7或更高版本

[INFO] 
[INFO] --- maven-compiler-plugin:3.1:compile (default-compile) @ springmvc_03_request_mapping ---
[INFO] Changes detected - recompiling the module!
[WARNING] File encoding has not been set, using platform encoding UTF-8, i.e. build is platform dependent!
[INFO] Compiling 4 source files to E:\java\Javaganji\spring\02-springmvc\02-springmvc\day01\源码\springmvc\springmvc_03_request_mapping\target\classes
[INFO] -------------------------------------------------------------
[ERROR] COMPILATION ERROR : 
[INFO] -------------------------------------------------------------
[ERROR] 不再支持源选项 5。请使用 7 或更高版本。
[ERROR] 不再支持目标选项 5。请使用 7 或更高版本。
[INFO] 2 errors 
[INFO] -------------------------------------------------------------

二、问题原因

maven的setings.xml文件中默认是JDK1.4版本,需要加载更高版本的JDK才行。

c10d4159ca414606b8b7ce3c61680db4.png

三、解决方法

(1)暂时解决

在pom.xml文件中指定的jdk版本,运行另一个项目,需要在另一个项目的pom.xml文件中再配置一个,每换一个项目,都需要在pom.xml中配置一个,所以是暂时解决的。

<properties>
        <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
        <maven.compiler.encoding>UTF-8</maven.compiler.encoding>
        <java.version>1.8</java.version>
        <maven.compiler.source>1.8</maven.compiler.source>
        <maven.compiler.target>1.8</maven.compiler.target>
 </properties>

(2)永久解决

在maven配置文件settings.xml文件中在每次运行maven用指定的jdk版本


把下面的代码放到<profiles></profiles>标签的中间才能生效

<profile>  
     <id>jdk-1.8</id>  
     <activation>  
         <activeByDefault>true</activeByDefault>  
         <jdk>1.8</jdk>  
     </activation>
     <properties>
         <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
         <maven.compiler.source>1.8</maven.compiler.source>  
         <maven.compiler.target>1.8</maven.compiler.target>   
     </properties>   
</profile>
目录
相关文章
|
8天前
|
Java Maven
Maven 将询问原型的版本
在创建 Maven 项目时,选择 `maven-archetype-quickstart` 的 1.1 版本。配置包括 `groupId`(com.companyname.insurance)、`artifactId`(health)、`version`(1.0-SNAPSHOT)和 `package`(com.companyname.insurance)。用户确认设置后,Maven 创建项目结构,成功完成于 C:\MVN\health 目录,总耗时 4 分钟 12 秒。
|
10天前
|
Java Maven
Maven 将询问原型的版本
在创建项目时,Maven 提供了 `maven-archetype-quickstart` 的版本选择,用户选择了版本 1.1。接着,用户输入了项目详细信息,包括 `groupId` 为 `com.companyname.insurance`,`artifactId` 为 `health`,以及 `version` 为 `1.0-SNAPSHOT`,并确认了这些配置。然后,Maven 创建了项目结构,输出了相关参数和成功完成的信息,整个过程耗时4分12秒。
|
10天前
|
Java Maven
Maven 将询问原型的版本
Maven prompts for the version of `maven-archetype-quickstart`, defaulting to 1.1. It then asks for project details like `groupId`, `artifactId`, `version`, and `package`, accepting default values or custom inputs. Upon confirmation
|
10天前
|
Java Maven
Maven 将询问原型的版本
Maven 将询问项目细节。按要求输入项目细节。如果要使用默认值则直接按 Enter 键。
|
3天前
|
Java Maven
Maven 将询问原型的版本
Maven prompts for the version of `maven-archetype-quickstart`, defaulting to 1.1. It then requests details like `groupId`, `artifactId`, `version`, and `package`, with user input or default values accepted.
|
10天前
|
Java Maven
Maven 将询问原型的版本
在创建项目时,Maven 提示选择 `maven-archetype-quickstart` 的版本,用户选择了 6,即版本 1.1。接着,Maven 询问并设置了项目详细信息,包括 `groupId`、`artifactId`、`version` 和 `package`,用户输入了相应的值。用户确认这些配置后,Maven 开始生成项目结构,并在指定目录创建了项目。整个过程耗时4分钟12秒,构建成功。
|
10天前
|
存储 安全 Java
maven仓库的版本列举
这段代码是Java程序,用于分析本地Maven项目的依赖版本。它遍历指定路径下的文件,提取groupId和version信息,并存储到HashSet中。最终,这些信息被写入到一个Excel文档。主要类`test`包含一个静态内部类`Version`来封装groupId和version字段。通过递归方法`func`处理文件夹结构,获取Maven坐标信息。
22 3
|
7天前
|
Java Apache Maven
Maven 项目文档
在C:/MVN下,使用命令`mvn archetype:generate -DgroupId=com.companyname.bank -DartifactId=consumerBanking -DarchetypeArtifactId=maven-archetype-quickstart -DinteractiveMode=false`创建Maven Java项目。确保`pom.xml`包含`maven-site-plugin`和`maven-project-info-reports-plugin`配置,版本分别至少为3.3和2.7,以避免`NoClassDefFoundError`。
|
6天前
|
Java Maven
Maven 构建 Java 项目
使用 Maven 的 archetype:generate 命令创建 Java 项目,如 `mvn archetype:generate` -DgroupId=com.companyname.bank -DartifactId=consumerBanking -DarchetypeArtifactId=maven-archetype-quickstart -DinteractiveMode=false,在 C:\MVN 下生成基于 maven 的 consumerBanking 项目。
|
9天前
|
Java Maven
SpringBoot项目的用maven插件打包报Test错误
SpringBoot项目的用maven插件打包报Test错误

热门文章

最新文章

推荐镜像

更多