hdu1035 Robot Motion(简单模拟题)

简介: hdu1035 Robot Motion(简单模拟题)

Problem Description


A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are


N north (up the page)

S south (down the page)

E east (to the right on the page)

W west (to the left on the page)


For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid.


Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits.


You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around.

 

 

Input

There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number of columns in the grid, and the number of the column in which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions. The lines of instructions contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.

 

 

Output

For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions on a certain number of locations once, and then the instructions on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word "step" is always immediately followed by "(s)" whether or not the number before it is 1.

 

 

Sample Input

 

3 6 5 NEESWE WWWESS SNWWWW 4 5 1 SESWE EESNW NWEEN EWSEN 0 0

 

 

Sample Output

 

10 step(s) to exit 3 step(s) before a loop of 8 step(s)

 

 

Source

Mid-Central USA 1999

 

简单模拟一下走动就可以了

代码如下:

#include<stdio.h>
int main()
{
    int n,m,y;
    while(scanf("%d %d",&n,&m)!=EOF&&m&&n)
    {
        scanf("%d",&y);
        y--;
        int i,j,road[15][15],x=0,sum=0,flag=0;
        char map[15][15];
        for(i=0;i<n;i++)
        {
            scanf("%s",&map[i]);
            for(j=0;j<m;j++)
                road[i][j]=0;
        }
        while(x>=0&&y>=0&&x<n&&y<m)
        {
            if(road[x][y]!=0)
            {
                flag=1;
                break;
            }
            sum++;
            road[x][y]=sum;
            if(map[x][y]=='N')
                x--;
            else if(map[x][y]=='S')
                x++;
            else if(map[x][y]=='E')
                y++;
            else if(map[x][y]=='W')
                y--;
        }
        if(flag==1)
            printf("%d step(s) before a loop of %d step(s)\n",road[x][y]-1,sum-road[x][y]+1);
        else
            printf("%d step(s) to exit\n",sum);
    }
    return 0;
}
目录
相关文章
|
6月前
|
C++
HDU2319— Card Trick
HDU2319— Card Trick
|
机器人
HDU-1035,Robot Motion(DFS)
HDU-1035,Robot Motion(DFS)
|
人工智能 Java
[HDU 7136] Jumping Monkey | 并查集 | 逆向思维
Jumping Monkey Time Limit: 8000/4000 MS (Java/Others) Memory Limit: 262144/262144 K (Java/Others) Total Submission(s): 747 Accepted Submission(s): 360
221 0
[HDU 7136] Jumping Monkey | 并查集 | 逆向思维
|
机器人 定位技术
HDU-1035,Robot Motion(DFS+模拟)
HDU-1035,Robot Motion(DFS+模拟)
|
人工智能 BI
[UVA 1599] Ideal Path | 细节最短路
Description New labyrinth attraction is open in New Lostland amusement park. The labyrinth consists of n rooms connected by m passages. Each passage is colored into some color ci .
201 0
|
算法 机器人 定位技术
算法学习之路|hdu 1035 Robot Motion(模拟)
给一个地图,由ESWN(东南西北)组成,机器人根据脚下的指令移动,求如果机器人能走出地图,走的步数多少,如果不能走出,求每绕一圈的步数和绕圈之前走的步数。
1100 0