Fence Repair(小根堆模板)

简介: Fence Repair(小根堆模板)

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.


FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.


Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.


Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.


Input

Line 1: One integer  N, the number of planks

Lines 2.. N+1: Each line contains a single integer describing the length of a needed plank


Output

Line 1: One integer: the minimum amount of money he must spend to make  N-1 cuts


Sample Input

3

8

5

8


Sample Output

34


Hint

He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8.

The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).


题目大概意思就是要我们据木头然后花钱最少;


解题思路;我们先把最小的2个取出来加上,然后合并加进堆里面。然后循环的直到最后一个,就是答案。


听懂了记得给个赞鼓励一下,码字不易,用爱发电。


上ac代码。

f58230e9f063709cf3167704f4efdf14.gif


有事你就q我;QQ2917366383


学习算法

#include<iostream>
#include<string>
#include<string.h>
#include<vector>
#include<map>
#include<algorithm>
#include<queue>
using namespace std; 
int main()
{
  long long ans=0;
  priority_queue<int ,vector<int>,greater<int> >q; //小根堆 
  int t;
  cin>>t;
  for(int i=1;i<=t;i++)
  {
    int n;
    cin>>n;
    q.push(n);  
  }
while(q.size()>1)//如果堆里面只有一个就结束循环 
  {
    int r1,r2;
    r1=q.top();
    q.pop();
    r2=q.top();
    q.pop();
    ans+=(r1+r2);//先加小的 
    q.push(r1+r2);//把小的加上然后加入堆里面 
  }
  cout<<ans<<endl;
}
相关文章
|
C++ Python 容器
C++中pair用法
⭐pair的简介 pair是C++STL(标准模板库)中的一个现有容器,它将2个数据整合成一组数据,当我们类似需求的时候就可以使用到pair啦!pair其实有点像Python中字典中的键值对(Key-Value),一个Key对应着一个Value。pair的本质其实就是个结构体,它含有两个成员变量first和second。因为使用的是struct不是class,所以在定义后是可以直接使用pair中的成员变量的。 其标准库类型–pair类型定义在#include< utility > 头文件中
438 0
|
数据安全/隐私保护
CE修改器入门:查找多级指针
本关是第6关的加强版,CE 6.X 教程中的4级指针比5.X的要简单些。多级指针就像玩解谜游戏一样,谜团不只一个,盒子中还有盒子。这里面是4级指针,游戏中也有比如8级指针,12级指针等等,思路都是一样的。
682 0
CE修改器入门:查找多级指针
|
编译器 C++ 容器
STL—pair
pair是一个特别实用的“小玩意儿”,当我们想把两个元素捆绑在一起当成一个元素的时候,又不想定义结构体的时候,这个时候就可以使用pair,也就是说,pair实际上可以当成内部只有两个元素的结构体,且这两个元素的类型是可以指定的.
151 0
|
机器学习/深度学习

热门文章

最新文章