1249:Lake Counting 2021-01-05

简介: 1249:Lake Counting 2021-01-05

1249:Lake Counting

时间限制: 1000 ms         内存限制: 65536 KB

【题目描述】

题意:有一块N×M的土地,雨后积起了水,有水标记为‘W’,干燥为‘.’。八连通的积水被认为是连接在一起的。请求出院子里共有多少水洼?

【输入】

第一行为N,M(1≤N,M≤110)。

下面为N*M的土地示意图。

【输出】

一行,共有的水洼数。

【输入样例】

10 12

W........WW.

.WWW.....WWW

....WW...WW.

.........WW.

.........W..

..W......W..

.W.W.....WW.

W.W.W.....W.

.W.W......W.

..W.......W.

【输出样例】

3

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int x[8]={-1,-1,-1,0,1,1,1,0};
int y[8]={-1,0,1,1,1,0,-1,-1};
int n,m,td[112][112],que[1100][4];
int tj=0;
void bfs(int a,int b){
  tj++;
  int x1,y1,to=0,w=1;
  memset(que,0,sizeof(que));
  que[1][1]=a,que[1][2]=b,que[1][3]=0;td[a][b]=0;
  do{
    to++;
    for(int k=0;k<8;k++){
      x1=que[to][1]+x[k];
      y1=que[to][2]+y[k];
      if(x1>0&&x1<=n&&y1>0&&y1<=m&&td[x1][y1]==1){
        w++;
        que[w][1]=x1;que[w][2]=y1;que[w][3]=que[to][3]+1;
        td[x1][y1]=0;
      }
    }
  }while(w>to);
}
int main(int argc, char *argv[])
{
  scanf("%d %d",&n,&m);
  char t;
  for(int i=1;i<=n;i++)
    for(int j=1;j<=m;j++){
      cin>>t;
      if(t=='W')td[i][j]=1;
      else td[i][j]=0;
    }
  for(int i=1;i<=n;i++)
    for(int j=1;j<=m;j++){
      if(td[i][j]==1) bfs(i,j);
    }
  printf("%d\n",tj);
  return 0;
}

 

相关文章
|
流计算
Delta Lake中CDC的实现
Delta Lake中CDC的实现
154 0
《Intel Data Direct IO (Intel DDIO)Frequently Asked Questions》电子版地址
Intel Data Direct I/O (Intel DDIO):Frequently Asked Questions
99 0
《Intel Data Direct IO (Intel DDIO)Frequently Asked Questions》电子版地址
|
机器学习/深度学习 数据采集 人工智能
Re10:读论文 Are we really making much progress? Revisiting, benchmarking, and refining heterogeneous gr
Re10:读论文 Are we really making much progress? Revisiting, benchmarking, and refining heterogeneous gr
Re10:读论文 Are we really making much progress? Revisiting, benchmarking, and refining heterogeneous gr
《Next Generation of Intel XEON® Processor Hero Features Review》电子版地址
Next Generation of Intel XEON® Processor Hero Features Review
78 0
《Next Generation of Intel XEON® Processor Hero Features Review》电子版地址
|
C++
Leetcode-Medium 338. Counting Bits
Leetcode-Medium 338. Counting Bits
96 0
|
SQL 移动开发 算法
New Dynamic Programming Algorithm for the Generation of Optimal Bushy Join Trees
MySQL无疑是现在开源关系型数据库系统的霸主,在DBEngine的最新排名中仍然稳居第2位,与第3位SQL Server的积分差距并不算小,可以说是最受欢迎,使用度最高的数据库系统,这一点看看有多少新型数据库要兼容MySQL的协议和语法就知道了。
327 0
New Dynamic Programming Algorithm for the Generation of Optimal Bushy Join Trees
|
存储 SQL 分布式计算
Delta Lake,让你从复杂的Lambda架构中解放出来
Linux 基金会的 Delta Lake(Delta.io)是一个给数据湖提供可靠性的开源存储层软件。在 QCon 全球软件开发大会(上海站)2019 的演讲中,Databricks 公司的 Engineering Manager 李潇带我们了解了 Delta Lake 在实际生产中的应用与实践以及未来项目规划,本文便整理自此次演讲。
Delta Lake,让你从复杂的Lambda架构中解放出来
|
SQL 消息中间件 JSON
Delta Lake在Soul的应用实践
传统离线数仓模式下,日志入库前首要阶段便是ETL,我们面临如下问题:天级ETL任务耗时久,影响下游依赖的产出时间;凌晨占用资源庞大,任务高峰期抢占大量集群资源;ETL任务稳定性不佳且出错需凌晨解决、影响范围大。为了解决天级ETL逐渐尖锐的问题,所以这次我们选择了近来逐渐进入大家视野的数据湖架构,基于阿里云EMR的Delta Lake,我们进一步打造优化实时数仓结构,提升部分业务指标实时性,满足更多更实时的业务需求。
Delta Lake在Soul的应用实践
|
SQL 分布式计算 大数据
Delta Lake Presto Integration & Manifests 机制
Delta 0.5 已于上周发布,增加了不少新特性,这篇文章主要讲解其 Presto Integration 和 Manifests 机制。
Delta Lake Presto Integration & Manifests 机制
|
存储 SQL 数据采集
深入剖析 Delta Lake:Schema Enforcement & Evolution
Schema 约束和 Schema 演变相互补益,合理地结合起来使用将能方便地管理好数据,避免脏数据侵染,保证数据的完整可靠。
深入剖析 Delta Lake:Schema Enforcement & Evolution