【PAT甲级 - C++题解】1045 Favorite Color Stripe

简介: 【PAT甲级 - C++题解】1045 Favorite Color Stripe

1045 Favorite Color Stripe

Eva is trying to make her own color stripe out of a given one. She would like to keep only her favorite colors in her favorite order by cutting off those unwanted pieces and sewing the remaining parts together to form her favorite color stripe.


It is said that a normal human eye can distinguish about less than 200 different colors, so Eva’s favorite colors are limited. However the original stripe could be very long, and Eva would like to have the remaining favorite stripe with the maximum length. So she needs your help to find her the best result.


Note that the solution might not be unique, but you only have to tell her the maximum length. For example, given a stripe of colors {2 2 4 1 5 5 6 3 1 1 5 6}. If Eva’s favorite colors are given in her favorite order as {2 3 1 5 6}, then she has 4 possible best solutions {2 2 1 1 1 5 6}, {2 2 1 5 5 5 6}, {2 2 1 5 5 6 6}, and {2 2 3 1 1 5 6}.


Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤200) which is the total number of colors involved (and hence the colors are numbered from 1 to N). Then the next line starts with a positive integer M (≤200) followed by M Eva’s favorite color numbers given in her favorite order. Finally the third line starts with a positive integer L (≤104) which is the length of the given stripe, followed by L colors on the stripe. All the numbers in a line a separated by a space.


Output Specification:

For each test case, simply print in a line the maximum length of Eva’s favorite stripe.


Sample Input:

6
5 2 3 1 5 6
12 2 2 4 1 5 5 6 3 1 1 5 6

Sample Output:

7


题意

这道题就是最长公共子序列的变种题,给定 ab 两个字符串,找到 ab 中出现长度最长的子串,注意 a 中的字符是可以在 b 中重复出现的。


思路

状态表示: f [ i ] [ j ] f[i][j]f[i][j] 表示 p[1~i] 与 s[1~j] 的所有公共子序列的集合中长度的最大值。


状态计算:


先从上一步转移过来:f [ i ] [ j ] = m a x ( f [ i − 1 ] [ j ] , f [ i ] [ j − 1 ] ) f[i][j] = max(f[i - 1][j], f[i][j - 1])f[i][j]=max(f[i−1][j],f[i][j−1])


如果 s 中当前字符与 p 中当前字符匹配:f [ i ] [ j ] = m a x ( f [ i ] [ j ] , f [ i ] [ j − 1 ] + 1 ) f[i][j] = max(f[i][j], f[i][j - 1] + 1)f[i][j]=max(f[i][j],f[i][j−1]+1)


这道题和原来的最长公共子序列不同之处在于后面这个更新,是 f [ i − 1 ] [ j − 1 ] + 1 f[i-1][j-1]+1f[i−1][j−1]+1 ,但是这里因为 p 中的字符可以重复出现,所以就是 f [ i ] [ j − 1 ] + 1 f[i][j-1]+1f[i][j−1]+1 。


代码

#include<bits/stdc++.h>
using namespace std;
const int N = 210, M = 10010;
int n, m, l;
int p[N], s[M], f[N][M];
int main()
{
    cin >> n >> m;
    for (int i = 1; i <= m; i++)   cin >> p[i];
    cin >> l;
    for (int i = 1; i <= l; i++)   cin >> s[i];
    for (int i = 1; i <= m; i++)
        for (int j = 1; j <= l; j++)
        {
            f[i][j] = max(f[i - 1][j], f[i][j - 1]);
            if (p[i] == s[j])  f[i][j] = max(f[i][j], f[i][j - 1] + 1);
        }
    cout << f[m][l] << endl;
    return 0;
}
目录
相关文章
|
C++
【PAT甲级 - C++题解】1040 Longest Symmetric String
【PAT甲级 - C++题解】1040 Longest Symmetric String
66 0
|
算法 C++
【PAT甲级 - C++题解】1044 Shopping in Mars
【PAT甲级 - C++题解】1044 Shopping in Mars
82 0
|
C++
【PAT甲级 - C++题解】1117 Eddington Number
【PAT甲级 - C++题解】1117 Eddington Number
77 0
|
存储 C++ 容器
【PAT甲级 - C++题解】1057 Stack
【PAT甲级 - C++题解】1057 Stack
76 0
|
存储 C++
【PAT甲级 - C++题解】1055 The World‘s Richest
【PAT甲级 - C++题解】1055 The World‘s Richest
79 0
|
C++
【PAT甲级 - C++题解】1051 Pop Sequence
【PAT甲级 - C++题解】1051 Pop Sequence
80 0
|
6天前
|
存储 编译器 C++
【c++】类和对象(下)(取地址运算符重载、深究构造函数、类型转换、static修饰成员、友元、内部类、匿名对象)
本文介绍了C++中类和对象的高级特性,包括取地址运算符重载、构造函数的初始化列表、类型转换、static修饰成员、友元、内部类及匿名对象等内容。文章详细解释了每个概念的使用方法和注意事项,帮助读者深入了解C++面向对象编程的核心机制。
30 5
|
13天前
|
存储 编译器 C++
【c++】类和对象(中)(构造函数、析构函数、拷贝构造、赋值重载)
本文深入探讨了C++类的默认成员函数,包括构造函数、析构函数、拷贝构造函数和赋值重载。构造函数用于对象的初始化,析构函数用于对象销毁时的资源清理,拷贝构造函数用于对象的拷贝,赋值重载用于已存在对象的赋值。文章详细介绍了每个函数的特点、使用方法及注意事项,并提供了代码示例。这些默认成员函数确保了资源的正确管理和对象状态的维护。
41 4
|
14天前
|
存储 编译器 Linux
【c++】类和对象(上)(类的定义格式、访问限定符、类域、类的实例化、对象的内存大小、this指针)
本文介绍了C++中的类和对象,包括类的概念、定义格式、访问限定符、类域、对象的创建及内存大小、以及this指针。通过示例代码详细解释了类的定义、成员函数和成员变量的作用,以及如何使用访问限定符控制成员的访问权限。此外,还讨论了对象的内存分配规则和this指针的使用场景,帮助读者深入理解面向对象编程的核心概念。
40 4
|
1月前
|
存储 编译器 对象存储
【C++打怪之路Lv5】-- 类和对象(下)
【C++打怪之路Lv5】-- 类和对象(下)
28 4